NCTAudioEditor2Lib

NCTAudioEditor2 ActiveX DLL
Version 2.1

Version 2.1

NCTAudioEditor2 ActiveX DLL is a visual audio files editor. It can be used to build applications, which allow the end-user to perform various operations with audio data such as displaying a waveform image of an audio file, filtering, applying various audio effects, examining the frequency components and other details about your audio with the Frequency Analysis, Statistics, and Spectral View features, format conversion and etc.

With NCTAudioEditor2 ActiveX DLL you can:

  • Open (Open), create (New) and save (Save) audio files;

  • Display in a special window waveform of an audio file (ZoomFull, ZoomIn, ZoomOut, ZoomVertical);

  • Play an audio file or any part of it (Play, Pause, Stop);

  • Record an audio file from a microphone or from another input device (Record, Recorder, RecordVisualizationType);

  • Get or set parameters of the recording (AccuAttackLevel, AccuAttackTime, AccuEnabled, AccuReleaseLevel, AccuReleaseTime, HighPassFilterEnabled, HighPassFilterFrequency, LowPassFilterEnabled, LowPassFilterFrequency, NotchFilterEnabled, NotchFilterFrequency);

  • Edit an audio file visually (Cut, Copy, DeleteSelect, DeleteSilence, Paste, PasteFromFile, Mix, MixFromFile);

  • Apply different effects (Amplify, Compressor, Delay, Envelope, Equalizer, Expander, Fade, Flanger, Invert, Normalize, Phaser, Reverb, Reverse, Silence, Stretch, Trim, Vibrato);

  • Apply different filters to the selected part of an audio file (BandPassFilter, FFTFilter, HighPassFilter, HighShelfFilter, LowPassFilter, LowShelfFilter, NotchFilter);

  • Insert in an audio file noise (AddNoise) and silence (InsertSilence);

  • Convert an audio file from one format to another (SetFommatADPCM, SetFommatALAW, SetFommatALF2CD, SetFommatDSP, SetFommatFromMenu, SetFormatG721, SetFormatG723, SetFommatG726, SetFommatGSM, SetFommatLikeSample, SetFormatMP2, SetFommatMP3, SetFommatOggVorbis, SetFommatPCM, SetFommatRAW, SetFommatULAW, SetFommatVOX, SetFommatWMA);

  • Insert and change described information about a marker (Count, Country, Dialect, Label, Language, Length, Note, Num, Position, Text);

  • Insert and change described information about an audio file (Album, Artist, Channels, Comments, Composer, Copyright, EncodedBy, FormatString, Frequency, Genre, GenreToString, Mp3TagInfoVersion, SaveExtraInfoEnabled, Title, Track, URL, Year).

The following audio formats are supported:

  • WAV PCM;

  • compressed WAV (ADPCM, GSM, DSP, A-LAW, U-LAW, ALF2 and others);

  • MP2;

  • MP3 (MPEG Layer-3);

  • VOX (Dialogic ADPCM);

  • WMA (Windows Media Audio);

  • RAW (PCM, A-LAW, U-LAW);

  • CDA (Audio CD Tracks);

  • OGG (Ogg Vorbis):

  • G.721, G.723, G.726.

The NCTAudioEditor2 includes the following objects:

  • AudioEditor2 - the main interface, which is intended for visual editing of an audio file and control all other interfaces;

  • AudioEditor2Device - the control of audio devices in your system;

  • AudioEditor2Scale - the control of the type and the appearance of scales in the displaying window;

  • AudioEditor2Colors - the control of colors of objects in the displaying window;

  • AudioEditor2FileInfo - the control of information about an audio file;

  • AudioEditor2DeviceLine - the control of input and output lines for the current audio device;

  • AudioEditor2Position - the control of positions in an audio file;

  • AudioEditor2Channel - the control of channels parameters in the audio file;

  • AudioEditor2Markers - the control of markers parameters in the audio file;

  • AudioEditor2Recorder - the control of recording parameters;

  • AudioEditor2Transform - the control of transformation parameters;

  • AudioEditor2FileFormat - the control of format of the audio file.

You can use the NCTAudioEditor2 ActiveX DLL in your program, written on the language, which supports ActiveX automation.

The NCTAudioEditor2 was tested with:

  • MS Visual Basic 6.0 (SP5);

  • MS Visual C++ 6.0 (SP5);

  • Borland C++ Builder 5.0.

under Windows 98/Me/NT/2000/XP

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT Company Ltd. http://www.nctsoft.com


NCTAudioEditor2 objects

NCTAudioEditor2 objects

Objects | Description
AudioEditor2 | The main interface, which is intended for visual editing of audio files and control all other interfaces.
AudioEditor2Channel | Controls channels parameters in an audio file.
AudioEditor2Colors | Controls colors of objects in the displaying window.
AudioEditor2Device | Controls audio devices in your system.
AudioEditor2DeviceLine | Controls input and output lines for the current audio device.
AudioEditor2FileFormat | Controls audio file format. With AudioEditor2FileFormat you can set format of input file to the selected audio file format.
AudioEditor2FileInfo | Controls information about an audio file.
AudioEditor2LameEnc | The AudioEditor2LameEnc object is intended for changing parameters of lame mp3 encoder.
AudioEditor2Markers | Described information about a marker.
AudioEditor2Position | Controls positions in an audio file.
AudioEditor2Recorder | Allows to get or set recording parameters.
AudioEditor2Scale | Controls the type and the appearance of scales in the displaying window.
AudioEditor2Transform | AudioEditor2Transform object is intended for processing and transforming of audio data.


AudioEditor2

AudioEditor2 object

The main interface, which is intended for visual editing of audio files and control all other interfaces.


AudioEditor2 Properties

Properties (AudioEditor2 object)

Property | Type | Default | Description
Channels | AudioEditor2Channel |  | Read-only property that returns a pointer to the AudioEditor2Channel object, for a control of channels in an audio file.
Colors | AudioEditor2Colors |  | Read-only property that returns a pointer to the AudioEditor2Colors object, for controlling of colors.
DeviceInput | AudioEditor2Device |  | Read-only property that returns a pointer to the AudioEditor2Device object, which controls an input device.
DeviceOutput | AudioEditor2Device |  | Read-only property that returns a pointer to the AudioEditor2Device object, which controls an input device.
FileBufferSize | Long | 10 000 ms | Gets or sets size of a buffer.
FileFormat | AudioEditor2FileFormat |  | Read-only property that returns a pointer to the AudioEditor2FileFormat object, for the control of a format of an audio file.
FileInfo | AudioEditor2FileInfo |  | Read-only property that returns a pointer to the AudioEditor2FileInfo object, for a control of information, contained in an audio file.
LastErrorNum | ErrorConstants |  | Read-only property that returns the number of the last error.
MarkerBackgroundEnabled | Boolean |  | Gets or sets a flag indicating if the background between selected marker bars is to be drawn or not.
MarkerBarEnabled | Boolean |  | Gets or sets a flag indicating if the dotted lines of marker are to be drawn or not.
Markers | AudioEditor2Markers |  | Read-only property that returns a pointer to the AudioEditor2Markers object, for controlling of marker parameters.
MouseCustom | String |  | Gets or sets the custom image for the mouse pointer.
MouseEventsEnabled | Boolean | True | Gets or sets a flag indicating if following events are worked or not: MouseDown, MouseMove, MouseUp.
MousePointer | MousePointerConstants |  | Gets or sets the type of the mouse pointer.
Mp3LameEncoder | AudioEditor2LameEnc |  | Read-only property that returns a pointer to AudioEditor2LameEnc object which used for changing parameters of lame mp3 encoder.
Mp3TypeDecoder | Mp3DecoderConstants |  | Gets or sets a type of mp3 decoder.
Mp3TypeEncoder | Mp3EncoderConstants |  | Gets or sets a type of mp3 encoder.
Position | AudioEditor2Position |  | Read-only property that returns a pointer to the AudioEditor2Position object, for the control of a position in an audio file.
Recorder | AudioEditor2Recorder |  | Read-only property that returns a pointer to AudioEditor2Recorder object which used for changing parameters of recording.
RecordVisualizationType | Integer |  | Gets or sets a visualization type during record.
RedoEnabled | Boolean |  | Read-only property that returns a flag indicating if the Redo method is enabled or not.
ScaleX | AudioEditor2Scale |  | Gets or sets a pointer to the AudioEditor2Scale object, to control parameters of the horizontal scale in a waveform window.
ScaleY | AudioEditor2Scale |  | Gets or sets a pointer to the AudioEditor2Scale object, to control parameters of the vertical scale in a waveform window.
Status | Integer |  | Read-only property that returns the status of the AudioEditor2.
TempDirectory | String |  | Gets or sets the location for keeping temporary files.
TempFileName | String |  | Gets or sets name for a temporary file.
Transform | AudioEditor2Transform |  | Read-only property that returns a pointer to the AudioEditor2Transform object, for the control of a transformation of an audio file.
TypeBorder | Integer |  | Gets or sets the type of a border.
TypeView | TypeViewConstants | WAVEFORM | Gets or sets a type of audio data visualization.
UndoEnabled | Boolean |  | Read-only property that returns a flag indicating if the Undo method can be applied or not.
UndoRedoCount | Long | 1000 | Gets or sets the maximum amount of operations, which can be reversed or restored by the Undo and Redo methods.


Channels property (AudioEditor2)

Channels property (AudioEditor2)

Read-only property that returns a pointer to the AudioEditor2Channel object, for a control of channels in an audio file.

Property type

A AudioEditor2Channel value.

Syntax

[value = ]object.Channels

The Channels property syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | AudioEditor2Channel | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Channels.Num = 1
Editor1.Channels.Visible = True
Editor1.Channels.Num = 2
Editor1.Channels.Visible = True

See Also:

Apples To: AudioEditor2


Colors property (AudioEditor2)

Colors property (AudioEditor2)

Read-only property that returns a pointer to the AudioEditor2Colors object, for controlling of colors.

Property type

An AudioEditor2Colors value.

Syntax

[value = ]object.Colors

The Colors property syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | AudioEditor2Colors | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)

See Also:

Apples To: AudioEditor2


DeviceInput property (AudioEditor2)

DeviceInput property (AudioEditor2)

Read-only property that returns a pointer to the AudioEditor2Device object, which controls an input device.

Property type

An AudioEditor2Device value.

Syntax

[value = ]object.DeviceInput

The DeviceInput property syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | AudioEditor2Device | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub SetSrcInput()
    cmbSrcInput.Clear
    If Editor1.DeviceInput.DeviceLines.Count < 0 Then Exit Sub
    kSrcInput = Editor1.DeviceInput.DeviceLines.Num
    For i = 0 To Editor1.DeviceInput.DeviceLines.Count
        Editor1.DeviceInput.DeviceLines.Num = i
        cmbSrcInput.AddItem Editor1.DeviceInput.DeviceLines.Name
        If Editor1.DeviceInput.DeviceLines.Select Then kSrcInput = i
    Next
    Editor1.DeviceInput.DeviceLines.Num = kSrcInput
    cmbSrcInput.ListIndex = kSrcInput
End Sub

See Also:

Apples To: AudioEditor2


DeviceOutput property (AudioEditor2)

DeviceOutput property (AudioEditor2)

Read-only property that returns a pointer to the AudioEditor2Device object, which controls an input device.

Property type

An AudioEditor2Device value.

Syntax

[value = ]object.DeviceOutput

The DeviceOutput property syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | AudioEditor2Device | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub SetSrcOutput()
    cmbSrcOutput.Clear
    If Editor1.DeviceOutput.DeviceLines.Count < 0 Then Exit Sub
    kSrcOutput = Editor1.DeviceOutput.DeviceLines.Num
    For i = 0 To Editor1.DeviceOutput.DeviceLines.Count
        Editor1.DeviceOutput.DeviceLines.Num = i
        cmbSrcOutput.AddItem Editor1.DeviceOutput.DeviceLines.Name
    Next
    Editor1.DeviceOutput.DeviceLines.Num = kSrcInput
    cmbSrcOutput.ListIndex = kSrcInput
End Sub

See Also:

Apples To: AudioEditor2


FileBufferSize property (AudioEditor2)

FileBufferSize property (AudioEditor2 object)

Gets or sets size of a buffer.

Property type

A Long value.

Syntax

object.FileBufferSize [= value]

The FileBufferSize property syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | Long | The buffer size in ms. Varies from 100 to 60 000. By default is set to 10 000 ms.

Remarks:

It is the buffer for following operation with an audio file: Copy, Cut, Paste, Mix. The computers of modern release can work with maximum value of FileBufferSize, but old releases require lesser value usually.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.FileBufferSize = 20000
Editor1.Copy
Editor1.Position.StartSelect = 10
Editor1.Position.EndSelect = Editor1.Position.TotalSamples - 10
Editor1.Paste
Editor1.Save OutputFile, False
AudioEditor2e1.Close

See Also:

Apples To: AudioEditor2

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


FileFormat property (AudioEditor2)

FileFormat property (AudioEditor2 object)

Read-only property that returns a pointer to the AudioEditor2FileFormat object, for the control of a format of an audio file.

Property type

An AudioEditor2FileFormat value.

Syntax

object.FileFormat [= value]

The FileFormat property syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | AudioEditor2FileFormat | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = FileFormat1.Position.TotalSamples
Editor1.Transform.Invert
If Editor1.FileFormat.IsFormatMpegAvailable(FQ_44_KHZ, BR_32_KBPS, STEREO) = True Then 'MP3
Editor1.FileFormat.SetFormatMP3 FQ_44_KHZ, BR_32_KBPS, STEREO
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Applies to: AudioEditor2

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


FileInfo property (AudioEditor2)

FileInfo property (AudioEditor2)

Read-only property that returns a pointer to the AudioEditor2FileInfo object, for a control of information, contained in an audio file.

Property type

An AudioEditor2FileInfo value.

Syntax

[value = ]object.FileInfo

The FileInfo property syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | AudioEditor2FileInfo | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.BandPassFilter Editor1.FileInfo.Frequency / 100, 100
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Apples To: AudioEditor2


LastErrorNum property (AudioEditor2)

LastErrorNum property (AudioEditor2)

Read-only property that returns the number of the last error.

Property type

An ErrorConstants value.

Syntax

[value = ]object.LastErrorNum

The LastErrorNum property syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | ErrorConstants | The number of the last error.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
MsgBox "Last error: " & Editor1.LastErrorNum

See Also:

Apples To: AudioEditor2


MarkerBackgroundEnabled property (AudioEditor2)

MarkerBackgroundEnabled property (AudioEditor2)

Gets or sets a flag indicating if the background between selected marker bars is to be drawn or not.

Property type

A Boolean value.

Syntax

object.MarkerBackgroundEnabled [= value]

The MarkerBackgroundEnabled property syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | Boolean | Can be True (drawn) or False (not drawn).

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Markers As AudioEditor2Markers
Dim Position As AudioEditor2Position
Editor1.Open InputFile, WAV
Position.Selected = True
Position.StartSelect = 0
Position.EndSelect = Position.TotalSamples
Editor1.MarkerBackgroundEnabled = True
Editor1.MarkerBarEnabled = True
Editor1.Markers.Insert Editor1.Position.StartSelect, Editor1.Position.EndSelect - Editor1.Position.StartSelect, "Marker " & Str(Cue.ListItems.Count + 1)
Editor1.Close

See Also:

Apples To: AudioEditor2


MarkerBarEnabled property (AudioEditor2)

MarkerBarEnabled property (AudioEditor2)

Gets or sets a flag indicating if the dotted lines of marker are to be drawn or not.

Property type

A Boolean value.

Syntax

object.MarkerBarEnabled [= value]

The MarkerBarEnabled property syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | Boolean | Can be True (drawn) or False (not drawn).

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Markers As AudioEditor2Markers
Dim Position As AudioEditor2Position
Editor1.Open InputFile, WAV
Position.Selected = True
Position.StartSelect = 0
Position.EndSelect = Position.TotalSamples
Editor1.MarkerBackgroundEnabled = True
Editor1.MarkerBarEnabled = True
Markers.Insert Position.StartSelect, Position.EndSelect - Position.StartSelect, "Marker " & Str(Cue.ListItems.Count + 1)
Editor1.Close

See Also:

Apples To: AudioEditor2


Markers property (AudioEditor2)

Markers property (AudioEditor2)

Read-only property that returns a pointer to the AudioEditor2Markers object, for controlling of marker parameters.

Property type

A AudioEditor2Markers value.

Syntax

[value = ]object.Markers

The Markers property syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | AudioEditor2Markers | An object with different marker parameters.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Editor1_MarkerClick(ByVal Num As Long)
    Editor1.Markers.Num = Num
    Editor1.Position.GoToMarker Num
End Sub

See Also:

Apples To: AudioEditor2


MouseCustom property (AudioEditor2)

MouseCustom property (AudioEditor2)

Gets or sets the custom image for the mouse pointer.

Property type

A String value.

Syntax

object.MouseCustom [= value]

The MouseCustom property syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | String | The pathname to the custom image file.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.MouseCustom = "C:\image.jpg"

See Also:

Apples To: AudioEditor2


MouseEventsEnabled property (AudioEditor2)

MouseEventsEnabled property (AudioEditor2 object)

Gets or sets a flag indicating if following events are worked or not: MouseDown, MouseMove, MouseUp.

Property type

A Boolean value.

Syntax

object.MouseEventsEnabled [= value]

The MouseEventsEnabled property syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | Boolean | True if events are worked, otherwise - False. By default is set to True.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
If Editor1.Status = 4 Then
Editor1.MousePointer = vbHourglass
Editor1.MouseEventsEnabled = False
EndIf

See Also:

Apples To: AudioEditor2

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


MousePointer property (AudioEditor2)

MousePointer property (AudioEditor2)

Gets or sets the type of the mouse pointer.

Property type

A MousePointerConstants value.

Syntax

object.MousePointer [= value]

The MousePointer property syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | MousePointerConstants | The mouse pointer.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
If Editor1.Status = 4 Then
Editor1.MousePointer = vbHourglass
EndIf

See Also:

Apples To: AudioEditor2


Position property (AudioEditor2)

Position property (AudioEditor2)

Read-only property that returns a pointer to the AudioEditor2Position object, for the control of a position in an audio file.

Property type

An AudioEditor2Position value.

Syntax

[value = ] object.Position

The Position property syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | AudioEditor2Position | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile, WAV
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Position.TotalSamples
Editor1.MarkerBackgroundEnabled = True
Editor1.MarkerBarEnabled = True
Editor1.Markers.Insert Editor1.Position.StartSelect, Editor1.Position.EndSelect - Editor1.Position.StartSelect, "Marker " & Str(Cue.ListItems.Count + 1)
Editor1.Close

See Also:

Apples To: AudioEditor2


Recorder property (AudioEditor2)

Recorder property (AudioEditor2)

Read-only property that returns a pointer to AudioEditor2Recorder object which used for changing parameters of recording.

Property type

A AudioEditor2Recorder value.

Syntax

[value = ]object.Recorder

The Recorder property syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object of type .
value | AudioEditor2Recorder | An expression evaluating to an object of type .

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.AccuEnabled = True
Editor1.Recorder.AGCEnabled = False
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Apples To: AudioEditor2


RecordVisualizationType property (AudioEditor2)

RecordVisualizationType property (AudioEditor2)

Gets or sets a visualization type during record.

Property type

A Integer value.

Syntax

object.RecordVisualizationType [= value]

The RecordVisualizationType property syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | Integer | Type of a visualization. Can be 1 (recorded data isn't show during record) or 2 (recorded data show during record).

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.AccuEnabled = True
Editor1.Recorder.AGCEnabled = False
Editor1.RecordVisualizationType = 2
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Apples To: AudioEditor2


RedoEnabled property (AudioEditor2)

RedoEnabled property (AudioEditor2)

Read-only property that returns a flag indicating if the Redo method is enabled or not.

Property type

A Boolean value.

Syntax

[value = ]object.RedoEnabled

The RedoEnabled property syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | Boolean | Is True if the Redo method is enabled, otherwise -False.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.UndoEnabled = True
Editor1.RedoEnabled = True
Editor1.UndoRedoCount = 4
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Phaser 120, 30, 50
Editor1.Undo
...
Editor1.Redo
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Redo | Undo | UndoEnabled

Apples To: AudioEditor2


ScaleX property (AudioEditor2)

ScaleX property (AudioEditor2)

Gets or sets a pointer to the AudioEditor2Scale object, to control parameters of the horizontal scale in a waveform window.

Property type

An AudioEditor2Scale value.

Syntax

object.ScaleX [= value]

The ScaleX property syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | AudioEditor2Scale | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.ScaleX.Visible = False
Editor1.ScaleY.Visible = False
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Reverse
Editor1.Save OutputFile, False
Editor1.Close

See Also:

ScaleY

Apples To: AudioEditor2


ScaleY property (AudioEditor2)

ScaleY property (AudioEditor2)

Gets or sets a pointer to the AudioEditor2Scale object, to control parameters of the vertical scale in a waveform window.

Property type

An AudioEditor2Scale value.

Syntax

object.ScaleY[= value]

The ScaleY property syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | AudioEditor2Scale | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.ScaleX.Visible = False
Editor1.ScaleY.Visible = False
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Reverse
Editor1.Save OutputFile, False
Editor1.Close

See Also:

ScaleX

Apples To: AudioEditor2


Status property (AudioEditor2)

Status property (AudioEditor2)

Read-only property that returns the status of the AudioEditor2.

Property type

An Integer value.

Syntax

[value = ]object.Status

The Status property syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | Integer | Status type.

Remarks:

An operation meant execution one of the following methods:

Value | Description
0 | "No Operation"
1 | "Play"
2 | "Record"
3 | "Load"
4 | "Save"
5 | "Pause"
6 | "Copy"
7 | "Reset Waveform"
10 | " Invert "
11 | " Reverse "
12 | "Normalize"
13 | "Silence"
14 | " Stretch "
15 | "Trim"
16 | " DeleteSilence "
17 | "DeleteSelect"
18 | "InsertSilence"
19 | "Paste Mix"
20 | "Paste"
21 | "ConvertSampleType"
30 | " Delay "
31 | "Phaser"
32 | " Flanger "
33 | "Reverb"
40 | " FFTFilter "
41 | " LowPassFilter "
42 | " BandPassFilter "
43 | " HighPassFilter "
44 | " NotchFilter "
45 | " LowShelfFilter "
46 | " HighShelfFilter "
47 | "PeakEQFilter"
50 | " Amplify "
51 | " Fade "
52 | " Vibrato "
53 | "AddNoise"
54 | "Advanced Mix"
56 | "MixStereoChannels"
57 | "Envelope"
58 | "Expander"
60 | " Equalizer "

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim i As Integer
For i = 41 To 47
If Editor1.Status = i Then
MsgBox "Applying filter"
EndIf
Next i

See Also:

Apples To: AudioEditor2


TempDirectory property (AudioEditor2)

TempDirectory property (AudioEditor2)

Gets or sets the location for keeping temporary files.

Property type

A String value.

Syntax

object.TempDirectory [= value]

The TempDirectory property syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | String | The pathname of a temporary folder.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.TempDirectory = "C:\Temp"
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Stretch 88
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Apples To: AudioEditor2


TempFileName property (AudioEditor2)

TempFileName property (AudioEditor2)

Gets or sets name for a temporary file.

Property type

A String value.

Syntax

object.TempFileName [= value]

The TempFileName property syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | String | A temporary file's name.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.TempDirectory = "C:\Temp"
Editor1.TempDFileName = "tempfile"
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Stretch 88
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Apples To: AudioEditor2


Transform property (AudioEditor2)

Transform property (AudioEditor2 object)

Read-only property that returns a pointer to the AudioEditor2Transform object, for the control of a transformation of an audio file.

Property type

An AudioEditor2Transform value.

Syntax

object.Transform [= value]

The Transform property syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | AudioEditor2Transform | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2Transform object and Editor1 is an AudioEditor2 object.
Editor1.Transform.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.BeginOperations
Editor1.Transform.AddNoise -50, 1
Editor1.Transform.Chorus 50, 40, 2, 40, 100
Editor1.Transform.Invert
Editor1.EndOperations
Editor1.Transform.Save OutputFile, False
Editor1.Transform.Close

See Also:

Applies to: AudioEditor2

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


TypeBorder property (AudioEditor2)

TypeBorder property (AudioEditor2)

Gets or sets the type of a border.

Property type

An Integer value.

Syntax

object.TypeBorder [= value]

The TypeBorder property syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | Integer | Type of border. Varies from 0 to 4.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.TypeBorder = 3
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Apples To: AudioEditor2


TypeView property (AudioEditor2)

TypeView property (AudioEditor2 object)

Gets or sets a type of audio data visualization.

Property type

A TypeViewConstants value.

Syntax

object.TypeView [= value]

The TypeView property syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | TypeViewConstants | Type of visualization. By default is set to WAVEFORM.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.TypeBorder = 3
Editor1.TypeView = SPECTRAL
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Apples To: AudioEditor2

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


UndoEnabled property (AudioEditor2)

UndoEnabled property (AudioEditor2)

Read-only property that returns a flag indicating if the Undo method can be applied or not.

Syntax

[value = ]object.UndoEnabled

The UndoEnabled property syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | Boolean | Is True if the Undo method is available, otherwise -False.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.UndoEnabled = True
Editor1.RedoEnabled = True
Editor1.UndoRedoCount = 4
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Phaser 120, 30, 50
Editor1.Undo
Editor1.Redo
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Redo | RedoEnabled | Undo

Apples To: AudioEditor2


UndoRedoCount property (AudioEditor2)

UndoRedoCount property (AudioEditor2)

Gets or sets the maximum amount of operations, which can be reversed or restored by the Undo and Redo methods.

Property type

A Long value.

Syntax

object.UndoRedoCount [= value]

The UndoRedoCount property syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
value | Long | The maximum amount of operations, which can be reversed or restored. The default value is 1000.

Remarks:

NCTAudioEditor2 creates temporary files on a HDD after applying every method from the list. It always takes some time to save a temporary file. Time depends on the size of the current file. So some large files may cause low memory conditions that could slow down the system. To speed it up you can set UndoRedoCount property to 0, but in this case it will be possible to reverse or restore the only last action.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.UndoEnabled = True
Editor1.RedoEnabled = True
Editor1.UndoRedoCount = 4
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Phaser 120, 30, 50
Editor1.Undo
Editor1.Redo
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Redo | RedoEnabled | Undo | UndoEnabled

Apples To: AudioEditor2


AudioEditor2 Methods

Methods (AudioEditor2 object)

Method | Description
BeginOperations | Starts a block of transformation operations without repainting audio data after every transformation.
Close | Closes the audio file, opened by the Open method or created by the New method.
Continue | Continues playback after applying the Pause method.
ConvertSampleType | Converts current audio file to audio file with specified parameters.
Copy | Copies a selected part of an audio file in the buffer.
CopyToClipboard | Copies a selected part of an audio file in the clipboard.
Cut | Cuts the selected part of an audio file and puts it in a buffer.
DeleteSelect | Deletes the selected part of an audio file.
EndOperations | Stops block of operations beginning by BeginOperations method and repainting audio data in the window.
GetAudioArray | Gets an audio data array from the current cursor position to.
Mix | Mixes the selected part of an audio file with an object in the buffer.
MixFromFile | Mixes the selected part of an audio file with another file.
Open | Opens an audio file.
Paste | Inserts a part of an audio file from the buffer.
PasteFromClipboard | Inserts a part of an audio file from the clipboard.
PasteFromFile | Inserts a file to the current position of an opened audio file.
Pause | Makes a pause in playback. This method can be applied only after the Play method.
Play | Begins playback of a part of an audio file.
PutAudioArray | Inserts an audio data array to the current cursor position or selection.
Record | Begins recording from an input source of an input device (DeviceInput) to a new audio file or to the end of an opened audio file.
Redo | Restores the last action on the waveform, such as applying different effects, filters and performing any editing operations, if no other actions have occurred since the last applying of the Undo method.
Refresh | Repaints the window in which an audio file is displayed.
Register | Enter user name and registration password to disable showing of about window.
Save | Saves a modified audio file or the selected part of the audio file, opened before by the Open method or created by the New method.
SaveWaveImage | Saves the waveform image in a standard BMP file.
Stop | Stops execution of the following methods: Play, Record, Open, Save, Continue.
Undo | Reverses the last action on the waveform, such as applying different effects, filters and performing any editing operations.
Zoom | Repaints audio data in the window from new beginning position to new ending position.
ZoomFull | Displays the entire waveform in a window.
ZoomIn | Makes zooming of the selected part of an audio file.
ZoomOut | Makes an operation, reversed to ZoomIn.
ZoomVertical | Makes zooming in the vertical direction.


BeginOperations method

BeginOperations method (AudioEditor2 object)

Starts a block of transformation operations without repainting audio data after every transformation.

Syntax

object.BeginOperations()

The BeginOperations method syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Remarks:

The audio data will repainted after applying the EndOperations method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Transform.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.BeginOperations
Editor1.Transform.AddNoise -50, 1
Editor1.Transform.Chorus 50, 40, 2, 40, 100
Editor1.Transform.Invert
Editor1.EndOperations
Editor1.Transform.Save OutputFile, False
Editor1.Transform.Close

See Also:

EndOperations

Applies to: AudioEditor2

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


Close method

Close method

Closes the audio file, opened by the Open method or created by the New method.

Syntax

object.Close()

The Close method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

New | Open | Save

Apples To: AudioEditor2


Continue method

Continue method

Continues playback after applying the Pause method.

Syntax

object.Continue()

The Continue method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Play
...
Editor1.Pause
...
Editor1.Continue
...
Editor1.Stop
Editor1.Close

See Also:

Play | Stop

Apples To: AudioEditor2


ConvertSampleType method

ConvertSampleType method

Converts current audio file to audio file with specified parameters.

Syntax

object.ConvertSampleType(Frequency As FrequencyConstants, Channels As ChannelsConstants)

The ConvertSampleType method syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
Frequency | FrequencyConstants | Frequency type. By default Frequency is equal to FQ_44_KHZ.
Channels | ChannelsConstants | Number of channels. By default Channels is equal to STEREO.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.ConvertSampleType FQ_22_KHZ, MONO
Editor1.Close

See Also:

Apples To: AudioEditor2


Copy method

Copy method

Copies a selected part of an audio file in the buffer.

Syntax

object.Copy()

The Copy method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Copy
Editor1.Position.StartSelect = 10
Editor1.Position.EndSelect = Editor1.Position.TotalSamples - 10
Editor1.Paste
Editor1.Save OutputFile, False
AudioEditor2e1.Close

See Also:

Cut | Paste

Apples To: AudioEditor2


CopyToClipboard method

CopyToClipboard method

Copies a selected part of an audio file in the clipboard.

Syntax

object.CopyToClipboard()

The CopyToClipboard method syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.CopyToClipBoard
Editor1.Position.StartSelect = 10
Editor1.Position.EndSelect = Editor1.Position.TotalSamples - 10
Editor1.PasteFromClipBoard
Editor1.Save OutputFile, False
Editor1.Close

See Also:

PasteFromClipboard

Apples To: AudioEditor2


Cut method

Cut method

Cuts the selected part of an audio file and puts it in a buffer.

Syntax

object.Cut()

The Cut method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 10
Editor1.Position.EndSelect = Editor1.Position.TotalSamples - 10
AudioFile1.Cut
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
AudioFile1.Paste
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Copy | Paste

Apples To: AudioEditor2


DeleteSelect method

DeleteSelect method

Deletes the selected part of an audio file.

Syntax

object.DeleteSelect()

The DeleteSelect method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.DeleteSelect
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Apples To: AudioEditor2


EndOperations method

EndOperations method (AudioEditor2 object)

Stops block of operations beginning by BeginOperations method and repainting audio data in the window.

Syntax

object.EndOperations

The EndOperations method syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Remarks:

The BeginOperations method starts this block of transformation.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Transform.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.BeginOperations
Editor1.Transform.AddNoise -50, 1
Editor1.Transform.Chorus 50, 40, 2, 40, 100
Editor1.Transform.Invert
Editor1.EndOperations
Editor1.Transform.Save OutputFile, False
Editor1.Transform.Close

See Also:

BeginOperations

Applies to: AudioEditor2

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


GetAudioArray method

GetAudioArray method

Read-only property that returns an audio data array from the current cursor position or selection.

Return Type

A Integer() value.

Syntax

GetAudioArray = object.GetAudioArray(nSamples As Long)

The GetAudioArray method syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
nSamples | Long | Number of samples in an audio array.
GetAudioArray | Integer() | Audio data array.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Array() As Integer
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Flanger 50, 30, 10, 50, 5
Array() = Editor1.GetAudioArray(Editor1.Position.TotalSamples)

See Also:

PutAudioArray

Apples To: AudioEditor2


Mix method

Mix method

Mixes the selected part of an audio file with an object in the buffer.

Syntax

object.Mix(AmplifySelect As Float, AmplifyPaste As Float)

The Mix method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
AmplifySelect | Float | An amplification percent for the selected part of an audio file. Varies from 0 to 100.
AmplifyPaste | Float | An amplification percent for an audio array in the buffer. Varies from 0 to 100.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 10
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Copy
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples - 10
Editor1.Mix 50, 50
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixFromFile | MixStereoChannels | Normalize | Phaser | Reverb | Reverse | Silence | Trim | Vibrato

Apples To: AudioEditor2


MixFromFile method

MixFromFile method

Mixes the selected part of an audio file with another file.

Syntax

object.MixFromFile(AmplifySelect As Float, fileNamePaste As String, AmplifyPaste As Float)

The MixFromFile method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
AmplifySelect | Float | An amplification percent for the selected part of an audio file.
fileNamePaste | String | The pathname of an inserting audio file.
AmplifyPaste | Float | An amplification percent for another audio file. Varies from 0 to 100.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.MixFromFile 50, InputFile2, 50
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | Mix | MixStereoChannels | Normalize | Phaser | Reverb | Reverse | Silence | Trim | Vibrato

Apples To: AudioEditor2


New method

New method

Creates a new audio file.

Syntax

object.New(Frequency As FrequencyConstants, nChannels As ChannelsConstants)

The New method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
Frequency | FrequencyConstants | Frequency type.
nChannels | ChannelsConstants | Number of channels.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.New FQ_44_KHZ, STEREO
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Close | Open | Save

Apples To: AudioEditor2


Open method

Open method

Opens an audio file.

Syntax

object.Open(fileName As String, FormatType As FormatTypeConstants)

The Open method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
fileName | String | The pathname of an audio file.
FormatType | FormatTypeConstants | The file type. By default FormatType is equal to DEFAULT.

Remarks:

If a file has a wrong extension, you should not change the extension of your files. You can use FormatType parameter of Open method to set the proper format. For example: if you have a RAW file with .VOX extension, you can set FormatType to RAW thus you should not rename the file.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile, WAV
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Close | New | Save

Apples To: AudioEditor2


Paste method

Paste method

Inserts a part of an audio file from the buffer.

Syntax

object.Paste()

The Paste method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Copy
Editor1.Position.StartSelect = 10
Editor1.Position.EndSelect = Editor1.Position.TotalSamples - 10
Editor1.Paste
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Copy | Cut

Apples To: AudioEditor2


PasteFromClipboard method

PasteFromClipboard method

Inserts a part of an audio file from the clipboard.

Return Type

A Boolean value.

Syntax

object.PasteFromClipboard()

The PasteFromClipboard method syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.CopyToClipBoard
Editor1.Position.StartSelect = 10
Editor1.Position.EndSelect = Editor1.Position.TotalSamples - 10
Editor1.PasteFromClipBoard
Editor1.Save OutputFile, False
Editor1.Close

See Also:

CopyToClipboard

Apples To: AudioEditor2


PasteFromFile method

PasteFromFile method

Inserts a file to the current position of an opened audio file.

Syntax

object.PasteFromFile(fileName As String)

The PasteFromFile method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
fileName | String | The pathname of an inserted audio file.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile1
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 10
Editor1.Position.EndSelect = Editor1.Position.TotalSamples - 10
Editor1.PasteFromFile InputFile2
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Apples To: AudioEditor2


Pause method

Pause method

Makes a pause in playback. This method can be applied only after the Play method.

Syntax

object.Pause

The Pause method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Play
...
Editor1.Pause
...
Editor1.Continue
...
Editor1.Stop
Editor1.Close

See Also:

Apples To: AudioEditor2


Play method

Play method

Begins playback of a part of an audio file.

Syntax

object.Play(PlayType As PlayTypeConstants)

The Play method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
PlayType | PlayTypeConstants | By default PlayType is equal to NORMALPLAY.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Play
...
Editor1.Pause
...
Editor1.Continue
...
Editor1.Stop
Editor1.Close

See Also:

Stop | Continue

Apples To: AudioEditor2


PutAudioArray method

PutAudioArray method (AudioEditor2 object)

Inserts an audio data array to the current cursor position or selection.

Syntax

object.PutAudioArray(Array As Integer())

The PutAudioArray method syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
Array | Integer() | Audio data array.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object. The PutAudioArray method replaces audio data from audio data in the selection to Array audio data. If the selection size is more or less then array size after applying this method file size and right selection bound will be changed.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Array() As Integer
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 50
Editor1.Position.EndSelect = 200
Editor1.Transform.Flanger 50, 30, 10, 50, 5
Array() = Editor1.GetAudioArray(Editor1.Position.TotalSamples)
Editor1.Position.StartSelect = 250
Editor1.Position.EndSelect = 400
Editor1.PutAudioArray(Array())

See Also:

GetAudioArray

Applies to: AudioEditor2

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


Record method

Record method

Begins recording from an input source of an input device (DeviceInput) to a new audio file or to the end of an opened audio file.

Syntax

object.Record(RecordType As RecordTypeConstants)

The Record method syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
RecordType | RecordTypeConstants | Type of recording. By default RecordType is equal to RECORD_MIX.

Remarks:

You can open existing audio files by the Open method or create a new audio file by the New method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Apples To: AudioEditor2


Redo method

Redo method

Restores the last action on the waveform, such as applying different effects, filters and performing any editing operations, if no other actions have occurred since the last applying of the Undo method.

Syntax

object.Redo()

The Redo method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Remarks:

This method takes no effect, if methods, which can be restored, have not been performed.

Here is the list of methods that can be restored: Cut, Copy, DeleteSelect, DeleteSilence, Paste, PasteFromFile, Mix, MixFromFile, Amplify, Compressor, Delay, Envelope, Equalizer, Expander, Fade, Flanger, Invert, Normalize, Phaser, Reverb, Reverse, Silence, Stretch, Trim, Vibrato, BandPassFilter, FFTFilter, HighPassFilter, HighShelfFilter, LowPassFilter, LowShelfFilter, NotchFilter, AddNoise, InsertSilence.

Use the UndoRedoCount property to set the maximum amount of operations, which can be restored. The default value is 1000. NCTAudioEditor2 creates temporary files on a HDD after applying every method from the list. It always takes some time to save a temporary file. Time depends on the size of the current file. So some large files may cause low memory conditions that could slow down the system. To speed it up you can set UndoRedoCount property to 0, but in this case it will be possible to restore the only last action.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.UndoEnabled = True
Editor1.RedoEnabled = True
Editor1.UndoRedoCount = 4
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Phaser 120, 30, 50
Editor1.Undo
...
Editor1.Redo
Editor1.Save OutputFile, False
Editor1.Close

See Also:

RedoEnabled | Undo | UndoEnabled

Apples To: AudioEditor2


Refresh method

Refresh method

Repaints the window in which an audio file is displayed.

Syntax

object.Refresh()

The Refresh method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Phaser 120, 30, 50
Editor1.Refresh
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Apples To: AudioEditor2


Register method

Register method

Enter user name and registration password to disable showing of about window.

Syntax

object.Register(bstrUser As String, bstrPassword As String)

The Register method syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
bstrUser | String | User name. You get a registration user name after the registration.
bstrPassword | String | Password string. You get a registration password after the registration.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Register "XXX", "XXX"

See Also:

Apples To: AudioEditor2


Save method

Save method

Saves a modified audio file or the selected part of the audio file, opened before by the Open method or created by the New method.

Syntax

object.Save(fileName As String, Selected As Boolean)

The Save method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
fileName | String | The pathname of an audio file.
Selected | Boolean | Is True if the selected part of a file is saved, and False if the whole file is saved. By default Selected is equal to False.
FormatType | FormatTypeConstants | The file type. By default FormatType is equal to DEFAULT.

Remarks:

The file is saving in the format, which is set by one of the following methods: SetFormatADPCM, SetFormatALAW, SetFormatALF2CD, SetFormatDSP, SetFormatFromMenu, SetFormatG721, SetFormatG723, SetFormatG726, SetFormatGSM, SetFormatLikeSample, SetFormatMP2, SetFormatMP3, SetFormatOggVorbis, SetFormatPCM, SetFormatRAW, SetFormatULAW, SetFormatVOX, SetFormatWMA.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Close | New | Open

Apples To: AudioEditor2


SaveWaveImage method

SaveWaveImage method

Saves the waveform image in a standard BMP file.

Syntax

object.SaveWaveImage(fileBMP As String)

The SaveWaveImage method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
fileBMP | String | The pathname of the BMP file.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.SaveWaveImage "C:\WaveImage.bmp"
Editor1.Close

See Also:

Apples To: AudioEditor2


Stop method

Stop method

Stops execution of the following methods: Play, Record, Open, Save, Continue.

Syntax

object.Stop()

The Stop method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Play
...
Editor1.Pause
...
Editor1.Continue
...
Editor1.Stop
Editor1.Close

See Also:

Play | Record | Open | Save | Continue

Apples To: AudioEditor2


Undo method

Undo method

Reverses the last action on the waveform, such as applying different effects, filters and performing any editing operations.

Syntax

object.Undo()

The Undo method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Remarks:

This method takes no effect, if methods, which can be reversed, have not been performed. Use the UndoEnabled property (read-only) to check if the Undo method is available or not.

Here is the list of methods that can be reversed: Cut, Copy, DeleteSelect, DeleteSilence, Paste, PasteFromFile, Mix, MixFromFile, Amplify, Compressor, Delay, Envelope, Equalizer, Expander, Fade, Flanger, Invert, Normalize, Phaser, Reverb, Reverse, Silence, Stretch, Trim, Vibrato, BandPassFilter, FFTFilter, HighPassFilter, HighShelfFilter, LowPassFilter, LowShelfFilter, NotchFilter, AddNoise, InsertSilence.

Use the UndoRedoCount property to set the maximum amount of operations, which can be reversed. The default value is 1000. NCTAudioEditor2 creates temporary files on a HDD after applying every method from the list. It always takes some time to save a temporary file. Time depends on the size of the current file. So some large files may cause low memory conditions that could slow down the system. To speed it up you can set UndoRedoCount property to 0, but in this case it will be possible to reverse the only last action.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.UndoEnabled = True
Editor1.RedoEnabled = True
Editor1.UndoRedoCount = 4
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Phaser 120, 30, 50
Editor1.Undo
Editor1.Redo
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Redo | RedoEnabled | UndoEnabled

Apples To: AudioEditor2


Zoom method

Zoom method (AudioEditor2 object)

Repaints audio data in the window from new beginning position to new ending position.

Syntax

object.Zoom(Start As Long, End As Long)

The Zoom method syntax has these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
Start | Long | Beginning position.
End | Long | Ending position.

Remarks:

The ZoomFull method works like Zoom method for Start is equal to beginning of file and End is equal to ending of file.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Zoom 50, 200
...
Editor1.ZoomFull
...
Editor1.Close

See Also:

ZoomFull | ZoomIn | ZoomOut | ZoomVertical

Applies to: AudioEditor2

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


ZoomFull method

ZoomFull method

Displays the entire waveform in a window.

Syntax

object.ZoomFull()

The ZoomFull method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.ZoomIn
...
Editor1.ZoomFull
...
Editor1.ZoomIn
...
Editor1.ZoomOut
....
Editor1.ZoomVertical 30
....
Editor1.ZoomFull
...
Editor1.Close

See Also:

Zoom | ZoomIn | ZoomOut | ZoomVertical

Apples To: AudioEditor2


ZoomIn method

ZoomIn method

Makes zooming of the selected part of an audio file.

Syntax

object.ZoomIn()

The ZoomIn method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.ZoomIn
...
Editor1.ZoomFull
...
Editor1.ZoomIn
...
Editor1.ZoomOut
...
Editor1.ZoomVertical 30
...
Editor1.ZoomFull
...
Editor1.Close

See Also:

Zoom | ZoomFull | ZoomOut | ZoomVertical

Apples To: AudioEditor2


ZoomOut method

ZoomOut method

Makes an operation, reversed to ZoomIn.

Syntax

object.ZoomOut()

The ZoomOut method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.ZoomIn
...
Editor1.ZoomFull
...
Editor1.ZoomIn
...
Editor1.ZoomOut
...
Editor1.ZoomVertical 30
...
Editor1.ZoomFull
...
Editor1.Close

See Also:

Zoom | ZoomFull | ZoomIn | ZoomVertical

Apples To: AudioEditor2


ZoomVertical method

ZoomVertical method

Makes zooming in the vertical direction.

Syntax

object.ZoomVertical(Procent As Long)

The ZoomVertical method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2 | An expression evaluating to an object.
Procent | Long | Zooming percent. Varies from 0 to 100. By default Procent is equal to 100.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.ZoomIn
...
Editor1.ZoomFull
...
Editor1.ZoomIn
...
Editor1.ZoomOut
...
Editor1.ZoomVertical 30
...
Editor1.ZoomFull
...
Editor1.Close

See Also:

Zoom | ZoomFull | ZoomIn | ZoomOut

Apples To: AudioEditor2


AudioEditor2 Events

Events (AudioEditor2 object)

Event | Description
BlockOperation | Occurs when an operation with a block of audio data is completed.
ChangeMarker | Occurs when the current marker bound position is changing.
ChangePlayPosition | Occurs when the playback position is changing.
ChangePosition | Occurs when the current cursor position is changing.
DblClick | Occurs when a user presses and releases a mouse button and then presses and releases it again over an object.
EndOperation | Occurs when an operation is completed.
EndPlay | Occurs when playback is completed.
GainChange | Occurs when an gain is changed.
MarkerClick | Occurs when the user click to a marker.
Meter | Occurs while playback or record process and gives information about the current levels in channels.
MouseDown | Occurs when a user presses the mouse button while an object has the focus.
MouseMove | Occurs when a user moves the mouse.
MouseUp | Occurs when a user releases the mouse button while an object has the focus.
NewMarker | Occurs when a new marker appears.
ScaleXClick | Occurs when a user releases the mouse button while mouse pointer points to the horizontal scale.
ScaleYClick | Occurs when a user releases the mouse button while mouse pointer points to the vertical scale.


BlockOperation event

BlockOperation event

Occurs when an operation with a block of audio data is completed.

Syntax

Sub object_BlockOperation(Percent As Integer)

The BlockOperation event syntax consists of these named arguments:

Part | Type | Description
Percent | Integer | Execution percent. Varies from 0 to 100.

Remarks:

An operation meant execution of one of the following methods: Amplify, BandPassFilter, Compressor, Delay, DeleteSilence, Envelope, Equalizer, Expander, Fade, FFTFilter, Flanger, HighPassFilter, HighShelfFilter, Invert, LowPassFilter, LowShelfFilter, Normalize, NotchFilter, Phaser, Reverb, Reverse, Stretch, Trim, Vibrato, Copy, Paste, PasteFromFile, Mix, MixFromFile.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Editor1_BlockOperation(ByVal Procent As Integer)
    Progress(0).Value = Procent
    DoEvents
End Sub

See Also:

EndOperation

Apples To: AudioEditor2


ChangeMarker event

ChangeMarker event

Occurs when the marker bound position is changing.

Syntax

Sub object_ChangePosition(Num As Long)

The ChangeMarker event syntax has these named arguments:

Part | Type | Description
Num | Long | Number of marker.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Editor1_ChangeMarker(Num As Long)
MsgBox Num & " marker is changed"
End Sub

See Also:

ChangePlayPosition

Apples To: AudioEditor2


ChangePlayPosition event

ChangePlayPosition event

Occurs when the playback position is changing.

Syntax

Sub object_ChangePlayPosition()

Remarks:

Playback position is changing during playback after applying of the Play method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Editor1_ChangePlayPosition()
MsgBox "Play position is changed"
End Sub

See Also:

ChangePosition

Apples To: AudioEditor2


ChangePosition event

ChangePosition event

Occurs when the current cursor position is changing.

Syntax

Sub object_ChangePosition()

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Editor1_ChangePosition()
MsgBox "Cursor position is changed"
End Sub

See Also:

ChangePlayPosition

Apples To: AudioEditor2


DblClick event

DblClick event

Occurs when a user presses and releases a mouse button and then presses and releases it again over an object.

Syntax

Sub object_DblClick()

Remarks:

For more information see the Mouse page.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Editor1_DblClick()
    MsgBox "Current position is " & Editor1.Position.CurrentPosition
End Sub

See Also:

Apples To: AudioEditor2


EndOperation event

EndOperation event

Occurs when an operation is completed.

Syntax

Sub object_EndOperation()

Remarks:

An operation meant execution one of the following methods: Amplify, BandPassFilter, Compressor, Delay, DeleteSilence, Envelope, Equalizer, Expander, Fade, FFTFilter, Flanger, HighPassFilter, HighShelfFilter, Invert, LowPassFilter, LowShelfFilter, Normalize, NotchFilter, Phaser, Reverb, Reverse, Stretch, Trim, Vibrato, Copy, Paste, PasteFromFile, Mix, MixFromFile.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Editor1_EndOperation()
   MsgBox "End Operation"
End Sub

See Also:

BlockOperation

Apples To: AudioEditor2


EndPlay event

EndPlay event

Occurs when playback is completed.

Syntax

Sub object_EndPlay()

Remarks:

Playback begins by the Play method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Editor1_EndOperation()
   MsgBox "The playback is completed"
End Sub

See Also:

Apples To: AudioEditor2


GainChange event

GainChange event

Occurs when an gain is changed.

Syntax

Sub object_GainChange(newVolume As Long)

The GainChange event syntax has these named arguments:

Part | Type | Description
newVolume | Long | Volume in db. Varies from -92 to 0.

Remarks:

N db = 20 lg (Pn/P0)

N - number of db.
Pn - Level of sound pressure in pascals.
P0 = 2*105 pascals.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Editor1_GainChange(ByVal newVolume As Long)
    Volume = 65535 - newVolume
End Sub

See Also:

Apples To: AudioEditor2


MarkerClick event

MarkerClick event

Occurs when the user click to a marker.

Syntax

Sub object_MarkerClick(Num As Long)

The MarkerClick event syntax has these named arguments:

Part | Type | Description
Num | Long | A marker number.

Remarks:

For more information see the Mouse page.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Editor1_MarkerClick(ByVal Num As Long)
    Editor1.Markers.Num = Num
    Editor1.Position.GoToMarker Num
End Sub

See Also:

Apples To: AudioEditor2


Meter event

Meter event

Occurs while playback or record process and gives information about the current levels in channels.

Syntax

Sub object_Meter(LevelLeft As Long, LevelRight As Long)

The Meter event syntax consists of these named arguments:

Part | Type | Description
LevelLeft | Long | The current recording level of the left channel, in db. Varies from 0 to 92.
LevelRight | Long | The current recording level of the right channel, in db. Varies from 0 to 92.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Editor1_Meter(ByVal LevelLeft As Long, ByVal LevelRight As Long)
    Progress(0).Value = LevelLeft
    Progress(1).Value = LevelRight
End Sub

See Also:

Apples To: AudioEditor2


MouseDown event

MouseDown event

Occurs when a user presses the mouse button while an object has the focus.

Syntax

Sub object_MouseDown(Button As Long, Shift As Long, x As Integer, y As Integer)

The MouseDown event syntax has these named arguments:

Part | Type | Description
Button | Long | Identification of the mouse button.
Shift | Long | "Shift" button is pressed.
x | Integer | Horizontal coordinate of the mouse pointer.
y | Integer | Vertical coordinate of the mouse pointer.

Remarks:

For more information see the Mouse page.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim RemoteAngle As Integer
Private Sub Editor1_MouseDown(Button As Long, Shift As Long, X As Integer, Y As Integer)
    If X>Y Then
        RemoteAngle = X
    Else
        RemoteAngle = Y
    EndIf
End Sub

See Also:

MouseMove | MouseUp

Apples To: AudioEditor2


MouseMove event

MouseMove event

Occurs when a user moves the mouse.

Syntax

Sub object_MouseMove(Button As Long, Shift As Long, x As Integer, y As Integer)

The MouseMove event syntax consists of these named arguments:

Part | Tupe | Description
Button | Long | Identification of the mouse button.
Shift | Long | "Shift" button is pressed.
x | Integer | Horizontal coordinate of the mouse pointer.
y | Integer | Vertical coordinate of the mouse pointer.

Remarks:

For more information see the Mouse page.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim RemoteAngle As Integer
Private Sub Editor1_MouseMove(Button As Long, Shift As Long, X As Integer, Y As Integer)
    If X>Y Then
        RemoteAngle = X
    Else
        RemoteAngle = Y
    EndIf
End Sub

See Also:

MouseDown | MouseUp

Apples To: AudioEditor2


MouseUp event

MouseUp event

Occurs when a user releases the mouse button while an object has the focus.

Syntax

Sub object_MouseUp(Button As Long, Shift As Long, x As Integer, y As Integer)

The MouseUp event syntax consists of these named arguments:

Part | Type | Description
Button | Long | Identification of the mouse button.
Shift | Long | "Shift" button is pressed.
x | Integer | Horizontal coordinate of the mouse pointer.
y | Integer | Vertical coordinate of the mouse pointer.

Remarks:

For more information see the Mouse page.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim RemoteAngle As Integer
Private Sub Editor1_MouseUp(Button As Long, Shift As Long, X As Integer, Y As Integer)
    If X>Y Then
        RemoteAngle = X
    Else
        RemoteAngle = Y
    EndIf
End Sub

See Also:

MouseDown | MouseMove

Apples To: AudioEditor2


NewMarker event

NewMarker event

Occurs when a new marker appears.

Syntax

Sub object_NewMarker(Num As Long)

The NewMarker event syntax has these named arguments:

Part | Type | Description
Num | Long | Number of marker.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Editor1_NewMarker(ByVal Num As Long)
    MsgBox Num
End Sub

See Also:

Apples To: AudioEditor2


ScaleXClick event

ScaleXClick event (AudioEditor2 object)

Occurs when a user releases the mouse button while mouse pointer points to the horizontal scale.

Syntax

Sub object_ScaleXClick()

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Editor1_ScaleXClick()
    Editor1.Colors.Scales = Editor.Colors.Cursor
End Sub

See Also:

ScaleYClick

Applies to: AudioEditor2

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


ScaleYClick event

ScaleYClick event (AudioEditor2 object)

Occurs when a user releases the mouse button while mouse pointer points to the vertical scale.

Syntax

Sub object_ScaleYClick()

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Editor1_ScaleYClick()
    Editor1.Colors.Scales = Editor.Colors.Cursor
End Sub

See Also:

ScaleXClick

Applies to: AudioEditor2

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


AudioEditor2Channel

AudioEditor2Channel object

Controls channels parameters in an audio file.


AudioEditor2Channel Properties

Properties (AudioEditor2Channel object)

Property | Type | Default | Description
Count | Integer |  | Read-only property that returns quantity of channels in an audio file. The current channel is set by the Num property.
Num | Integer |  | Gets or sets the number of the current channel in an audio file.
Operation | Boolean |  | Gets or sets a flag indicating if an operation is available for the current channel.
Visible | Boolean |  | Gets or sets a flag indicating if the current channel is visible or not.


Count property (AudioEditor2Channel)

Count property (AudioEditor2Channel)

Read-only property that returns quantity of channels in an audio file. The current channel is set by the Num property.

Property type

A Integer value.

Syntax

[value = ]object.Count

The Count property syntax has these parts:

Part | Type | Description
object | AudioEditor2Channel | An expression evaluating to an object.
value | Integer | Varies from 1 to 2.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Channels.Num = 1
Editor1.Channels.Visible = True
If Editor1.Channels.Count = 2 Then
Editor1.Channels.Num = 2
Editor1.Channels.Visible = True
EndIf

See Also:

Num | Operation | Visible

Apples To: AudioEditor2Channel


Num property (AudioEditor2Channel)

Num property (AudioEditor2Channel)

Gets or sets the number of the current channel in an audio file.

Property type

A Integer value.

Syntax

object.Num [= value]

The Num property syntax has these parts:

Part | Type | Description
object | AudioEditor2Channel | An expression evaluating to an object.
value | Integer | Varies from 1 to the Count value.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Channels.Num = 1
Editor1.Channels.Visible = True
Editor1.Channels.Num = 2
Editor1.Channels.Visible = True

See Also:

Count | Operation | Visible

Apples To: AudioEditor2Channel


Operation property (AudioEditor2Channel)

Operation property (AudioEditor2Channel)

Gets or sets a flag indicating if an operation is available for the current channel.

Property type

A Boolean value.

Syntax

object.Operation [= value]

The Operation property syntax has these parts:

Part | Type | Description
object | AudioEditor2Channel | An expression evaluating to an object.
value | Boolean | Is True if an operation is available, otherwise - False.

Remarks:

Operation meant execution one of the following methods: Amplify, BandPassFilter, Delay, DeleteSilence, Equalizer, Fade, FFTFilter, Flanger, HighPassFilter, HighShelfFilter, Invert, LowPassFilter, LowShelfFilter, MultiTapDelay, Normalize, NotchFilter, Reverse, Stretch, Vibrato.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Channels.Num = 1
Editor1.Channels.Operation = True
Editor1.Channels.Visible = True
If Editor1.Channels.Count = 2 Then
Editor1.Channels.Num = 2
Editor1.Channels.Operation = False
Editor1.Channels.Visible = True
EndIf
Editor1.Transform.AddNoise -50, 1
Editor1.SetFormatFromMenu
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Count | Num | Visible

Apples To: AudioEditor2Channel


Visible property (AudioEditor2Channel)

Visible property (AudioEditor2Channel)

Gets or sets a flag indicating if the current channel is visible or not.

Property type

A Boolean value.

Syntax

object.Visible [= value]

The Visible property syntax has these parts:

Part | Type | Description
object | AudioEditor2Channel | An expression evaluating to an object.
value | Boolean | Is True if the current channel is visible, otherwise - False.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Channels.Num = 1
Editor1.Channels.Visible = True
Editor1.Channels.Num = 2
Editor1.Channels.Visible = True

See Also:

Count | Num | Operation

Apples To: AudioEditor2Channel


AudioEditor2Colors

AudioEditor2Colors object

Controls colors of objects in the displaying window.


AudioEditor2Colors Properties

Properties (AudioEditor2Colors object)

Property | Type | Default | Description
AnalogWaveform | OLE_COLOR |  | Gets or sets the RGB color of waveform using standard Windows palette.
Background | OLE_COLOR |  | Gets or sets the RGB color of background using standard Windows palette.
Boundary | OLE_COLOR |  | Gets or sets the RGB color of boundary using standard Windows palette.
CenterLine | OLE_COLOR |  | Gets or sets the RGB color of the center line using standard Windows palette.
CueMarker | OLE_COLOR |  | Gets or sets the RGB color of marker using standard Windows palette. This marker distinguish only one position.
Cursor | OLE_COLOR |  | Gets or sets the RGB color of a cursor using standard Windows palette.
DigitalWaveform | OLE_COLOR |  | Gets or sets the RGB color of a waveform signal in points using standard Windows palette.
Font | OLE_COLOR |  | Gets or sets the font RGB color of scales using standard Windows palette.
Grid | OLE_COLOR |  | Gets or sets the RGB color of grid using standard Windows palette.
PlayCursor | OLE_COLOR |  | Gets or sets the cursor's RGB color during playback using standard Windows palette.
RangeMarker | OLE_COLOR |  | Gets or sets the RGB color of range marker using standard Windows palette. This marker distinguish a range from one position to another.
RangeMarkerBackground | OLE_COLOR |  | Gets or sets the RGB color of background between selected marker bars using standard Windows palette.
Scales | OLE_COLOR |  | Gets or sets the scales RGB color using standard Windows palette.
SelectAnalogWaveform | OLE_COLOR |  | Gets or sets the RGB color of the selected waveform using standard Windows palette.
SelectBackground | OLE_COLOR |  | Gets or sets the RGB color of background selection using standard Windows palette.
SelectCenterLine | OLE_COLOR |  | Gets or sets the RGB color of the selected center line using standard Windows palette.
SelectDigitalWaveform | OLE_COLOR |  | Gets or sets the RGB color of the selected waveform in points using standard Windows palette.
SpectralHigh | Long |  | Gets or sets RGB color of high signal of audio data spectral view.
SpectralLow | Long |  | Gets or sets RGB color of low signal of audio data spectral view.
SpectralSelectHigh | Long |  | Gets or sets RGB color of high signal of selected part of audio data spectral view.
SpectralSelectLow | Long |  | Gets or sets RGB color of low signal of selected part of audio data spectral view.


AnalogWaveform property (AudioEditor2Colors)

AnalogWaveform property (AudioEditor2Colors)

Gets or sets the RGB color of waveform using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.AnalogWaveform [= value]

The AnalogWaveform property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The RGB color of waveform.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Background | Boundary | CenterLine | CueMarker | Cursor | DigitalWaveform | Font | Grid | PlayCursor | RangeMarker | RangeMarkerBackground | Scales | SelectAnalogWaveform | SelectBackground | SelectCenterLine | SelectDigitalWaveform

Apples To: AudioEditor2Colors


Background property (AudioEditor2Colors)

Background property (AudioEditor2Colors)

Gets or sets the RGB color of background using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.Background [= value]

The Background property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The RGB color of background.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Boundary | CenterLine | CueMarker | Cursor | DigitalWaveform | Font | Grid | PlayCursor | RangeMarker | RangeMarkerBackground | Scales | SelectAnalogWaveform | SelectBackground | SelectCenterLine | SelectDigitalWaveform

Apples To: AudioEditor2Colors


Boundary property (AudioEditor2Colors)

Boundary property (AudioEditor2Colors)

Gets or sets the RGB color of boundary using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.Boundary [= value]

The Boundary property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The RGB color of boundary.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Background | CenterLine | CueMarker | Cursor | DigitalWaveform | Font | Grid | PlayCursor | RangeMarker | RangeMarkerBackground | Scales | SelectAnalogWaveform | SelectBackground | SelectCenterLine | SelectDigitalWaveform

Apples To: AudioEditor2Colors


CenterLine property (AudioEditor2Colors)

CenterLine property (AudioEditor2Colors)

Gets or sets the RGB color of the center line using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.CenterLine [= value]

The CenterLine property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The RGB color of the center line.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Background | Boundary | CueMarker | Cursor | DigitalWaveform | Font | Grid | PlayCursor | RangeMarker | RangeMarkerBackground | Scales | SelectAnalogWaveform | SelectBackground | SelectCenterLine | SelectDigitalWaveform

Apples To: AudioEditor2Colors


CueMarker property (AudioEditor2Colors)

CueMarker property (AudioEditor2Colors)

Gets or sets the RGB color of marker using standard Windows palette. This marker distinguish only one position.

Property type

A OLE_COLOR value.

Syntax

object.CueMarker [= value]

The CueMarker property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The RGB color of marker.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Background | Boundary | CenterLine | Cursor | DigitalWaveform | Font | Grid | PlayCursor | RangeMarker | RangeMarkerBackground | Scales | SelectAnalogWaveform | SelectBackground | SelectCenterLine | SelectDigitalWaveform

Apples To: AudioEditor2Colors


Cursor property (AudioEditor2Colors)

Cursor property (AudioEditor2Colors)

Gets or sets the RGB color of a cursor using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.Cursor [= value]

The Cursor property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The RGB color of a cursor.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Background | Boundary | CenterLine | CueMarker | DigitalWaveform | Font | Grid | PlayCursor | RangeMarker | RangeMarkerBackground | Scales | SelectAnalogWaveform | SelectBackground | SelectCenterLine | SelectDigitalWaveform

Apples To: AudioEditor2Colors


DigitalWaveform property (AudioEditor2Colors)

DigitalWaveform property (AudioEditor2Colors)

Gets or sets the RGB color of a waveform signal in points using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.DigitalWaveform [= value]

The DigitalWaveform property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The RGB color of a waveform signal in points.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Background | Boundary | CenterLine | CueMarker | Cursor | Font | Grid | PlayCursor | RangeMarker | RangeMarkerBackground | Scales | SelectAnalogWaveform | SelectBackground | SelectCenterLine | SelectDigitalWaveform

Apples To: AudioEditor2Colors


Font property (AudioEditor2Colors)

Font property (AudioEditor2Colors)

Gets or sets the font RGB color of scales using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.Font [= value]

The Font property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The font RGB color of scales.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Background | Boundary | CenterLine | CueMarker | Cursor | DigitalWaveform | Grid | PlayCursor | RangeMarker | RangeMarkerBackground | Scales | SelectAnalogWaveform | SelectBackground | SelectCenterLine | SelectDigitalWaveform

Apples To: AudioEditor2Colors


Grid property (AudioEditor2Colors)

Grid property (AudioEditor2Colors)

Gets or sets the RGB color of grid using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.Grid [= value]

The Grid property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The RGB color of grid.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Background | Boundary | CenterLine | CueMarker | Cursor | DigitalWaveform | Font | PlayCursor | RangeMarker | RangeMarkerBackground | Scales | SelectAnalogWaveform | SelectBackground | SelectCenterLine | SelectDigitalWaveform

Apples To: AudioEditor2Colors


PlayCursor property (AudioEditor2Colors)

PlayCursor property (AudioEditor2Colors)

Gets or sets the cursor's RGB color during playback using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.PlayCursor [= value]

The PlayCursor property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The cursor's RGB color during playback.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Background | Boundary | CenterLine | CueMarker | Cursor | DigitalWaveform | Font | Grid | RangeMarker | RangeMarkerBackground | Scales | SelectAnalogWaveform | SelectBackground | SelectCenterLine | SelectDigitalWaveform

Apples To: AudioEditor2Colors


RangeMarker property (AudioEditor2Colors)

RangeMarker property (AudioEditor2Colors)

Gets or sets the RGB color of range marker using standard Windows palette. This marker distinguish a range from one position to another.

Property type

A OLE_COLOR value.

Syntax

object.RangeMarker [= value]

The RangeMarker property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The RGB color of range marker.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Background | Boundary | CenterLine | CueMarker | Cursor | DigitalWaveform | Font | Grid | PlayCursor | RangeMarkerBackground | Scales | SelectAnalogWaveform | SelectBackground | SelectCenterLine | SelectDigitalWaveform

Apples To: AudioEditor2Colors


RangeMarkerBackground property (AudioEditor2Colors)

RangeMarkerBackground property (AudioEditor2Colors)

Gets or sets the RGB color of background between selected marker bars using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.RangeMarkerBackground [= value]

The RangeMarkerBackground property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The RGB color of background between selected marker bars.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Background | Boundary | CenterLine | CueMarker | Cursor | DigitalWaveform | Font | Grid | PlayCursor | RangeMarker | Scales | SelectAnalogWaveform | SelectBackground | SelectCenterLine | SelectDigitalWaveform

Apples To: AudioEditor2Colors


Scales property (AudioEditor2Colors)

Scales property (AudioEditor2Colors)

Gets or sets the scales RGB color using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.Scales [= value]

The Scales property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The scales RGB color.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Background | Boundary | CenterLine | CueMarker | Cursor | DigitalWaveform | Font | Grid | PlayCursor | RangeMarker | RangeMarkerBackground | SelectAnalogWaveform | SelectBackground | SelectCenterLine | SelectDigitalWaveform

Apples To: AudioEditor2Colors


SelectAnalogWaveform property (AudioEditor2Colors)

SelectAnalogWaveform property (AudioEditor2Colors)

Gets or sets the RGB color of the selected waveform using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.SelectAnalogWaveform [= value]

The SelectAnalogWaveform property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The RGB color of the selected waveform.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Background | Boundary | CenterLine | CueMarker | Cursor | DigitalWaveform | Font | Grid | PlayCursor | RangeMarker | RangeMarkerBackground | Scales | SelectBackground | SelectCenterLine | SelectDigitalWaveform

Apples To: AudioEditor2Colors


SelectBackground property (AudioEditor2Colors)

SelectBackground property (AudioEditor2Colors)

Gets or sets the RGB color of background selection using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.SelectBackground [= value]

The SelectBackground property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The RGB color of background selection.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Background | Boundary | CenterLine | CueMarker | Cursor | DigitalWaveform | Font | Grid | PlayCursor | RangeMarker | RangeMarkerBackground | Scales | SelectAnalogWaveform | SelectCenterLine | SelectDigitalWaveform

Apples To: AudioEditor2Colors


SelectCenterLine property (AudioEditor2Colors)

SelectCenterLine property (AudioEditor2Colors)

Gets or sets the RGB color of the selected center line using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.SelectCenterLine [= value]

The SelectCenterLine property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The RGB color of the selected center line.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Background | Boundary | CenterLine | CueMarker | Cursor | DigitalWaveform | Font | Grid | PlayCursor | RangeMarker | RangeMarkerBackground | Scales | SelectAnalogWaveform | SelectBackground | SelectDigitalWaveform

Apples To: AudioEditor2Colors


SelectDigitalWaveform property (AudioEditor2Colors)

SelectDigitalWaveform property (AudioEditor2Colors)

Gets or sets the RGB color of the selected waveform in points using standard Windows palette.

Property type

A OLE_COLOR value.

Syntax

object.SelectDigitalWaveform [= value]

The SelectDigitalWaveform property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | OLE_COLOR | The RGB color of the selected waveform in points.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AnalogWaveform | Background | Boundary | CenterLine | CueMarker | Cursor | DigitalWaveform | Font | Grid | PlayCursor | RangeMarker | RangeMarkerBackground | Scales | SelectAnalogWaveform | SelectBackground | SelectCenterLine

Apples To: AudioEditor2Colors


SpectralHigh property (AudioEditor2Colors)

SpectralHigh property (AudioEditor2Colors object)

Gets or sets RGB color of high signal of audio data spectral view.

Property type

A Long value.

Syntax

object.SpectralHigh [= value]

The SpectralHigh property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | Long | Color of high signal of audio data spectral view.

Remarks:

You can see spectral view of audio data if the TypeView property is set to SPECTRAL.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.TypeView = SPECTRAL

Editor1.Colors.SpectralHigh = lstColors.ItemData(17)
Editor1.Colors.SpectralLow = lstColors.ItemData(18)
Editor1.Colors.SpectralSelectHigh = lstColors.ItemData(19)
Editor1.Colors.SpectralSelectLow = lstColors.ItemData(20)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SpectralLow | SpectralSelectHigh | SpectralSelectLow

Applies to: AudioEditor2Colors

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


SpectralLow property (AudioEditor2Colors)

SpectralLow property (AudioEditor2Colors object)

Gets or sets RGB color of low signal of audio data spectral view.

Property type

A Long value.

Syntax

object.SpectralLow [= value]

The SpectralLow property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | Long | Color of low signal of audio data spectral view.

Remarks:

You can see spectral view of audio data if the TypeView property is set to SPECTRAL.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.TypeView = SPECTRAL

Editor1.Colors.SpectralHigh = lstColors.ItemData(17)
Editor1.Colors.SpectralLow = lstColors.ItemData(18)
Editor1.Colors.SpectralSelectHigh = lstColors.ItemData(19)
Editor1.Colors.SpectralSelectLow = lstColors.ItemData(20)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SpectralHigh | SpectralSelectHigh | SpectralSelectLow

Applies to: AudioEditor2Colors

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


SpectralSelectHigh property (AudioEditor2Colors)

SpectralSelectHigh property (AudioEditor2Colors object)

Gets or sets RGB color of high signal of selected part of audio data spectral view.

Property type

A Long value.

Syntax

object.SpectralSelectHigh [= value]

The SpectralSelectHigh property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | Long | Color of high signal of selected part of audio data spectral view.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

You can see spectral view of audio data if the TypeView property is set to SPECTRAL.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.TypeView = SPECTRAL

Editor1.Colors.SpectralHigh = lstColors.ItemData(17)
Editor1.Colors.SpectralLow = lstColors.ItemData(18)
Editor1.Colors.SpectralSelectHigh = lstColors.ItemData(19)
Editor1.Colors.SpectralSelectLow = lstColors.ItemData(20)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SpectralHigh | SpectralLow | SpectralSelectLow

Applies to: AudioEditor2Colors

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


SpectralSelectLow property (AudioEditor2Colors)

SpectralSelectLow property (AudioEditor2Colors object)

Gets or sets RGB color of low signal of selected part of audio data spectral view.

Property type

A Long value.

Syntax

object.SpectralSelectLow [= value]

The SpectralSelectLow property syntax has these parts:

Part | Type | Description
object | AudioEditor2Colors | An expression evaluating to an object.
value | Long | Color of low signal of selected part of audio data spectral view.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

You can see spectral view of audio data if the TypeView property is set to SPECTRAL.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Colors.DigitalWaveform = lstColors.ItemData(0)
Editor1.Colors.AnalogWaveform = lstColors.ItemData(1)
Editor1.Colors.Background = lstColors.ItemData(2)
Editor1.Colors.CenterLine = lstColors.ItemData(3)
Editor1.Colors.SelectDigitalWaveform = lstColors.ItemData(4)
Editor1.Colors.SelectAnalogWaveform = lstColors.ItemData(5)
Editor1.Colors.SelectBackground = lstColors.ItemData(6)
Editor1.Colors.SelectCenterLine = lstColors.ItemData(7)
Editor1.Colors.Grid = lstColors.ItemData(8)
Editor1.Colors.Cursor = lstColors.ItemData(9)
Editor1.Colors.PlayCursor = lstColors.ItemData(10)
Editor1.Colors.Boundary = lstColors.ItemData(11)
Editor1.Colors.Scales = lstColors.ItemData(12)
Editor1.Colors.Font = lstColors.ItemData(13)
Editor1.Colors.CueMarker = lstColors.ItemData(14)
Editor1.Colors.RangeMarker = lstColors.ItemData(15)
Editor1.Colors.RangeMarkerBackground = lstColors.ItemData(16)
Editor1.TypeView = SPECTRAL

Editor1.Colors.SpectralHigh = lstColors.ItemData(17)
Editor1.Colors.SpectralLow = lstColors.ItemData(18)
Editor1.Colors.SpectralSelectHigh = lstColors.ItemData(19)
Editor1.Colors.SpectralSelectLow = lstColors.ItemData(20)
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SpectralHigh | SpectralLow | SpectralSelectHigh

Applies to: AudioEditor2Colors

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


AudioEditor2Device

AudioEditor2Device object

Controls audio devices in your system.


AudioEditor2Device Properties

Properties (AudioEditor2Device object)

Property | Type | Default | Description
BufferCount | Integer |  | Gets or sets count of buffers of support.
BufferSize | Long |  | Gets or sets a size of recording buffer.
Count | Integer |  | Read-only property that returns quantity of audio devices in your system. The current audio device is set by the Num property.
DeviceLines | AudioEditor2DeviceLine |  | Read-only property that returns a pointer to the AudioEditor2DeviceLine object, which controls input and output lines for the current audio device.
Name | String |  | Read-only property that returns the name of the current device. The current output device must be set by the Num property preliminary.
Num | Integer |  | Gets or sets the number of the current device. An audio device's name can be get by the Name property.
TimerInterval | Integer |  | Gets or sets the time interval from one Meter event to another.
Volume | Long |  | Gets or sets a magnitude of volume for playback of audio data.


BufferCount property (AudioEditor2Device)

BufferCount property (AudioEditor2Device)

Gets or sets count of buffers of support.

Property type

A Integer value.

Syntax

object.BufferCount [= value]

The BufferCount property syntax has these parts:

Part | Type | Description
object | AudioEditor2Device | An expression evaluating to an object.
value | Integer | The count of buffers. Can accept only non-negative values.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.DeviceInput.BufferCount = 2
Editor1.DeviceInput.BufferSize = 500
Editor1.DeviceInput.TimerInterval = 0
Editor1.DeviceInput.Volume = 4000
For i = 0 To Editor1.DeviceInput.Count
    Editor1.DeviceInput.Num = i
    If Editor1.DeviceInput.DeviceLines.Count > 0 Then
        MsgBox "Device : " & Editor1.DeviceInput.Name
    End If
Next
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

BufferSize | Count | DeviceLines | Name | Num | TimerInterval | Volume

Apples To: AudioEditor2Device


BufferSize property (AudioEditor2Device)

BufferSize property (AudioEditor2Device)

Gets or sets a size of recording buffer.

Property type

A Long value.

Syntax

object.BufferSize [= value]

The BufferSize property syntax has these parts:

Part | Type | Description
object | AudioEditor2Device | An expression evaluating to an object.
value | Long | The size of recording buffer, in ms.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.DeviceInput.BufferCount = 2
Editor1.DeviceInput.BufferSize = 500
Editor1.DeviceInput.TimerInterval = 0
Editor1.DeviceInput.Volume = 4000
For i = 0 To Editor1.DeviceInput.Count
    Editor1.DeviceInput.Num = i
    If Editor1.DeviceInput.DeviceLines.Count > 0 Then
        MsgBox "Device : " & Editor1.DeviceInput.Name
    End If
Next
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

BufferCount | Count | DeviceLines | Name | Num | TimerInterval | Volume

Apples To: AudioEditor2Device


Count property (AudioEditor2Device)

Count property (AudioEditor2Device)

Read-only property that returns quantity of audio devices in your system. The current audio device is set by the Num property.

Property type

A Integer value.

Syntax

[value = ]object.Count

The Count property syntax has these parts:

Part | Type | Description
object | AudioEditor2Device | An expression evaluating to an object.
value | Integer | Quantity of audio devices.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.DeviceInput.BufferCount = 2
Editor1.DeviceInput.BufferSize = 500
Editor1.DeviceInput.TimerInterval = 0
Editor1.DeviceInput.Volume = 4000
For i = 0 To Editor1.DeviceInput.Count
    Editor1.DeviceInput.Num = i
    If Editor1.DeviceInput.DeviceLines.Count > 0 Then
        MsgBox "Device : " & Editor1.DeviceInput.Name
    End If
Next
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

BufferCount | BufferSize | DeviceLines | Name | Num | TimerInterval | Volume

Apples To: AudioEditor2Device


DeviceLines property (AudioEditor2Device)

DeviceLines property (AudioEditor2Device)

Read-only property that returns a pointer to the AudioEditor2DeviceLine object, which controls input and output lines for the current audio device.

Property type

A AudioEditor2DeviceLine value.

Syntax

[value = ]object.DeviceLines

The DeviceLines property syntax has these parts:

Part | Type | Description
object | AudioEditor2Device | An expression evaluating to an object.
value | AudioEditor2DeviceLine | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub SetSrcInput()
    cmbSrcInput.Clear
    If Editor1.DeviceInput.DeviceLines.Count < 0 Then Exit Sub
    kSrcInput = Editor1.DeviceInput.DeviceLines.Num
    For i = 0 To Editor1.DeviceInput.DeviceLines.Count
        Editor1.DeviceInput.DeviceLines.Num = i
        cmbSrcInput.AddItem Editor1.DeviceInput.DeviceLines.Name
        If Editor1.DeviceInput.DeviceLines.Select Then kSrcInput = i
    Next
    Editor1.DeviceInput.DeviceLines.Num = kSrcInput
    cmbSrcInput.ListIndex = kSrcInput
End Sub

See Also:

BufferCount | BufferSize | Count | Name | Num | TimerInterval | Volume

Apples To: AudioEditor2Device


Name property (AudioEditor2Device)

Name property (AudioEditor2Device)

Read-only property that returns the name of the current device. The current output device must be set by the Num property preliminary.

Property type

A String value.

Syntax

[value = ]object.Name

The Name property syntax has these parts:

Part | Type | Description
object | AudioEditor2Device | An expression evaluating to an object.
value | String | The name of the current device.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.DeviceInput.BufferCount = 2
Editor1.DeviceInput.BufferSize = 500
Editor1.DeviceInput.TimerInterval = 0
Editor1.DeviceInput.Volume = 4000
For i = 0 To Editor1.DeviceInput.Count
    Editor1.DeviceInput.Num = i
    If Editor1.DeviceInput.DeviceLines.Count > 0 Then
        MsgBox "Device : " & Editor1.DeviceInput.Name
    End If
Next
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

BufferCount | BufferSize | Count | DeviceLines | Num | TimerInterval | Volume

Apples To: AudioEditor2Device


Num property (AudioEditor2Device)

Num property (AudioEditor2Device)

Gets or sets the number of the current device. An audio device's name can be get by the Name property.

Property type

A Integer value.

Syntax

object.Num [= value]

The Num property syntax has these parts:

Part | Type | Description
object | AudioEditor2Device | An expression evaluating to an object.
value | Integer | Varies from 0 to the Count-1 value.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.DeviceInput.BufferCount = 2
Editor1.DeviceInput.BufferSize = 500
Editor1.DeviceInput.TimerInterval = 0
Editor1.DeviceInput.Volume = 4000
For i = 0 To Editor1.DeviceInput.Count
    Editor1.DeviceInput.Num = i
    If Editor1.DeviceInput.DeviceLines.Count > 0 Then
        MsgBox "Device : " & Editor1.DeviceInput.Name
    End If
Next
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

BufferCount | BufferSize | Count | DeviceLines | Name | TimerInterval | Volume

Apples To: AudioEditor2Device


TimerInterval property (AudioEditor2Device)

TimerInterval property (AudioEditor2Device)

Gets or sets the time interval from one Meter event to another.

Property type

A Integer value.

Syntax

object.TimerInterval [= value]

The TimerInterval property syntax has these parts:

Part | Type | Description
object | AudioEditor2Device | An expression evaluating to an object.
value | Integer | Time interval, in ms.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.DeviceInput.BufferCount = 2
Editor1.DeviceInput.BufferSize = 500
Editor1.DeviceInput.TimerInterval = 0
Editor1.DeviceInput.Volume = 4000
For i = 0 To Editor1.DeviceInput.Count
    Editor1.DeviceInput.Num = i
    If Editor1.DeviceInput.DeviceLines.Count > 0 Then
        MsgBox "Device : " & Editor1.DeviceInput.Name
    End If
Next
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

BufferCount | BufferSize | Count | DeviceLines | Name | Num | Volume

Apples To: AudioEditor2Device


Volume property (AudioEditor2Device)

Volume property (AudioEditor2Device)

Gets or sets a magnitude of volume for playback of audio data.

Property type

A Long value.

Syntax

object.Volume [= value]

The Volume property syntax has these parts:

Part | Type | Description
object | AudioEditor2Device | An expression evaluating to an object.
value | Long | Varies from 0 to 65535.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.DeviceInput.BufferCount = 2
Editor1.DeviceInput.BufferSize = 500
Editor1.DeviceInput.TimerInterval = 0
Editor1.DeviceInput.Volume = 4000
For i = 0 To Editor1.DeviceInput.Count
    Editor1.DeviceInput.Num = i
    If Editor1.DeviceInput.DeviceLines.Count > 0 Then
        MsgBox "Device : " & Editor1.DeviceInput.Name
    End If
Next
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

BufferCount | BufferSize | Count | DeviceLines | Name | Num | TimerInterval

Apples To: AudioEditor2Device


AudioEditor2DeviceLine

AudioEditor2DeviceLine object

Controls input and output lines for the current audio device.


AudioEditor2DeviceLine Properties

Properties (AudioEditor2DeviceLine object)

Property | Type | Default | Description
AdvancedCount | Integer |  | Read-only property that returns quantity of advanced controls for the current line. The current line must be set by the Num property preliminary.
AdvancedName | String |  | Read-only property that returns the names of advanced controls for the current line. The current line must be set by the Num property preliminary.
AdvancedValue | Variant |  | Gets or sets value for advanced controls for the current line. The current line must be set by the Num property preliminary.
Count | Integer |  | Read-only property that returns quantity of lines for the current device. The current device must be set by the Num property preliminary.
Name | String |  | Read-only property that returns name of current line for the current device. The current device must be set by the Num (AudioEditor2Device) property and the current line must be set by the Num (AudioEditor2DeviceLine) property preliminary.
Num | Integer |  | Gets or sets the current line for the current device. The current output device must be set by the Num (AudioEditor2Device) property preliminary.
Select | Boolean |  | Gets or sets a flag indicating if the current line is selected or not. The current line must be set by the Num (AudioEditor2DeviceLine) property preliminary.
Volume | Long |  | Gets or sets a magnitude of volume for playback of audio data for the current line. The current line must be set by the Num (AudioEditor2DeviceLine) property preliminary.
VolumeBalance | Integer |  | Gets or sets the relative volume between left and right channels in a stereo audio system for playback of audio data for the current line. The current line must be set by the Num (AudioEditor2DeviceLine) property preliminary.


AdvancedCount property (AudioEditor2DeviceLine)

AdvancedCount property (AudioEditor2DeviceLine)

Read-only property that returns quantity of advanced controls for the current line. The current line must be set by the Num property preliminary.

Property type

A Integer value.

Syntax

[value = ]object.AdvancedCount

The AdvancedCount property syntax has these parts:

Part | Type | Description
object | AudioEditor2DeviceLine | An expression evaluating to an object.
value | Integer | Can accept only non-negative values.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim i As Integer
Dim j As Integer
Dim ACValue As Variant
Dim DLName As String
Dim ACName As String
For i = 0 To Editor1.DeviceOutput.DeviceLines.Count
    Editor1.DeviceOutput.DeviceLines.Num = i
    DLName = Editor1.DeviceOutput.DeviceLines.Name
    For j = 0 To Editor1.DeviceOutput.DeviceLines.AdvancedCount
        ACName = Editor1.DeviceOutput.DeviceLines.AdvancedName(j)
        ACValue = Editor1.DeviceOutput.DeviceLines.AdvancedValue(j)
        MsgBox "Device line" & DLName & ", Advanced control name: " & ACName & " with value: " & ACValue
    Next j
    Editor1.DeviceOutput.DeviceLines.Select = True
    Editor1.DeviceOutput.DeviceLines.Volume = 4000 + i*100
    Editor1.DeviceOutput.DeviceLines.VolumeBalance = 50
Next i

See Also:

AdvancedName | AdvancedValue | Count | Name | Num | Select | Volume | VolumeBalance

Apples To: AudioEditor2DeviceLine


AdvancedName property (AudioEditor2DeviceLine)

AdvancedName property (AudioEditor2DeviceLine)

Read-only property that returns the names of advanced controls for the current line. The current line must be set by the Num property preliminary.

Property type

A String value.

Syntax

[value = ]object.AdvancedName(index As Integer)

The AdvancedName property syntax has these parts:

Part | Type | Description
object | AudioEditor2DeviceLine | An expression evaluating to an object.
index | Integer | The number of advanced control.
value | String | The name of advanced control.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim i As Integer
Dim j As Integer
Dim ACValue As Variant
Dim DLName As String
Dim ACName As String
For i = 0 To Editor1.DeviceOutput.DeviceLines.Count
    Editor1.DeviceOutput.DeviceLines.Num = i
    DLName = Editor1.DeviceOutput.DeviceLines.Name
    For j = 0 To Editor1.DeviceOutput.DeviceLines.AdvancedCount
        ACName = Editor1.DeviceOutput.DeviceLines.AdvancedName(j)
        ACValue = Editor1.DeviceOutput.DeviceLines.AdvancedValue(j)
        MsgBox "Device line" & DLName & ", Advanced control name: " & ACName & " with value: " & ACValue
    Next j
    Editor1.DeviceOutput.DeviceLines.Select = True
    Editor1.DeviceOutput.DeviceLines.Volume = 4000 + i*100
    Editor1.DeviceOutput.DeviceLines.VolumeBalance = 50
Next i

See Also:

AdvancedCount | AdvancedValue | Count | Name | Num | Select | Volume | VolumeBalance

Apples To: AudioEditor2DeviceLine


AdvancedValue property (AudioEditor2DeviceLine)

AdvancedValue property (AudioEditor2DeviceLine)

Gets or sets value for advanced controls for the current line. The current line must be set by the Num property preliminary.

Property type

A Variant value.

Syntax

object.AdvancedValue(index As Integer) [= value]

The AdvancedValue property syntax has these parts:

Part | Type | Description
object | AudioEditor2DeviceLine | An expression evaluating to an object.
index | Integer | The number of advanced control.
value | Variant | The value for advanced control.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim i As Integer
Dim j As Integer
Dim ACValue As Variant
Dim DLName As String
Dim ACName As String
For i = 0 To Editor1.DeviceOutput.DeviceLines.Count
    Editor1.DeviceOutput.DeviceLines.Num = i
    DLName = Editor1.DeviceOutput.DeviceLines.Name
    For j = 0 To Editor1.DeviceOutput.DeviceLines.AdvancedCount
        ACName = Editor1.DeviceOutput.DeviceLines.AdvancedName(j)
        ACValue = Editor1.DeviceOutput.DeviceLines.AdvancedValue(j)
        MsgBox "Device line" & DLName & ", Advanced control name: " & ACName & " with value: " & ACValue
    Next j
    Editor1.DeviceOutput.DeviceLines.Select = True
    Editor1.DeviceOutput.DeviceLines.Volume = 4000 + i*100
    Editor1.DeviceOutput.DeviceLines.VolumeBalance = 50
Next i

See Also:

AdvancedCount | AdvancedName | Count | Name | Num | Select | Volume | VolumeBalance

Apples To: AudioEditor2DeviceLine


Count property (AudioEditor2DeviceLine)

Count property (AudioEditor2DeviceLine)

Read-only property that returns quantity of lines for the current device. The current device must be set by the Num property preliminary.

Property type

A Integer value.

Syntax

[value = ]object.Count

The Count property syntax has these parts:

Part | Type | Description
object | AudioEditor2DeviceLine | An expression evaluating to an object.
value | Integer | Can accept only non-negative values.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim i As Integer
Dim j As Integer
Dim ACValue As Variant
Dim DLName As String
Dim ACName As String
For i = 0 To Editor1.DeviceOutput.DeviceLines.Count
    Editor1.DeviceOutput.DeviceLines.Num = i
    DLName = Editor1.DeviceOutput.DeviceLines.Name
    For j = 0 To Editor1.DeviceOutput.DeviceLines.AdvancedCount
        ACName = Editor1.DeviceOutput.DeviceLines.AdvancedName(j)
        ACValue = Editor1.DeviceOutput.DeviceLines.AdvancedValue(j)
        MsgBox "Device line" & DLName & ", Advanced control name: " & ACName & " with value: " & ACValue
    Next j
    Editor1.DeviceOutput.DeviceLines.Select = True
    Editor1.DeviceOutput.DeviceLines.Volume = 4000 + i*100
    Editor1.DeviceOutput.DeviceLines.VolumeBalance = 50
Next i

See Also:

AdvancedCount | AdvancedName | AdvancedValue | Name | Num | Select | Volume | VolumeBalance

Apples To: AudioEditor2DeviceLine


Name property (AudioEditor2DeviceLine)

Name property (AudioEditor2DeviceLine)

Read-only property that returns name of current line for the current device. The current device must be set by the Num (AudioEditor2Device) property and the current line must be set by the Num (AudioEditor2DeviceLine) property preliminary.

Property type

A String value.

Syntax

[value = ]object.Name

The Name property syntax has these parts:

Part | Type | Description
object | AudioEditor2DeviceLine | An expression evaluating to an object.
value | String | The name of current line.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim i As Integer
Dim j As Integer
Dim ACValue As Variant
Dim DLName As String
Dim ACName As String
For i = 0 To Editor1.DeviceOutput.DeviceLines.Count
    Editor1.DeviceOutput.DeviceLines.Num = i
    DLName = Editor1.DeviceOutput.DeviceLines.Name
    For j = 0 To Editor1.DeviceOutput.DeviceLines.AdvancedCount
        ACName = Editor1.DeviceOutput.DeviceLines.AdvancedName(j)
        ACValue = Editor1.DeviceOutput.DeviceLines.AdvancedValue(j)
        MsgBox "Device line" & DLName & ", Advanced control name: " & ACName & " with value: " & ACValue
    Next j
    Editor1.DeviceOutput.DeviceLines.Select = True
    Editor1.DeviceOutput.DeviceLines.Volume = 4000 + i*100
    Editor1.DeviceOutput.DeviceLines.VolumeBalance = 50
Next i

See Also:

AdvancedCount | AdvancedName | AdvancedValue | Count | Num | Select | Volume | VolumeBalance

Apples To: AudioEditor2DeviceLine


Num property (AudioEditor2DeviceLine)

Num property (AudioEditor2DeviceLine)

Gets or sets the current line for the current device. The current output device must be set by the Num (AudioEditor2Device) property preliminary.

Property type

A Integer value.

Syntax

object.Num [= value]

The Num property syntax has these parts:

Part | Type | Description
object | AudioEditor2DeviceLine | An expression evaluating to an object.
value | Integer | Varies from 0 to the Count-1 value.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim i As Integer
Dim j As Integer
Dim ACValue As Variant
Dim DLName As String
Dim ACName As String
For i = 0 To Editor1.DeviceOutput.DeviceLines.Count
    Editor1.DeviceOutput.DeviceLines.Num = i
    DLName = Editor1.DeviceOutput.DeviceLines.Name
    For j = 0 To Editor1.DeviceOutput.DeviceLines.AdvancedCount
        ACName = Editor1.DeviceOutput.DeviceLines.AdvancedName(j)
        ACValue = Editor1.DeviceOutput.DeviceLines.AdvancedValue(j)
        MsgBox "Device line" & DLName & ", Advanced control name: " & ACName & " with value: " & ACValue
    Next j
    Editor1.DeviceOutput.DeviceLines.Select = True
    Editor1.DeviceOutput.DeviceLines.Volume = 4000 + i*100
    Editor1.DeviceOutput.DeviceLines.VolumeBalance = 50
Next i

See Also:

AdvancedCount | AdvancedName | AdvancedValue | Count | Name | Select | Volume | VolumeBalance

Apples To: AudioEditor2DeviceLine


Select property (AudioEditor2DeviceLine)

Select property (AudioEditor2DeviceLine)

Gets or sets a flag indicating if the current line is selected or not. The current line must be set by the Num (AudioEditor2DeviceLine) property preliminary.

Property type

A Boolean value.

Syntax

object.Select [= value]

The Select property syntax has these parts:

Part | Type | Description
object | AudioEditor2DeviceLine | An expression evaluating to an object.
value | Boolean | Is True if the current line is selected, otherwise- False.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim i As Integer
Dim j As Integer
Dim ACValue As Variant
Dim DLName As String
Dim ACName As String
For i = 0 To Editor1.DeviceOutput.DeviceLines.Count
    Editor1.DeviceOutput.DeviceLines.Num = i
    DLName = Editor1.DeviceOutput.DeviceLines.Name
    For j = 0 To Editor1.DeviceOutput.DeviceLines.AdvancedCount
        ACName = Editor1.DeviceOutput.DeviceLines.AdvancedName(j)
        ACValue = Editor1.DeviceOutput.DeviceLines.AdvancedValue(j)
        MsgBox "Device line" & DLName & ", Advanced control name: " & ACName & " with value: " & ACValue
    Next j
    Editor1.DeviceOutput.DeviceLines.Select = True
    Editor1.DeviceOutput.DeviceLines.Volume = 4000 + i*100
    Editor1.DeviceOutput.DeviceLines.VolumeBalance = 50
Next i

See Also:

AdvancedCount | AdvancedName | AdvancedValue | Count | Name | Num | Volume | VolumeBalance

Apples To: AudioEditor2DeviceLine


Volume property (AudioEditor2DeviceLine)

Volume property (AudioEditor2DeviceLine)

Gets or sets a magnitude of volume for playback of audio data for the current line. The current line must be set by the Num (AudioEditor2DeviceLine) property preliminary.

Property type

A Long value.

Syntax

object.Volume [= value]

The Volume property syntax has these parts:

Part | Type | Description
object | AudioEditor2DeviceLine | An expression evaluating to an object.
value | Long | Varies from 0 to 65535.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim i As Integer
Dim j As Integer
Dim ACValue As Variant
Dim DLName As String
Dim ACName As String
For i = 0 To Editor1.DeviceOutput.DeviceLines.Count
    Editor1.DeviceOutput.DeviceLines.Num = i
    DLName = Editor1.DeviceOutput.DeviceLines.Name
    For j = 0 To Editor1.DeviceOutput.DeviceLines.AdvancedCount
        ACName = Editor1.DeviceOutput.DeviceLines.AdvancedName(j)
        ACValue = Editor1.DeviceOutput.DeviceLines.AdvancedValue(j)
        MsgBox "Device line" & DLName & ", Advanced control name: " & ACName & " with value: " & ACValue
    Next j
    Editor1.DeviceOutput.DeviceLines.Select = True
    Editor1.DeviceOutput.DeviceLines.Volume = 4000 + i*100
    Editor1.DeviceOutput.DeviceLines.VolumeBalance = 50
Next i

See Also:

AdvancedCount | AdvancedName | AdvancedValue | Count | Name | Num | Select | VolumeBalance

Apples To: AudioEditor2DeviceLine


VolumeBalance property (AudioEditor2DeviceLine)

VolumeBalance property (AudioEditor2DeviceLine)

Gets or sets the relative volume between left and right channels in a stereo audio system for playback of audio data for the current line. The current line must be set by the Num (AudioEditor2DeviceLine) property preliminary.

Property type

A Integer value.

Syntax

object.VolumeBalance [= value]

The VolumeBalance property syntax has these parts:

Part | Type | Description
object | AudioEditor2DeviceLine | An expression evaluating to an object.
value | Integer | Varies from 0 to 100.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim i As Integer
Dim j As Integer
Dim ACValue As Variant
Dim DLName As String
Dim ACName As String
For i = 0 To Editor1.DeviceOutput.DeviceLines.Count
    Editor1.DeviceOutput.DeviceLines.Num = i
    DLName = Editor1.DeviceOutput.DeviceLines.Name
    For j = 0 To Editor1.DeviceOutput.DeviceLines.AdvancedCount
        ACName = Editor1.DeviceOutput.DeviceLines.AdvancedName(j)
        ACValue = Editor1.DeviceOutput.DeviceLines.AdvancedValue(j)
        MsgBox "Device line" & DLName & ", Advanced control name: " & ACName & " with value: " & ACValue
    Next j
    Editor1.DeviceOutput.DeviceLines.Select = True
    Editor1.DeviceOutput.DeviceLines.Volume = 4000 + i*100
    Editor1.DeviceOutput.DeviceLines.VolumeBalance = 50
Next i

See Also:

AdvancedCount | AdvancedName | AdvancedValue | Count | Name | Num | Select | Volume

Apples To: AudioEditor2DeviceLine


AudioEditor2FileFormat

AudioEditor2FileFormat object

Controls audio file format. With AudioEditor2FileFormat you can set format of input file to the selected audio file format.

The following audio formats are supported:

  • Uncompressed WAV PCM;

  • Compressed WAV (GSM, ADPCM, DSP and others);

  • MP3 (including VBR);

  • MP2;

  • VOX (Dialogic ADPCM);

  • RAW;

  • WMA;

  • AVI (audio);

  • G.726, G.723, G.721;

  • Ogg Vorbis;

  • MPC.

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


AudioEditor2FileFormat Methods

Methods (AudioEditor2FileFormat object)

Method | Description
IsFormatMpegAvailable | Indicates if parameters are supported by Mpeg codec or not.
IsFormatOggVorbisAvailable | Indicates if parameters are supported by Ogg Vorbis codec or not.
SetFormatADPCM | Sets the output format to ADPCM.
SetFormatALAW | Sets the output format to A-law.
SetFormatDSP | Sets the output format to DSP.
SetFormatFromMenu | Sets the output format of an audio file. This method calls the standard Windows menu in which you can pick up parameters of the output format.
SetFormatG721 | Sets the output format to G.721.
SetFormatG723 | Sets the output format to G.723.
SetFormatG726 | Sets the output format to G.726.
SetFormatGSM | Sets the output format to GSM.
SetFormatLikeSample | Sets the output format of an audio file according to the format of the chosen sample file.
SetFormatMP2 | Sets the output format to MP2.
SetFormatMP3 | Sets the output format to MP3.
SetFormatMP3Ex | Sets the format with specific lame mp3 encoder parameters of an MP3 audio file.
SetFormatOggVorbis | Sets the output format to Ogg Vorbis.
SetFormatPCM | Sets the output format to PCM.
SetFormatRAW | Sets the output format to RAW.
SetFormatULAW | Sets the output format to U-law.
SetFormatVOX | Sets the output format to VOX.
SetFormatWMA | Sets the output format to WMA.


IsFormatMpegAvailable method

IsFormatMpegAvailable method (AudioEditor2FileFormat object)

Indicates if parameters are supported by Mpeg codec or not.

Return Type

A Boolean value.

Syntax

MpegFormat = object.IsFormatMpegAvailable(Frequency As FrequencyConstants, Bitrate As BitrateConstants, Channels As ChannelsConstants)

The IsFormatMpegAvailable method syntax has these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
Frequency | FrequencyConstants | Frequency of a Mpeg file. By default the Frequency is equal to FQ_44_KHZ.
Bitrate | BitrateConstants | Bitrate of a Mpeg file. By default the Bitrate is set to BR_128_KBPS.
Channels | ChannelsConstants | Quantity of channels for a Mpeg file.
MpegFormat | Boolean | True if Mpeg parameters has correct values, otherwise - False.

Remarks:

This method is recommended to use before applying SetFormatMP2 or SetFormatMP3 methods.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.FileFormat.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = FileFormat1.Position.TotalSamples
Editor1.Transform.Invert
If Editor1.FileFormat.IsFormatMpegAvailable(FQ_44_KHZ, BR_32_KBPS, STEREO) = True Then 'MP3
Editor1.FileFormat.SetFormatMP3 FQ_44_KHZ, BR_32_KBPS, STEREO
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatMP2 | SetFormatMP3

Applies to: AudioEditor2FileFormat


IsFormatOggVorbisAvailable method

IsFormatOggVorbisAvailable method (AudioEditor2FileFormat object)

Indicates if parameters are supported by Ogg Vorbis codec or not.

Return Type

A Boolean value.

Syntax

OggVorbis Format = object.IsAvailableFormatOggVorbis(Frequency As FrequencyConstants, nChannels As ChannelsConstants, NominalBitrate As BitrateConstants, MinBitrate As BitrateConstants, MaxBitrate As BitrateConstants)

The IsFormatOggVorbisAvailable method syntax has these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
Frequency | FrequencyConstants | Frequency of an audio file. By default the Frequency is equal to FQ_44_KHZ.
nChannels | ChannelsConstants | Quantity of channels for an audio file. By default the nChannels is equal to STEREO.
NominalBitrate | BitrateConstants | Bitrate of an audio file. By default the NominalBitrate is equal to BR_128_KBPS.
MinBitrate | BitrateConstants | Minimal bitrate. By default the MinBitrate is equal to BR_NONE.
MaxBitrate | BitrateConstants | Maxilmal bitrate. By default the MaxBitrate is equal to BR_NONE.
OggVorbis Format | Boolean | True if Mpeg parameters has correct values, otherwise - False.

Remarks:

This method is recommended to use before applying SetFormatOggVorbis method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Invert
If Editor1.FileFormat.IsFormatOggVorbisAvailable(, , Bitrate, MinBitrate, MaxBitrate) = True Then 'Ogg Vorbis
Editor1.FileFormat.SetFormatOggVorbis , , Bitrate, MinBitrate, MaxBitrate
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatOggVorbis

Applies to: AudioEditor2FileFormat


SetFormatADPCM method

SetFormatADPCM method

Sets the output format to ADPCM.

Syntax

object.SetFormatADPCM(Frequency As FrequencyConstants, nChannels As ChannelsConstants)

The SetFormatADPCM method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
Frequency | FrequencyConstants | Frequency of an audio file. By default the Frequency is equal to FQ_44_KHZ.
nChannels | ChannelsConstants | Quantity of channels for an audio file. By default the nChannels is equal to STEREO.

Remarks:

You should apply this method before saving ADPCM file by the Save method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
If TypeComp = 1 Then
Editor1.FileFormat.SetFormatADPCM Freq, Chann
ElseIf TypeComp = 2 Then
Editor1.FileFormat.SetFormatALAW Freq, Chann
ElseIf TypeComp = 3 Then
Editor1.FileFormat.SetFormatDSP
ElseIf TypeComp = 4 Then
Editor1.FileFormat.SetFormatGSM Freq
ElseIf TypeComp = 5 Then
Editor1.FileFormat.SetFormatMobileVoice Freq
ElseIf TypeComp = 6 Then
Editor1.FileFormat.SetFormatULAW Freq, Chann
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatALAW | SetFormatDSP | SetFrmatFromMenu | SetFormatG721 | SetFormatG723 | SetFormatG726 | SetFormatGSM | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatPCM | SetFormatRAW | SetFormatULAW | SetFormatVOX | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatALAW method

SetFormatALAW method

Sets the output format to A-law.

Syntax

object.SetFormatALAW(Frequency As FrequencyConstants, nChannels As ChannelsConstants)

The SetFormatALAW method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
Frequency | FrequencyConstants | Frequency of an audio file. By default the Frequency is equal to FQ_8_KHZ.
nChannels | ChannelsConstants | Quantity of channels for an audio file. By default he nChannels is equal to MONO.

Remarks:

You should apply this method before saving ADPCM file by the Save method.

By default the Frequency is equal to FQ_8_KHZ and the nChannels is equal to MONO.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
If TypeComp = 1 Then
Editor1.FileFormat.SetFormatADPCM Freq, Chann
ElseIf TypeComp = 2 Then
Editor1.FileFormat.SetFormatALAW Freq, Chann
ElseIf TypeComp = 3 Then
Editor1.FileFormat.SetFormatDSP
ElseIf TypeComp = 4 Then
Editor1.FileFormat.SetFormatGSM Freq
ElseIf TypeComp = 5 Then
Editor1.FileFormat.SetFormatMobileVoice Freq
ElseIf TypeComp = 6 Then
Editor1.FileFormat.SetFormatULAW Freq, Chann
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatDSP | SetFrmatFromMenu | SetFormatG721 | SetFormatG723 | SetFormatG726 | SetFormatGSM | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatPCM | SetFormatRAW | SetFormatULAW | SetFormatVOX | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatDSP method

SetFormatDSP method

Sets the output format to DSP.

Syntax

object.SetFormatDSP()

The SetFormatDSP method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.

Remarks:

You should apply this method before saving DSP file by the Save method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
If TypeComp = 1 Then
Editor1.FileFormat.SetFormatADPCM Freq, Chann
ElseIf TypeComp = 2 Then
Editor1.FileFormat.SetFormatALAW Freq, Chann
ElseIf TypeComp = 3 Then
Editor1.FileFormat.SetFormatDSP
ElseIf TypeComp = 4 Then
Editor1.FileFormat.SetFormatGSM Freq
ElseIf TypeComp = 5 Then
Editor1.FileFormat.SetFormatMobileVoice Freq
ElseIf TypeComp = 6 Then
Editor1.FileFormat.SetFormatULAW Freq, Chann
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatALAW | SetFrmatFromMenu | SetFormatG721 | SetFormatG723 | SetFormatG726 | SetFormatGSM | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatPCM | SetFormatRAW | SetFormatULAW | SetFormatVOX | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatFromMenu method

SetFormatFromMenu method

Sets the output format of an audio file. This method calls the standard Windows menu in which you can pick up parameters of the output format.

Syntax

object.SetFormatFromMenu()

The SetFormatFromMenu method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.

Example:

' VB sample where Editor1.FileFormat is an AudioEditor2FileFormat object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.FileFormat.SetFormatFromMenu
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatALAW | SetFormatDSP | SetFormatG721 | SetFormatG723 | SetFormatG726 | SetFormatGSM | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatPCM | SetFormatRAW | SetFormatULAW | SetFormatVOX | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatG721 method

SetFormatG721 method

Sets the output format to G.721.

Syntax

object.SetFormatG721(Frequency As FrequencyConstants)

The SetFormatG721 method syntax has these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
Frequency | FrequencyConstants | Frequency of a G.721 audio file. By default is equal to FQ_8_KHZ.

Remarks:

You should apply this method before saving G.721 file by the Save method or opening it by the Open method.

Example:

' VB sample where Editor1 is an AudioEditor2FileFormat object.
Editor1.Open InputFile
If TypeComp = 1 Then
Editor1.FileFormat.SetFormatG721 FQ_16_KHZ
ElseIf TypeComp = 2 Then
Editor1.FileFormat.SetFormatG723 FQ_8_KHZ, BPS_5_BIT
ElseIf TypeComp = 3 Then
Editor1.FileFormat.SetFormatG726 FQ_16_KHZ, BPS_4_BIT
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatALAW | SetFormatDSP | SetFrmatFromMenu | SetFormatG723 | SetFormatG726 | SetFormatGSM | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatPCM | SetFormatRAW | SetFormatULAW | SetFormatVOX | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatG723 method

SetFormatG723 method

Sets the output format to G.723.

Syntax

object.SetFormatG723(Frequency As FrequencyConstants, BitsPerSample As BitsPerSampleConstants)

The SetFormatG723 method syntax has these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object of type .
Frequency | FrequencyConstants | Frequency of a G.723 audio file. By default is equal to FQ_8_KHZ.
BitsPerSample | BitsPerSampleConstants | Number of bits per sample of an audio file. By default the BitsPerSample is equal to BPS_3_BIT. Can accept BPS_3_BIT and BPS_5_BIT values.

Remarks:

You should apply this method before saving G.723 file by the Save method or opening it by the Open method.

Example:

' VB sample where Editor1 is an AudioEditor2FileFormat object.
Editor1.Open InputFile
If TypeComp = 1 Then
Editor1.FileFormat.SetFormatG721 FQ_16_KHZ
ElseIf TypeComp = 2 Then
Editor1.FileFormat.SetFormatG723 FQ_8_KHZ, BPS_5_BIT
ElseIf TypeComp = 3 Then
Editor1.FileFormat.SetFormatG726 FQ_16_KHZ, BPS_4_BIT
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatALAW | SetFormatDSP | SetFrmatFromMenu | SetFormatG721 | SetFormatG726 | SetFormatGSM | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatPCM | SetFormatRAW | SetFormatULAW | SetFormatVOX | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatG726 method

SetFormatG726 method

Sets the output format to G.726.

Syntax

object.SetFormatG726(Frequency As FrequencyConstants, BitsPerSample As BitsPerSampleConstants)

The SetFormatG726 method syntax has these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
Frequency | FrequencyConstants | Frequency of a G.726 audio file. By default is equal to FQ_8_KHZ.
BitsPerSample | BitsPerSampleConstants | Number of bits per sample of an audio file. By default the BitsPerSample is equal to BPS_4_BIT. The correct values of BitsPerSample for G.726 format are BPS_2_BIT, BPS_3_BIT, BPS_4_BIT and BPS_5_BIT.

Remarks:

You should apply this method before saving G.726 file by the Save method or opening it by the Open method.

Example:

' VB sample where Editor1 is an AudioEditor2FileFormat object.
Editor1.Open InputFile
If TypeComp = 1 Then
Editor1.FileFormat.SetFormatG721 FQ_16_KHZ
ElseIf TypeComp = 2 Then
Editor1.FileFormat.SetFormatG723 FQ_8_KHZ, BPS_5_BIT
ElseIf TypeComp = 3 Then
Editor1.FileFormat.SetFormatG726 FQ_16_KHZ, BPS_4_BIT
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatALAW | SetFormatDSP | SetFrmatFromMenu | SetFormatG721 | SetFormatG723 | SetFormatGSM | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatPCM | SetFormatRAW | SetFormatULAW | SetFormatVOX | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatGSM method

SetFormatGSM method

Sets the output format to GSM.

Syntax

object.SetFormatGSM(Frequency As FrequencyConstants)

The SetFormatGSM method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
Frequency | FrequencyConstants | By default the Frequency is equal to FQ_8_KHZ.

Remarks:

You should apply this method before saving GSM file by the Save method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
If TypeComp = 1 Then
Editor1.FileFormat.SetFormatADPCM Freq, Chann
ElseIf TypeComp = 2 Then
Editor1.FileFormat.SetFormatALAW Freq, Chann
ElseIf TypeComp = 3 Then
Editor1.FileFormat.SetFormatDSP
ElseIf TypeComp = 4 Then
Editor1.FileFormat.SetFormatGSM Freq
ElseIf TypeComp = 5 Then
Editor1.FileFormat.SetFormatMobileVoice Freq
ElseIf TypeComp = 6 Then
Editor1.FileFormat.SetFormatULAW Freq, Chann
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatALAW | SetFormatDSP | SetFrmatFromMenu | SetFormatG721 | SetFormatG723 | SetFormatG726 | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatPCM | SetFormatRAW | SetFormatULAW | SetFormatVOX | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatLikeSample method

SetFormatLikeSample method

Sets the output format of an audio file according to the format of the chosen sample file.

Syntax

object.SetFormatLikeSample(fileName As String)

The SetFormatLikeSample method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
fileName | String | The pathname of a sample audio file.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.FileFormat.SetFormatLikeSample FileName1
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatALAW | SetFormatDSP | SetFrmatFromMenu | SetFormatG721 | SetFormatG723 | SetFormatG726 | SetFormatGSM | SetFormatMP2 | SetFormatMP3 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatPCM | SetFormatRAW | SetFormatULAW | SetFormatVOX | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatMP2 method

SetFormatMP2 method

Sets the output format to MP2.

Return Type

A Boolean value.

Syntax

object.SetFormatMP2(Frequency As FrequencyConstants, Bitrate As BitrateConstants, nChannels As Integer)

The SetFormatMP2 method syntax has these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
Frequency | FrequencyConstants | Frequency of an MP2 file. By default the Frequency is equal to FQ_44_KHZ.
Bitrate | BitrateConstants | Bitrate of an MP2 file. By default the Bitrate is set to BR_128_KBPS.
nChannels | Integer | Can be one of following values: 1 - mono, 2 - stereo, 3 - joint stereo. By default is equal to 2.

Remarks:

You should apply this method before saving an MP2 file by the Save method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.FileFormat.Position.TotalSamples
Editor1.Transform.Invert
If Editor1.FileFormat.IsFormatMpegAvailable(FQ_22_KHZ, BR_192_KBPS, 3) = True Then 'MP2
Editor1.FileFormat.SetFormatMP2 FQ_22_KHZ, BR_192_KBPS, 3
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatALAW | SetFormatDSP | SetFrmatFromMenu | SetFormatG721 | SetFormatG723 | SetFormatG726 | SetFormatGSM | SetFormatLikeSample | SetFormatMP3 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatPCM | SetFormatRAW | SetFormatULAW | SetFormatVOX | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatMP3 method

SetFormatMP3 method

Sets the output format to MP3.

Syntax

object.SetFormatMP3(Frequency As FrequencyConstants, Bitrate As BitrateConstants, nChannels As ChannelsConstants)

The SetFormatMP3 method syntax has these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
Frequency | FrequencyConstants | Frequency of an MP3 file. By default the Frequency is equal to FQ_44_KHZ.
Bitrate | BitrateConstants | Bitrate of an MP3 file. By default the Bitrate is set to BR_128_KBPS.
nChannels | ChannelsConstants | Quantity of channels for an MP3 file. By default the nChannels is equal to STEREO.

Remarks:

You should apply this method before saving an MP3 file by the Save method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.FileFormat.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = FileFormat1.Position.TotalSamples
Editor1.Transform.Invert
If Editor1.FileFormat.IsFormatMpegAvailable(FQ_44_KHZ, BR_32_KBPS, STEREO) = True Then 'MP3
Editor1.FileFormat.SetFormatMP3 FQ_44_KHZ, BR_32_KBPS, STEREO
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatALAW | SetFormatDSP | SetFrmatFromMenu | SetFormatG721 | SetFormatG723 | SetFormatG726 | SetFormatGSM | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatPCM | SetFormatRAW | SetFormatULAW | SetFormatVOX | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatMP3Ex method

SetFormatMP3Ex method (AudioEditor2FileFormat object)

Sets the format with specific lame mp3 encoder parameters of an MP3 audio file.

Syntax

object.SetFormatMP3Ex(LameFormat As IAudioEditor2LameEnc)

The SetFormatMP3Ex method syntax has these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
LameFormat | AudioEditor2LameEnc | An expression evaluating to an object.

Remarks:

You should apply this method before saving an MP3 file by the Save method.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Lame.VbrCodingMethod = VBR_ABR
Lame.AbrBitrate = 128
Lame.VbrBitrate = BR_192_KBPS
Lame.WritingVBRHeader = True
Lame.StrictlyEnforceMinBitrate = False
Editor1.SetFormatMP3Ex Lame

See Also:

SetFormatADPCM | SetFormatALAW | SetFormatDSP | SetFrmatFromMenu | SetFormatG721 | SetFormatG723 | SetFormatG726 | SetFormatGSM | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3 | SetFormatOggVorbis | SetFormatPCM | SetFormatRAW | SetFormatULAW | SetFormatVOX | SetFormatWMA

Applies to: AudioEditor2FileFormat

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


SetFormatOggVorbis method

SetFormatOggVorbis method

Sets the output format to Ogg Vorbis.

Syntax

object.SetFormatOggVorbis(Frequency As FrequencyConstants, nChannels As ChannelsConstants, NominalBitrate As BitrateConstants, MinBitrate As BitrateConstants, MaxBitrate As BitrateConstants, Quality As Integer)

The SetFormatOggVorbis method syntax has these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
Frequency | FrequencyConstants | Frequency of an audio file. By default the Frequency is equal to FQ_44_KHZ.
nChannels | ChannelsConstants | Quantity of channels for an audio file. By default the nChannels is equal to STEREO.
NominalBitrate | BitrateConstants | Bitrate of an audio file. By default NominalBitrate is equal to BR_128_KBPS.
MinBitrate | BitrateConstants | Minimal bitrate. By default MinBitrate is equal to BR_NONE.
MaxBitrate | BitrateConstants | Maxilmal bitrate. By default MaxBitrate is equal to BR_NONE.
Quality | Integer | Varies from 0 (best quality and worse speed) to 1000 (worse quality and best speed).

Remarks:

You should apply this method before saving an Ogg Vorbis file by the Save method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Invert
If Editor1.FileFormat.IsFormatOggVorbisAvailable(, , Bitrate, MinBitrate, MaxBitrate) = True Then 'Ogg Vorbis
Editor1.FileFormat.SetFormatOggVorbis , , Bitrate, MinBitrate, MaxBitrate
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatALAW | SetFormatDSP | SetFrmatFromMenu | SetFormatG721 | SetFormatG723 | SetFormatG726 | SetFormatGSM | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3 | SetFormatMP3Ex | SetFormatPCM | SetFormatRAW | SetFormatULAW | SetFormatVOX | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatPCM method

SetFormatPCM method

Sets the output format to PCM.

Syntax

object.SetFormatPCM(Frequency As FrequencyConstants, nChannels As ChannelsConstants, BitsPerSample As BitsPerSampleConstants)

The SetFormatPCM method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
Frequency | FrequencyConstants | Frequency of a PCM audio file. By default the Frequency is equal to FQ_8_KHZ.
nChannels | ChannelsConstants | Quantity of channels for a PCM audio file. By default the nChannels is equal to MONO.
BitsPerSample | BitsPerSampleConstants | Quantity of bits per sample for a PCM audio file. By default the BitsPerSample is equal to BPS_16_BIT.

Remarks:

You should apply this method before saving a PCM file by the Save method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
If cmbTypeFile.ListIndex = 0 Then 'PCM
Editor1.FileFormat.SetFormatPCM FQ_22_KHZ, STEREO, BPS_8_BIT
ElseIf cmbTypeFile.ListIndex = 1 Then 'VOX
Editor1.FileFormat.SetFormatVOX FQ_24_KHZ
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatALAW | SetFormatDSP | SetFrmatFromMenu | SetFormatG721 | SetFormatG723 | SetFormatG726 | SetFormatGSM | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatRAW | SetFormatULAW | SetFormatVOX | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatRAW method

SetFormatRAW method

Sets the output format to RAW.

Syntax

object.SetFormatRAW(TypeCompress As RawTypeCompressConstants, Frequency As FrequencyConstants, nChannels As ChannelsConstants, BitsPerSample As BitsPerSampleConstants)

The SetFormatRAW method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
TypeCompress | RawTypeCompressConstants | The type of compression for a RAW file. By default the TypeCompress is equal to PCM.
Frequency | FrequencyConstants | Frequency of an audio file. By default the Frequency is equal to FQ_44_KHZ.
nChannels | ChannelsConstants | Quantity of channels for an audio file. By default the nChannels is equal to STEREO.
BitsPerSample | BitsPerSampleConstants | Quantity of bits per sample for an audio file. By default the BitsPerSample is equal to BPS_16_BIT.

Remarks:

You should apply this method before saving a RAW file by the Save method or opening it by the Open method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.FileFormat.SetFormatRAW ULAW, FQ_22_KHZ, STEREO, BPS_8_BIT
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatALAW | SetFormatDSP | SetFrmatFromMenu | SetFormatG721 | SetFormatG723 | SetFormatG726 | SetFormatGSM | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatPCM | SetFormatULAW | SetFormatVOX | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatULAW method

SetFormatULAW method

Sets the output format to U-law.

Syntax

object.SetFormatULAW(Frequency As FrequencyConstants, nChannels As ChannelsConstants)

The SetFormatULAW method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
Frequency | FrequencyConstants | Frequency of an audio file. By default the Frequency is equal to FQ_8_KHZ.
nChannels | ChannelsConstants | Quantity of channels for an audio file. By default the nChannels is equal to MONO.

Remarks:

You should apply this method before saving an ADPCM file by the Save method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
If TypeComp = 1 Then
Editor1.FileFormat.SetFormatADPCM Freq, Chann
ElseIf TypeComp = 2 Then
Editor1.FileFormat.SetFormatALAW Freq, Chann
ElseIf TypeComp = 3 Then
Editor1.FileFormat.SetFormatDSP
ElseIf TypeComp = 4 Then
Editor1.FileFormat.SetFormatGSM Freq
ElseIf TypeComp = 5 Then
Editor1.FileFormat.SetFormatMobileVoice Freq
ElseIf TypeComp = 6 Then
Editor1.FileFormat.SetFormatULAW Freq, Chann
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatALAW | SetFormatDSP | SetFrmatFromMenu | SetFormatG721 | SetFormatG723 | SetFormatG726 | SetFormatGSM | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatPCM | SetFormatRAW | SetFormatVOX | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatVOX method

SetFormatVOX method

Sets the output format to VOX.

Syntax

object.SetFormatVOX(Frequency As FrequencyConstants)

The SetFormatVOX method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
Frequency | FrequencyConstants | Frequency of a VOX audio file. By default the Frequency is equal to FQ_8_KHZ.

Remarks:

You should apply this method before saving a VOX file by the Save method or opening it by the Open method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
If cmbTypeFile.ListIndex = 0 Then 'PCM
Editor1.FileFormat.SetFormatPCM FQ_22_KHZ, STEREO, BPS_8_BIT
ElseIf cmbTypeFile.ListIndex = 1 Then 'VOX
Editor1.FileFormat.SetFormatVOX FQ_24_KHZ
End If
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatALAW | SetFormatDSP | SetFrmatFromMenu | SetFormatG721 | SetFormatG723 | SetFormatG726 | SetFormatGSM | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatPCM | SetFormatRAW | SetFormatULAW | SetFormatWMA

Apples To: AudioEditor2FileFormat


SetFormatWMA method

SetFormatWMA method

Sets the output format to WMA.

Syntax

object.SetFormatWMA(wmaProfile As Long)

The SetFormatWMA method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2FileFormat | An expression evaluating to an object.
wmaProfile | Long | Type of profile of the WMA audio file.

Remarks:

You should apply this method before saving a WMA file by the Save method.

At present it is possible to use only 51 profiles, which exist already. Here is the list.

Profile | Description | Profile name
1 | WMA 8,000 Hz; 16 Bit; Mono; 8 kbps. | Video for dial-up modems or single channel ISDN (28.8 to 56 Kbps)
2 | WMA 32,000 Hz; 16 Bit; Stereo; 32 kbps. | Video for LAN, cable modem, or xDSL (100 to 768 Kbps)
3 | WMA 8,000 Hz; 16 Bit; Mono; 8 kbps. | Video for dial-up modems or LAN (28.8 to 100 Kbps)
4 | WMA 8,000 Hz; 16 Bit; Mono; 4 kbps. | Video with voice emphasis for dial-up modems (28.8 Kbps)
5 | WMA 8,000 Hz; 16 Bit; Mono; 8 kbps. | Video with audio emphasis for dial-up modems (28.8 Kbps)
6 | WMA 8,000 Hz; 16 Bit; Mono; 8 kbps. | Video for Web servers (28.8 Kbps)
7 | WMA 11,025 Hz; 16 Bit; Mono; 10 kbps. | Video for Web servers (56 Kbps)
8 | WMA 11,025 Hz; 16 Bit; Mono; 10 kbps. | Video for single-channel ISDN (64 Kbps)
9 | WMA 16,000 Hz; 16 Bit; Mono; 16 kbps. | Video for e-mail and dual-channel ISDN (128 Kbps)
10 | WMA 32,000 Hz; 16 Bit; Stereo; 32 kbps. | Video for broadband NTSC (256 Kbps)
11 | WMA 32,000 Hz; 16 Bit; Stereo; 32 kbps. | Video for broadband NTSC (384 Kbps)
12 | WMA 44,100 Hz; 16 Bit; Stereo; 64 kbps. | Video for broadband NTSC (768 Kbps)
13 | WMA 44,100 Hz; 16 Bit; Stereo; 128 kbps. | Video for broadband NTSC (1500 Kbps total)
14 | WMA 44,100 Hz; 16 Bit; Stereo; 128 kbps. | Video for broadband NTSC (2 Mbps total)
15 | WMA 44,100 Hz; 16 Bit; Stereo; 128 kbps. | Video for broadband film content (768 Kbps)
16 | WMA 44,100 Hz; 16 Bit; Stereo; 128 kbps. | Video for broadband film content (1500 Kbps total)
17 | WMA 8,000 Hz; 16 Bit; Mono; 6 kbps. | Audio for low bit rate voice-oriented content (6.5 Kbps)
18 | WMA 22,050 Hz; 16 Bit; Mono; 20 kbps. | Audio for FM radio quality for dial-up modems (28.8 Kbps mono)
19 | WMA 22,050 Hz; 16 Bit; Stereo; 20 kbps. | Audio for FM radio quality for dial-up modems (28.8 Kbps stereo)
20 | WMA 32,000 Hz; 16 Bit; Stereo; 32 kbps. | Audio for dial-up modems (56 Kbps stereo)
21 | WMA 32,000 Hz; 16 Bit; Stereo; 48 kbps. | Audio for single-channel ISDN (64 Kbps stereo)
22 | WMA 44,100 Hz; 16 Bit; Stereo; 64 kbps. | Audio for near-CD quality (64 Kbps stereo)
23 | WMA 44,100 Hz; 16 Bit; Stereo; 96 kbps. | Audio for CD-quality (96 Kbps stereo)
24 | WMA 44,100 Hz; 16 Bit; Stereo; 128 kbps. | Audio for CD-quality transparency (128 Kbps stereo)
25 | WMA 22,050 Hz; 16 Bit; Stereo; 32 kbps. | Video for color PDA devices (225 Kbps)
26 | WMA 22,050 Hz; 16 Bit; Stereo; 32 kbps. | Video for color PDA devices (150 Kbps)
27 | WMA 22,050 Hz; 16 Bit; Stereo; 32 kbps. | Windows Media Video 8 for Color Pocket PCs (225 Kbps)
28 | WMA 22,050 Hz; 16 Bit; Stereo; 32 kbps. | Windows Media Video 8 for Color Pocket PCs (150 Kbps)
29 | WMA 8,000 Hz; 16 Bit; Mono; 8 kbps. | Windows Media Video 8 for Dial-up Modems or Single-channel ISDN (28.8 to 56 Kbps)
30 | WMA 32,000 Hz; 16 Bit; Stereo; 32 kbps. | Windows Media Video 8 for LAN, Cable Modem, or xDSL (100 to 768 Kbps)
31 | WMA 8,000 Hz; 16 Bit; Mono; 8 kbps. | Windows Media Video 8 for Dial-up Modems or LAN (28.8 to 100 Kbps)
32 | WMA 8,000 Hz; 16 Bit; Mono; 5 kbps. | Windows Media Video 8 for Dial-up Modems (28.8 Kbps)
33 | WMA 11,025 Hz; 16 Bit; Mono; 10 kbps. | Windows Media Video 8 for Dial-up Modems (56 Kbps)
34 | WMA 16,000 Hz; 16 Bit; Mono; 16 kbps. | Windows Media Video 8 for Local Area Network (100 Kbps)
35 | WMA 32,000 Hz; 16 Bit; Stereo; 40 kbps. | Windows Media Video 8 for Local Area Network (256 Kbps)
36 | WMA 32,000 Hz; 16 Bit; Stereo; 48 kbps. | Windows Media Video 8 for Local Area Network (384 Kbps)
37 | WMA 44,100 Hz; 16 Bit; Stereo; 64 kbps. | Windows Media Video 8 for Local Area Network (768 Kbps)
38 | WMA 44,100 Hz; 16 Bit; Stereo; 64 kbps. | Windows Media Video 8 for Broadband (NTSC, 700 Kbps)
39 | WMA 44,100 Hz; 16 Bit; Stereo; 128 kbps. | Windows Media Video 8 for Broadband (NTSC, 1400 Kbps)
40 | WMA 32,000 Hz; 16 Bit; Stereo; 48 kbps. | Windows Media Video 8 for Broadband (PAL, 384 Kbps)
41 | WMA 44,000 Hz; 16 Bit; Stereo; 64 kbps. | Windows Media Video 8 for Broadband (PAL, 700 Kbps)
42 | WMA 22,050 Hz; 16 Bit; Mono; 20 kbps. | Windows Media Audio 8 for Dial-up Modem (Mono, 28.8 Kbps)
43 | WMA 22,050 Hz; 16 Bit; Stereo; 20 kbps. | Windows Media Audio 8 for Dial-up Modem (FM Radio Stereo, 28.8 Kbps)
44 | WMA 32,000 Hz; 16 Bit; Stereo; 32 kbps. | Windows Media Audio 8 for Dial-up Modem (32 Kbps)
45 | WMA 44,100 Hz; 16 Bit; Stereo; 48 kbps. | Windows Media Audio 8 for Dial-up Modem (Near CD quality, 48 Kbps)
46 | WMA 44,100 Hz; 16 Bit; Stereo; 64 kbps. | Windows Media Audio 8 for Dial-up Modem (CD quality, 64 Kbps)
47 | WMA 44,100 Hz; 16 Bit; Stereo; 96 kbps. | Windows Media Audio 8 for ISDN (Better than CD quality, 96 Kbps)
48 | WMA 44,100 Hz; 16 Bit; Stereo; 128 kbps. | Windows Media Audio 8 for ISDN (Better than CD quality, 128 Kbps)
49 | WMA 44,100 Hz; 16 Bit; Stereo; 64 kbps. | Windows Media 8 Fair Quality based VBR for Broadband
50 | WMA 44,100 Hz; 16 Bit; Stereo; 64 kbps. | Windows Media 8 High Quality based VBR for Broadband.
51 | WMA 44,100 Hz; 16 Bit; Stereo; 64 kbps. | Windows Media 8 Best Quality based VBR for Broadband.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.FileFormat.SetFormatWMA 28
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SetFormatADPCM | SetFormatALAW | SetFormatDSP | SetFrmatFromMenu | SetFormatG721 | SetFormatG723 | SetFormatG726 | SetFormatGSM | SetFormatLikeSample | SetFormatMP2 | SetFormatMP3 | SetFormatMP3Ex | SetFormatOggVorbis | SetFormatPCM | SetFormatRAW | SetFormatULAW | SetFormatVOX

Apples To: AudioEditor2FileFormat


AudioEditor2FileInfo

AudioEditor2FileInfo object

Controls information about an audio file.


AudioEditor2FileInfo Properties

Properties (AudioEditor2FileInfo object)

Property | Type | Default | Description
Album | String |  | Gets or sets the string with the album name.
Artist | String |  | Gets or sets the string with the name of the artist. If there are many artists, the names are separated by a semicolon and a blank.
Channels | ChannelsConstants |  | Read-only property that returns a number of channels in an audio file. Mono data uses one channel and stereo data uses two channels.
Comments | String |  | Gets or sets the string with general comments about the audio file.
Composer | String |  | Gets or sets the string with the name of the composer who written the original music of the file.
Copyright | String |  | Gets or sets the string with the copyright information for an audio file.
EncodedBy | String |  | Gets or sets the string with information about the encoder.
FormatString | String |  | Read-only property that returns the string with information about the audio file's format.
Frequency | FrequencyConstants |  | Read-only property that returns the frequency of an audio file.
Genre | Integer |  | Gets or sets the genre or classification of an audio file.
GenreS | String |  | Gets or sets the genre or classification string of the audio file.
Mp3TagInfoVersion | Integer |  | Gets or sets version of MP3 audio file.
OriginalArtist | String |  | Gets or sets the string with the name of the artist who created the original subject of the file. If there are many artists, the names are separated by a semicolon and a blank.
SaveExtraInfoEnabled | Boolean |  | Gets or sets a flag indicating if information put to an audio file or not.
Title | String |  | Gets or sets the string with the title of an audio file.
Track | String |  | Gets or sets the number of track of the audio file's subject.
URL | String |  | Gets or sets the URL of the audio file's subject.
Year | Integer |  | Gets or sets the year when the audio file was created.


Album property (AudioEditor2FileInfo)

Album property (AudioEditor2FileInfo)

Gets or sets the string with the album name.

Property type

A String value.

Syntax

object.Album [= value]

The Album property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | String | The album name.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
infoTitle.Text = Info.Title
infoArtist.Text = Info.Artist
infoAlbum.Text = Info.Album
infoGenre.ListIndex = Info.Genre
infoCopyright.Text = Info.Copyright
infoComment.Text = Info.Comments
infoYear.Text = Info.Year
infoTrack.Text = Info.Track
infoURL.Text = Info.URL
infoEncodedBy.Text = Info.EncodedBy
infoComposer.Text = Info.Composer

See Also:

Artist | Channels | Comments | Composer | Copyright | EncodedBy | FormatString | Frequency | Genre | GenreS | Mp3TagInfoVersion | OriginalArtist | SaveExtraInfoEnabled | Title | Track | URL | Year

Apples To: AudioEditor2FileInfo


Artist property (AudioEditor2FileInfo)

Artist property (AudioEditor2FileInfo)

Gets or sets the string with the name of the artist. If there are many artists, the names are separated by a semicolon and a blank.

Property type

A String value.

Syntax

object.Artist [= value]

The Artist property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | String | The name of the artist.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
infoTitle.Text = Info.Title
infoArtist.Text = Info.Artist
infoAlbum.Text = Info.Album
infoGenre.ListIndex = Info.Genre
infoCopyright.Text = Info.Copyright
infoComment.Text = Info.Comments
infoYear.Text = Info.Year
infoTrack.Text = Info.Track
infoURL.Text = Info.URL
infoEncodedBy.Text = Info.EncodedBy
infoComposer.Text = Info.Composer

See Also:

Album | Channels | Comments | Composer | Copyright | EncodedBy | FormatString | Frequency | Genre | GenreS | Mp3TagInfoVersion | OriginalArtist | SaveExtraInfoEnabled | Title | Track | URL | Year

Apples To: AudioEditor2FileInfo


Channels property (AudioEditor2FileInfo)

Channels property (AudioEditor2FileInfo)

Read-only property that returns a number of channels in an audio file. Mono data uses one channel and stereo data uses two channels.

Property type

A ChannelsConstants value.

Syntax

[value = ]object.Channels

The Channels property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | ChannelsConstants | The number of channels in an audio file.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Form_Load()
    Dim ind As Long
    Freq = Editor1.FileInfo.Frequency
    Chan = Editor1.FileInfo.Channels
    Select Case Freq
        Case FQ_6_KHZ: ind = 0
        Case FQ_8_KHZ: ind = 1
        Case FQ_11_KHZ: ind = 2
        Case FQ_12_KHZ: ind = 3
        Case FQ_16_KHZ: ind = 4
        Case FQ_22_KHZ: ind = 5
        Case FQ_24_KHZ: ind = 6
        Case FQ_32_KHZ: ind = 7
        Case FQ_44_KHZ: ind = 8
        Case FQ_48_KHZ: ind = 9
    End Select
    opFq(ind).Value = True
    If Chan = MONO Then opCh(0).Value = True
    If Chan = STEREO Then opCh(1).Value = True
End Sub

See Also:

Album | Artist | Comments | Composer | Copyright | EncodedBy | FormatString | Frequency | Genre | GenreS | Mp3TagInfoVersion | OriginalArtist | SaveExtraInfoEnabled | Title | Track | URL | Year

Apples To: AudioEditor2FileInfo


Comments property (AudioEditor2FileInfo)

Comments property (AudioEditor2FileInfo)

Gets or sets the string with general comments about the audio file.

Property type

A String value.

Syntax

object.Comments [= value]

The Comments property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | String | The general comments about the audio file.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
infoTitle.Text = Info.Title
infoArtist.Text = Info.Artist
infoAlbum.Text = Info.Album
infoGenre.ListIndex = Info.Genre
infoCopyright.Text = Info.Copyright
infoComment.Text = Info.Comments
infoYear.Text = Info.Year
infoTrack.Text = Info.Track
infoURL.Text = Info.URL
infoEncodedBy.Text = Info.EncodedBy
infoComposer.Text = Info.Composer

See Also:

Album | Artist | Channels | Composer | Copyright | EncodedBy | FormatString | Frequency | Genre | GenreS | Mp3TagInfoVersion | OriginalArtist | SaveExtraInfoEnabled | Title | Track | URL | Year

Apples To: AudioEditor2FileInfo


Composer property (AudioEditor2FileInfo)

Composer property (AudioEditor2FileInfo)

Gets or sets the string with the name of the composer who written the original music of the file.

Property type

A String value.

Syntax

object.Composer [= value]

The Composer property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | String | Composer's name.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
infoTitle.Text = Info.Title
infoArtist.Text = Info.Artist
infoAlbum.Text = Info.Album
infoGenre.ListIndex = Info.Genre
infoCopyright.Text = Info.Copyright
infoComment.Text = Info.Comments
infoYear.Text = Info.Year
infoTrack.Text = Info.Track
infoURL.Text = Info.URL
infoEncodedBy.Text = Info.EncodedBy
infoComposer.Text = Info.Composer

See Also:

Album | Artist | Channels | Comments | Copyright | EncodedBy | FormatString | Frequency | Genre | GenreS | Mp3TagInfoVersion | OriginalArtist | SaveExtraInfoEnabled | Title | Track | URL | Year

Apples To: AudioEditor2FileInfo


Copyright property (AudioEditor2FileInfo)

Copyright property (AudioEditor2FileInfo)

Gets or sets the string with the copyright information for an audio file.

Property type

A String value.

Syntax

object.Copyright [= value]

The Copyright property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | String | The copyright information for an audio file.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
infoTitle.Text = Info.Title
infoArtist.Text = Info.Artist
infoAlbum.Text = Info.Album
infoGenre.ListIndex = Info.Genre
infoCopyright.Text = Info.Copyright
infoComment.Text = Info.Comments
infoYear.Text = Info.Year
infoTrack.Text = Info.Track
infoURL.Text = Info.URL
infoEncodedBy.Text = Info.EncodedBy
infoComposer.Text = Info.Composer

See Also:

Album | Artist | Channels | Comments | Composer | EncodedBy | FormatString | Frequency | Genre | GenreS | Mp3TagInfoVersion | OriginalArtist | SaveExtraInfoEnabled | Title | Track | URL | Year

Apples To: AudioEditor2FileInfo


EncodedBy property (AudioEditor2FileInfo)

EncodedBy property (AudioEditor2FileInfo)

Gets or sets the string with information about the encoder.

Property type

A String value.

Syntax

object.EncodedBy [= value]

The EncodedBy property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | String | Type of encoder.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
infoTitle.Text = Info.Title
infoArtist.Text = Info.Artist
infoAlbum.Text = Info.Album
infoGenre.ListIndex = Info.Genre
infoCopyright.Text = Info.Copyright
infoComment.Text = Info.Comments
infoYear.Text = Info.Year
infoTrack.Text = Info.Track
infoURL.Text = Info.URL
infoEncodedBy.Text = Info.EncodedBy
infoComposer.Text = Info.Composer

See Also:

Album | Artist | Channels | Comments | Composer | Copyright | FormatString | Frequency | Genre | GenreS | Mp3TagInfoVersion | OriginalArtist | SaveExtraInfoEnabled | Title | Track | URL | Year

Apples To: AudioEditor2FileInfo


FormatString property (AudioEditor2FileInfo)

FormatString property (AudioEditor2FileInfo)

Read-only property that returns the string with information about the audio file's format.

Property type

A String value.

Syntax

[value = ]object.FormatString

The FormatString property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | String | The string with information about the audio file's format.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
infoTitle.Text = Info.Title
infoArtist.Text = Info.Artist
infoAlbum.Text = Info.Album
infoGenre.ListIndex = Info.Genre
infoCopyright.Text = Info.Copyright
infoComment.Text = Info.Comments
infoYear.Text = Info.Year
infoTrack.Text = Info.Track
infoURL.Text = Info.URL
infoEncodedBy.Text = Info.EncodedBy
infoComposer.Text = Info.Composer
infoFormat.Text = Info.FormatString & Str(Info.Mp3TagInfoVersion)

See Also:

Album | Artist | Channels | Comments | Composer | Copyright | EncodedBy | Frequency | Genre | GenreS | Mp3TagInfoVersion | OriginalArtist | SaveExtraInfoEnabled | Title | Track | URL | Year

Apples To: AudioEditor2FileInfo


Frequency property (AudioEditor2FileInfo)

Frequency property (AudioEditor2FileInfo)

Read-only property that returns the frequency of an audio file.

Property type

A FrequencyConstants value.

Syntax

[value = ]object.Frequency

The Frequency property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | FrequencyConstants | The frequency of an audio file.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Private Sub Form_Load()
    Dim ind As Long
    Freq = Editor1.FileInfo.Frequency
    Chan = Editor1.FileInfo.Channels
    Select Case Freq
        Case FQ_6_KHZ: ind = 0
        Case FQ_8_KHZ: ind = 1
        Case FQ_11_KHZ: ind = 2
        Case FQ_12_KHZ: ind = 3
        Case FQ_16_KHZ: ind = 4
        Case FQ_22_KHZ: ind = 5
        Case FQ_24_KHZ: ind = 6
        Case FQ_32_KHZ: ind = 7
        Case FQ_44_KHZ: ind = 8
        Case FQ_48_KHZ: ind = 9
    End Select
    opFq(ind).Value = True
    If Chan = MONO Then opCh(0).Value = True
    If Chan = STEREO Then opCh(1).Value = True
End Sub

See Also:

Album | Artist | Channels | Comments | Composer | Copyright | EncodedBy | FormatString | Genre | GenreS | Mp3TagInfoVersion | OriginalArtist | SaveExtraInfoEnabled | Title | Track | URL | Year

Apples To: AudioEditor2FileInfo


Genre property (AudioEditor2FileInfo)

Genre property (AudioEditor2FileInfo)

Gets or sets the genre or classification of an audio file.

Property type

A Integer value.

Syntax

object.Genre [= value]

The Genre property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | Integer | The genre or classification of an audio file.

Remarks:

You can get Genre description using GenreToString method or GenreS property. For more information about Genres go to Genre page.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
infoTitle.Text = Info.Title
infoArtist.Text = Info.Artist
infoAlbum.Text = Info.Album
infoGenre.ListIndex = Info.Genre
infoCopyright.Text = Info.Copyright
infoComment.Text = Info.Comments
infoYear.Text = Info.Year
infoTrack.Text = Info.Track
infoURL.Text = Info.URL
infoEncodedBy.Text = Info.EncodedBy
infoComposer.Text = Info.Composer

See Also:

Album | Artist | Channels | Comments | Composer | Copyright | EncodedBy | FormatString | Frequency | GenreS | Mp3TagInfoVersion | OriginalArtist | SaveExtraInfoEnabled | Title | Track | URL | Year

Apples To: AudioEditor2FileInfo


GenreS property (AudioEditor2FileInfo)

GenreS property (AudioEditor2FileInfo object)

Gets or sets the genre or classification string of the audio file.

Property type

A String value.

Syntax

object.GenreS [= value]

The GenreS property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | String | The genre or classification of the audio file.

Remarks:

For more information about Genres go to Genre page.

See Also:

Album | Artist | Channels | Comments | Composer | Copyright | EncodedBy | FormatString | Frequency | Genre | Mp3TagInfoVersion | OriginalArtist | SaveExtraInfoEnabled | Title | Track | URL | Year

Applies to: AudioEditor2FileInfo

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


Mp3TagInfoVersion property (AudioEditor2FileInfo)

Mp3TagInfoVersion property (AudioEditor2FileInfo)

Gets or sets version of MP3 audio file.

Property type

A Integer value.

Syntax

object.Mp3TagInfoVersion [= value]

The Mp3TagInfoVersion property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | Integer | Can be one of following values: 1 - first version, 2 - second version.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
infoTitle.Text = Info.Title
infoArtist.Text = Info.Artist
infoAlbum.Text = Info.Album
infoGenre.ListIndex = Info.Genre
infoCopyright.Text = Info.Copyright
infoComment.Text = Info.Comments
infoYear.Text = Info.Year
infoTrack.Text = Info.Track
infoURL.Text = Info.URL
infoEncodedBy.Text = Info.EncodedBy
infoComposer.Text = Info.Composer
infoFormat.Text = Info.FormatString & Str(Info.Mp3TagInfoVersion)

See Also:

Album | Artist | Channels | Comments | Composer | Copyright | EncodedBy | FormatString | Frequency | Genre | GenreS | OriginalArtist | SaveExtraInfoEnabled | Title | Track | URL | Year

Apples To: AudioEditor2FileInfo


OriginalArtist property (AudioEditor2FileInfo)

OriginalArtist property (AudioEditor2FileInfo object)

Gets or sets the string with the name of the artist who created the original subject of the file. If there are many artists, the names are separated by a semicolon and a blank.

Property type

A String value.

Syntax

object.OriginalArtist [= value]

The OriginalArtist property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | String | Artist's name.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
infoTitle.Text = Info.Title
infoArtist.Text = Info.Artist
infoOriginalArtist.Text = Info.OriginalArtist
infoAlbum.Text = Info.Album
infoGenre.ListIndex = Info.Genre
infoCopyright.Text = Info.Copyright
infoComment.Text = Info.Comments
infoYear.Text = Info.Year
infoTrack.Text = Info.Track
infoURL.Text = Info.URL
infoEncodedBy.Text = Info.EncodedBy
infoComposer.Text = Info.Composer

See Also:

Album | Artist | Channels | Comments | Composer | Copyright | EncodedBy | FormatString | Frequency | Genre | GenreS | Mp3TagInfoVersion | SaveExtraInfoEnabled | Title | Track | URL | Year

Applies to: AudioEditor2FileInfo

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


SaveExtraInfoEnabled property (AudioEditor2FileInfo)

SaveExtraInfoEnabled property (AudioEditor2FileInfo)

Gets or sets a flag indicating if information put to an audio file or not.

Property type

A Boolean value.

Syntax

object.SaveExtraInfoEnabled [= value]

The SaveExtraInfoEnabled property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | Boolean | True if information read to the file, otherwise - False.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
Info.SaveExtraInfoEnabled = True
Info.Year = 2002

See Also:

Album | Artist | Channels | Comments | Composer | Copyright | EncodedBy | FormatString | Frequency | Genre | GenreS | Mp3TagInfoVersion | OriginalArtist | Title | Track | URL | Year

Apples To: AudioEditor2FileInfo


Title property (AudioEditor2FileInfo)

Title property (AudioEditor2FileInfo)

Gets or sets the string with the title of an audio file.

Property type

A String value.

Syntax

object.Title [= value]

The Title property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | String |

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
infoTitle.Text = Info.Title
infoArtist.Text = Info.Artist
infoAlbum.Text = Info.Album
infoGenre.ListIndex = Info.Genre
infoCopyright.Text = Info.Copyright
infoComment.Text = Info.Comments
infoYear.Text = Info.Year
infoTrack.Text = Info.Track
infoURL.Text = Info.URL
infoEncodedBy.Text = Info.EncodedBy
infoComposer.Text = Info.Composer

See Also:

Album | Artist | Channels | Comments | Composer | Copyright | EncodedBy | FormatString | Frequency | Genre | GenreS | Mp3TagInfoVersion | OriginalArtist | SaveExtraInfoEnabled | Track | URL | Year

Apples To: AudioEditor2FileInfo


Track property (AudioEditor2FileInfo)

Track property (AudioEditor2FileInfo)

Gets or sets the number of track of the audio file's subject.

Property type

A Integer value.

Syntax

object.Track [= value]

The Track property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | Integer | Number of track.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
infoTitle.Text = Info.Title
infoArtist.Text = Info.Artist
infoAlbum.Text = Info.Album
infoGenre.ListIndex = Info.Genre
infoCopyright.Text = Info.Copyright
infoComment.Text = Info.Comments
infoYear.Text = Info.Year
infoTrack.Text = Info.Track
infoURL.Text = Info.URL
infoEncodedBy.Text = Info.EncodedBy
infoComposer.Text = Info.Composer

See Also:

Album | Artist | Channels | Comments | Composer | Copyright | EncodedBy | FormatString | Frequency | Genre | GenreS | Mp3TagInfoVersion | OriginalArtist | SaveExtraInfoEnabled | Title | URL | Year

Apples To: AudioEditor2FileInfo


URL property (AudioEditor2FileInfo)

URL property (AudioEditor2FileInfo)

Gets or sets the URL of the audio file's subject.

Property type

A String value.

Syntax

object.URL [= value]

The URL property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | String | The URL of the audio file's subject.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
infoTitle.Text = Info.Title
infoArtist.Text = Info.Artist
infoAlbum.Text = Info.Album
infoGenre.ListIndex = Info.Genre
infoCopyright.Text = Info.Copyright
infoComment.Text = Info.Comments
infoYear.Text = Info.Year
infoTrack.Text = Info.Track
infoURL.Text = Info.URL
infoEncodedBy.Text = Info.EncodedBy
infoComposer.Text = Info.Composer

See Also:

Album | Artist | Channels | Comments | Composer | Copyright | EncodedBy | FormatString | Frequency | Genre | GenreS | Mp3TagInfoVersion | OriginalArtist | SaveExtraInfoEnabled | Title | Track | Year

Apples To: AudioEditor2FileInfo


Year property (AudioEditor2FileInfo)

Year property (AudioEditor2FileInfo)

Gets or sets the year when the audio file was created.

Property type

A Long value.

Syntax

object.Year [= value]

The Year property syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
value | Long | The year when the audio file was created.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
infoTitle.Text = Info.Title
infoArtist.Text = Info.Artist
infoAlbum.Text = Info.Album
infoGenre.ListIndex = Info.Genre
infoCopyright.Text = Info.Copyright
infoComment.Text = Info.Comments
infoYear.Text = Info.Year
infoTrack.Text = Info.Track
infoURL.Text = Info.URL
infoEncodedBy.Text = Info.EncodedBy
infoComposer.Text = Info.Composer

See Also:

Album | Artist | Channels | Comments | Composer | Copyright | EncodedBy | FormatString | Frequency | Genre | GenreS | Mp3TagInfoVersion | OriginalArtist | SaveExtraInfoEnabled | Title | Track | URL

Apples To: AudioEditor2FileInfo


AudioEditor2FileInfo Methods

Methods (AudioEditor2FileInfo object)

Method | Description
GenreToString | Attaches the string with the audio file's genre to the Integer value got from the audio file.


GenreToString method

GenreToString method

Attaches the string with the audio file's genre to the Integer value got from the audio file.

Return Type

A String value.

Syntax

sGenre = object.GenreToString(nGenre As Integer)

The GenreToString method syntax has these parts:

Part | Type | Description
object | AudioEditor2FileInfo | An expression evaluating to an object.
nGenre | Integer | Genre number.
sGenre | String | Genre string.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Info As AudioEditor2FileInfo
infoTitle.Text = Info.Title
infoArtist.Text = Info.Artist
infoAlbum.Text = Info.Album
infoGenre.Text = Info.GenreToString Info.Genre
infoCopyright.Text = Info.Copyright
infoComment.Text = Info.Comments
infoYear.Text = Info.Year
infoTrack.Text = Info.Track
infoURL.Text = Info.URL
infoEncodedBy.Text = Info.EncodedBy
infoComposer.Text = Info.Composer

You can get genre number from Genre property.

See Also:

Apples To: AudioEditor2FileInfo


AudioEditor2LameEnc

AudioEditor2LameEnc object

The AudioEditor2LameEnc object is intended for changing parameters of lame mp3 encoder.


AudioEditor2LameEnc Properties

Properties (AudioEditor2LameEnc object)

Property | Type | Default | Description
AbrBitrate | Integer |  | Gets or sets maximum ABR/VBR bitrate.
ATHControlMode | Integer |  | Gets or sets ATH (absolute threshold of hearing).
Bitrate | BitrateConstants | BR_128_KBPS | Gets or sets bitrate of an MP3 Editor.
BitReservoir | Boolean | True | Gets or sets a flag indicating if bit reservoir is used or not. Each frame will then become independent from previous ones, but the quality will be lower.
BlockTypeControl | Boolean |  | Gets or sets a flag indicating if block type control is enabled or not. The block type control allows block types to differ between channels.
Channels | ChannelsConstants |  | Gets or sets the number of channels in the MP3 Editor.
Emphasis | Integer |  | Gets or sets type of emphasis of the audio array.
EncoderQuality | Integer |  | Gets or sets a quality of encoder.
ErrorProtection | Boolean |  | Gets or sets a flag indicating if error protection is enabled or not.
Frequency | FrequencyConstants | FQ_44_KHZ | Gets or sets the frequency of an MP3 Editor.
HighPassFrequency | Long |  | Gets or sets frequency for high pass filtering.
HighPassWidth | Long |  | Gets or sets width of high pass filtering.
LowPassFrequency | Long |  | Gets or sets frequency for low pass filtering.
LowPassWidth | Long |  | Gets or sets width of low pass filtering.
ShortBlocks | Boolean |  | Gets or sets a flag indicating if short blocks are used or not.
StrictISOCompliance | Boolean |  | Gets or sets a flag indicating if ISO MPEG specification is enable or not.
StrictlyEnforceMinBitrate | Boolean |  | Gets or sets a flag indicating if minimum bitrate is enforced or not.
TypeStereo | Mp3LameTypeStereoConstants |  | Gets or sets a type of stereo realization.
VbrBitrate | BitrateConstants |  | Gets or sets VBR bitrate.
VbrCodingMethod | Mp3LameMethodConstants |  | Gets or sets a type of lame method.
VbrQuality | Integer |  | Gets or sets VBR quality.
WritingVBRHeader | Boolean |  | Gets or sets a flag indicating if VBR header is included to audio Editor or not.


AbrBitrate property (AudioEditor2LameEnc)

AbrBitrate property (AudioEditor2LameEnc)

Gets or sets maximum ABR/VBR bitrate.

Property type

A Integer value.

Syntax

object.AbrBitrate [= value]

The AbrBitrate property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Integer | Maximum ABR/VBR bitrate. Varies from 10 to 310.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Lame.VbrCodingMethod = VBR_ABR
Lame.AbrBitrate = 128
Lame.VbrBitrate = BR_192_KBPS
Lame.WritingVBRHeader = True
Lame.StrictlyEnforceMinBitrate = False
Editor1.SetFormatMP3Ex Lame

See Also:

Apples To: AudioEditor2LameEnc


ATHControlMode property (AudioEditor2LameEnc)

ATHControlMode property (AudioEditor2LameEnc)

Gets or sets ATH (absolute threshold of hearing).

Property type

A Integer value.

Syntax

object.ATHControlMode [= value]

The ATHControlMode property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Integer | Can be one of following values: 1 - default, 2 - ATH only (ignore psychoacoustics model, use ATH only), 3 - disable ATH (use psychoacoustics model only), 4 - ATH only for short block (ignore psychoacoustics model for short blocks, use ATH only).

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Lame.ATHControlMode = 4
Lame.ShortBlocks = True
Lame.BitReservoir = True
Editor1.SetFormatMP3Ex Lame

See Also:

Apples To: AudioEditor2LameEnc


Bitrate property (AudioEditor2LameEnc)

Bitrate property (AudioEditor2LameEnc)

Gets or sets bitrate of an MP3 file.

Property type

A BitrateConstants value.

Syntax

object.Bitrate [= value]

The Bitrate property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | BitrateConstants | Bitrate of the MP3 file. By default the value is set to BR_128_KBPS.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Editor1.SetFormatMP3Ex Lame

See Also:

Apples To: AudioEditor2LameEnc


BitReservoir property (AudioEditor2LameEnc)

BitReservoir property (AudioEditor2LameEnc)

Gets or sets a flag indicating if bit reservoir is used or not. Each frame will then become independent from previous ones, but the quality will be lower.

Property type

A Boolean value.

Syntax

object.BitReservoir [= value]

The BitReservoir property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Boolean | Can be True (bit reservoir is used) or False (bit reservoir isn't used). By default is True.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Lame.ATHControlMode = 4
Lame.ShortBlocks = True
Lame.BitReservoir = True
Editor1.SetFormatMP3Ex Lame

See Also:

Apples To: AudioEditor2LameEnc


BlockTypeControl property (AudioEditor2LameEnc)

BlockTypeControl property (AudioEditor2LameEnc)

Gets or sets a flag indicating if block type control is enabled or not. The block type control allows block types to differ between channels.

Property type

A Boolean value.

Syntax

object.BlockTypeControl [= value]

The BlockTypeControl property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Boolean | Can be True (block type control is enabled) or False (block type control is disabled).

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = FQ_24_KHZ
Lame.Bitrate = BR_160_KBPS
Lame.Channels = 2
Lame.ATHControlMode = 4
Lame.ShortBlocks = True
Lame.BitReservoir = True
Lame.BlockTypeControl = False
Lame.StrictISOCompliance = False
Lame.Emphasis = 3
Editor1.SetFormatMP3Ex Lame

See Also:

Apples To: AudioEditor2LameEnc


Channels property (AudioEditor2LameEnc)

Channels property (AudioEditor2LameEnc)

Gets or sets the number of channels in the MP3 file. Monaural data uses one channel and stereo data uses two channels.

Property type

A ChannelsConstants value.

Syntax

object.Channels [= value]

The Channels property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | ChannelsConstants | Quantity of channels for an MP3 file. By default the value is equal to STEREO.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Editor1.SetFormatMP3Ex Lame

See Also:

Apples To: AudioEditor2LameEnc


Emphasis property (AudioEditor2LameEnc)

Emphasis property (AudioEditor2LameEnc)

Gets or sets type of emphasis of the audio array.

Property type

A Integer value.

Syntax

object.Emphasis [= value]

The Emphasis property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Integer | Can be one f following values: 1 - none (default), 2 0/15 microseconds, 3 - citt j.17.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = FQ_24_KHZ
Lame.Bitrate = BR_160_KBPS
Lame.Channels = 2
Lame.ATHControlMode = 4
Lame.ShortBlocks = True
Lame.BitReservoir = True
Lame.BlockTypeControl = False
Lame.StrictISOCompliance = False
Lame.Emphasis = 3
Editor1.SetFormatMP3Ex Lame

See Also:

Apples To: AudioEditor2LameEnc


EncoderQuality property (AudioEditor2LameEnc)

EncoderQuality property (AudioEditor2LameEnc)

Gets or sets a quality of encoder.

Property type

A Integer value.

Syntax

object.EncoderQuality [= value]

The EncoderQuality property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Integer | Varies from 0 (best quality and worse speed) to 9 (worse quality and best speed).

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Lame.EncoderQuality = 7
Lame.TypeStereo = 2
Editor1.SetFormatMP3Ex Lame

See Also:

Apples To: AudioEditor2LameEnc


ErrorProtection property (AudioEditor2LameEnc)

ErrorProtection property (AudioEditor2LameEnc)

Gets or sets a flag indicating if error protection is enabled or not.

Property type

A Boolean value.

Syntax

object.ErrorProtection [= value]

The ErrorProtection property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Boolean | Can be True (error protection is enabled) or False (error protection is disabled).

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Lame.EncoderQuality = 7
Lame.TypeStereo = 2
Lame.ErrorProtection = True
Editor1.SetFormatMP3Ex Lame

See Also:

Apples To: AudioEditor2LameEnc


Frequency property (AudioEditor2LameEnc)

Frequency property (AudioEditor2LameEnc)

Gets or sets the frequency of an MP3 file.

Property type

A FrequencyConstants value.

Syntax

object.Frequency [= value]

The Frequency property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | FrequencyConstants | Frequency of the MP3 file. By default the value is equal to FQ_44_KHZ.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Editor1.SetFormatMP3Ex Lame

See Also:

Apples To: AudioEditor2LameEnc


HighPassFrequency property (AudioEditor2LameEnc)

HighPassFrequency property (AudioEditor2LameEnc)

Gets or sets frequency for high pass filtering.

Property type

A Long value.

Syntax

object.HighPassFrequency [= value]

The HighPassFrequency property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Long | Frequency, in hertz.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = FQ_24_KHZ
Lame.Bitrate = BR_160_KBPS
Lame.Channels = 2
Lame.ATHControlMode = 4
Lame.ShortBlocks = True
Lame.BitReservoir = True
Lame.BlockTypeControl = False
Lame.StrictISOCompliance = False
Lame.Emphasis = 3
Lame.HighPassFrequency = 30
Lame.HighPassWidth = 5
Lame.LowPassFrequency = 15160
Lame.LowPassWidth = 760
Editor1.SetFormatMP3Ex Lame

See Also:

HighPassWidth | LowPassFrequency | LowPassWidth

Apples To: AudioEditor2LameEnc


HighPassWidth property (AudioEditor2LameEnc)

HighPassWidth property (AudioEditor2LameEnc)

Gets or sets width of high pass filtering.

Property type

A Long value.

Syntax

object.HighPassWidth [= value]

The HighPassWidth property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Long | Width of high pass filtering, in hertz.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = FQ_24_KHZ
Lame.Bitrate = BR_160_KBPS
Lame.Channels = 2
Lame.ATHControlMode = 4
Lame.ShortBlocks = True
Lame.BitReservoir = True
Lame.BlockTypeControl = False
Lame.StrictISOCompliance = False
Lame.Emphasis = 3
Lame.HighPassFrequency = 30
Lame.HighPassWidth = 5
Lame.LowPassFrequency = 15160
Lame.LowPassWidth = 760
Editor1.SetFormatMP3Ex Lame

See Also:

HighPassFrequency | LowPassFrequency | LowPassWidth

Apples To: AudioEditor2LameEnc


LowPassFrequency property (AudioEditor2LameEnc)

LowPassFrequency property (AudioEditor2LameEnc)

Gets or sets frequency for low pass filtering.

Property type

A Long value.

Syntax

object.LowPassFrequency [= value]

The LowPassFrequency property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Long | Frequency, in hertz.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = FQ_24_KHZ
Lame.Bitrate = BR_160_KBPS
Lame.Channels = 2
Lame.ATHControlMode = 4
Lame.ShortBlocks = True
Lame.BitReservoir = True
Lame.BlockTypeControl = False
Lame.StrictISOCompliance = False
Lame.Emphasis = 3
Lame.HighPassFrequency = 30
Lame.HighPassWidth = 5
Lame.LowPassFrequency = 15160
Lame.LowPassWidth = 760
Editor1.SetFormatMP3Ex Lame

See Also:

HighPassFrequency | HighPassWidth | LowPassWidth

Apples To: AudioEditor2LameEnc


LowPassWidth property (AudioEditor2LameEnc)

LowPassWidth property (AudioEditor2LameEnc)

Gets or sets width of low pass filtering.

Property type

A Long value.

Syntax

object.LowPassWidth [= value]

The LowPassWidth property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Long | Width of low pass filtering, in hertz.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = FQ_24_KHZ
Lame.Bitrate = BR_160_KBPS
Lame.Channels = 2
Lame.ATHControlMode = 4
Lame.ShortBlocks = True
Lame.BitReservoir = True
Lame.BlockTypeControl = False
Lame.StrictISOCompliance = False
Lame.Emphasis = 3
Lame.HighPassFrequency = 30
Lame.HighPassWidth = 5
Lame.LowPassFrequency = 15160
Lame.LowPassWidth = 760
Editor1.SetFormatMP3Ex Lame

See Also:

HighPassFrequency | HighPassWidth | LowPassFrequency

Apples To: AudioEditor2LameEnc


ShortBlocks property (AudioEditor2LameEnc)

ShortBlocks property (AudioEditor2LameEnc)

Gets or sets a flag indicating if short blocks are used or not.

Property type

A Boolean value.

Syntax

object.ShortBlocks [= value]

The ShortBlocks property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object of type .
value | Boolean | Can be True (short blocks are used) or False (short blocks aren't used).

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Lame.ATHControlMode = 4
Lame.ShortBlocks = True
Lame.BitReservoir = True
Editor1.SetFormatMP3Ex Lame

See Also:

Apples To: AudioEditor2LameEnc


StrictISOCompliance property (AudioEditor2LameEnc)

StrictISOCompliance property (AudioEditor2LameEnc)

Gets or sets a flag indicating if ISO MPEG specification is enable or not.

Property type

A Boolean value.

Syntax

object.StrictISOCompliance [= value]

The StrictISOCompliance property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Boolean | Can be True (ISO MPEG specification is enable) or False (ISO MPEG specification is disable).

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = FQ_24_KHZ
Lame.Bitrate = BR_160_KBPS
Lame.Channels = 2
Lame.ATHControlMode = 4
Lame.ShortBlocks = True
Lame.BitReservoir = True
Lame.BlockTypeControl = False
Lame.StrictISOCompliance = False
Lame.Emphasis = 3
Editor1.SetFormatMP3Ex Lame

See Also:

Apples To: AudioEditor2LameEnc


StrictlyEnforceMinBitrate property (AudioEditor2LameEnc)

StrictlyEnforceMinBitrate property (AudioEditor2LameEnc)

Gets or sets a flag indicating if minimum bitrate is enforced or not.

Property type

A Boolean value.

Syntax

object.StrictlyEnforceMinBitrate [= value]

The StrictlyEnforceMinBitrate property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Boolean | False if the minimum bitrate is ignored for passages of analog silence, otherwise -True.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Lame.CodingMethod = VBR_ABR
Lame.AbrBitrate = 128
Lame.VbrBitrate = BR_192_KBPS
Lame.WritingVBRHeader = True
Lame.StrictlyEnforceMinBitrate = False
Editor1.SetFormatMP3Ex Lame

See Also:

Apples To: AudioEditor2LameEnc


TypeStereo property (AudioEditor2LameEnc)

TypeStereo property (AudioEditor2LameEnc)

Gets or sets a type of stereo realization.

Property type

A Mp3LameTypeStereoConstants value.

Syntax

object.TypeStereo [= value]

The TypeStereo property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Mp3LameTypeStereoConstants | Type of stereo.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Lame.EncoderQuality = 7
Lame.TypeStereo = 2
Editor1.SetFormatMP3Ex Lame

See Also:

Apples To: AudioEditor2LameEnc


VbrBitrate property (AudioEditor2LameEnc)

VbrBitrate property (AudioEditor2LameEnc)

Gets or sets VBR bitrate.

Property type

A BitrateConstants value.

Syntax

object.VbrBitrate [= value]

The VbrBitrate property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | BitrateConstants | Type of bitrate.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Lame.CodingMethod = VBR_ABR
Lame.AbrBitrate = 128
Lame.VbrBitrate = BR_192_KBPS
Lame.WritingVBRHeader = True
Lame.StrictlyEnforceMinBitrate = False
Editor1.SetFormatMP3Ex Lame

See Also:

VbrCodingMethod | VbrQuality | WritingVBRHeader

Apples To: AudioEditor2LameEnc


VbrCodingMethod property (AudioEditor2LameEnc)

VbrCodingMethod property (AudioEditor2LameEnc)

Gets or sets a type of lame method.

Property type

A Mp3LameMethodConstants value.

Syntax

object.VbrCodingMethod [= value]

The VbrCodingMethod property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Mp3LameMethodConstants | Type of lame method.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Lame.CodingMethod = VBR_ABR
Lame.AbrBitrate = 128
Lame.VbrBitrate = BR_192_KBPS
Lame.WritingVBRHeader = True
Lame.StrictlyEnforceMinBitrate = False
Editor1.SetFormatMP3Ex Lame

See Also:

VbrBitrate | VbrQuality | WritingVBRHeader

Apples To: AudioEditor2LameEnc


VbrQuality property (AudioEditor2LameEnc)

VbrQuality property (AudioEditor2LameEnc)

Gets or sets VBR quality.

Property type

A Integer value.

Syntax

object.VbrQuality [= value]

The VbrQuality property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Integer | Varies from 0 (best quality and worse speed) to 9 (worse quality and best speed).

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Lame.CodingMethod = VBR_NEW
Lame.VbrQuality = 7
Lame.VbrBitrate = BR_192_KBPS
Lame.WritingVBRHeader = True
Lame.StrictlyEnforceMinBitrate = False
Editor1.SetFormatMP3Ex Lame

See Also:

VbrBitrate | VbrCodingMethod | WritingVBRHeader

Apples To: AudioEditor2LameEnc


WritingVBRHeader property (AudioEditor2LameEnc)

WritingVBRHeader property (AudioEditor2LameEnc)

Gets or sets a flag indicating if VBR header is included to audio file or not.

Property type

A Boolean value.

Syntax

object.WritingVBRHeader [= value]

The WritingVBRHeader property syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
value | Boolean | Can be true (VBR header is included) or false (VBR header isn't included).

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.Frequency = Frequency
Lame.Bitrate = Bitrate
Lame.Channels = Channels
Lame.CodingMethod = VBR_ABR
Lame.AbrBitrate = 128
Lame.VbrBitrate = BR_192_KBPS
Lame.WritingVBRHeader = True
Lame.StrictlyEnforceMinBitrate = False
Editor1.SetFormatMP3Ex Lame

See Also:

VbrBitrate | VbrCodingMethod | VbrQuality

Apples To: AudioEditor2LameEnc


AudioEditor2LameEnc Methods

Methods (AudioEditor2LameEnc object)

Method | Description
SetParamsFromAltPreset | Sets parameters of lame mp3 encoder from "alternate" preset.
SetParamsFromCommandLine | Sets parameters of lame mp3 encoder from command line.
SetParamsFromPreset | Sets parameters of lame mp3 encoder from preset.


SetParamsFromAltPreset method

SetParamsFromAltPreset method

Sets parameters of lame mp3 encoder from "alternate" preset.

Syntax

object.SetParamsFromAltPreset(Preset As Integer)

The SetParamsFromAltPreset method syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
Preset | Integer | Number of "alternate" preset. Can be one of following values: 0 - None (abolition of preset parameters), 1 - Fast Standard, 2 - Standard, 3 - Fast Extreme, 4 - Extreme, 5 - Insane. By default is equal to None.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.SetParamsFromAltPreset 1
Editor1.SetFormatMP3Ex Lame

See Also:

SetParamsFromCommandLine | SetParamsFromPreset

Apples To: AudioEditor2LameEnc


SetParamsFromCommandLine method

SetParamsFromCommandLine method

Sets parameters of lame mp3 encoder from command line.

Syntax

object.SetParamsFromCommandLine(CommandLine As String)

The SetParamsFromCommandLine method syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
CommandLine | String | Command string.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Dim Text As String
Lame.SetParamsFromCommandLine Text
Editor1.SetFormatMP3Ex Lame

See Also:

SetParamsFromAltPreset | SetParamsFromPreset

Apples To: AudioEditor2LameEnc


SetParamsFromPreset method

SetParamsFromPreset method

Sets parameters of lame mp3 encoder from preset.

Syntax

object.SetParamsFromPreset(Preset As Integer)

The SetParamsFromPreset method syntax has these parts:

Part | Type | Description
object | AudioEditor2LameEnc | An expression evaluating to an object.
Preset | Integer | Number of preset. Can be one of following values: 0 - None (abolition of preset parameters), 1 - Phone, 2 - SW, 3 - AM, 4 - FM, 5 - Voice, 6 - Radio, 7 - Tape, 8 - HiFi, 9 - CD, 10 - Studio, 11 - R3Mix. By default is equal to None.

Example:

' VB sample where Editor1 is an AudioEditor2 object and Lame is an AudioEditor2LameEnc object.
Lame.SetParamsFromPreset 8
Editor1.SetFormatMP3Ex Lame

See Also:

SetParamsFromAltPreset | SetParamsFromCommandLine

Apples To: AudioEditor2LameEnc


AudioEditor2Markers

AudioEditor2Markers object

Described information about a marker.


AudioEditor2Position Properties

Properties (AudioEditor2Position object)

Property | Type | Default | Description
CurrentPosition | Long |  | Gets or sets current position during playing.
EndSelect | Long |  | Gets or sets the position in the end of the selected part of an audio file.
EndView | Long |  | Gets or sets the position in the end of the viewing part of an audio file.
Selected | Boolean |  | Gets or sets a flag indicating if the part of an audio file is selected or not.
StartSelect | Long |  | Gets or sets the position in the beginning of the selected part of an audio file.
StartView | Long |  | Gets or sets the position in the beginning of the viewing part of an audio file.
TotalSamples | Long |  | Read-only property that returns the number of samples in an audio file.


CodePage property (AudioEditor2Markers)

CodePage property (AudioEditor2Markers)

Gets or sets marker code page.

Property type

A Integer value.

Syntax

object.CodePage [= value]

The CodePage property syntax has these parts:

Part | Type | Description
object | AudioEditor2Markers | An expression evaluating to an object.
value | Integer | Can accept only non-negative values.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Markers As AudioEditor2Markers
Private Sub ResetList()
    Dim itm As ListItem
    Cue.ListItems.Clear
    For i = 1 To Markers.Count
        Markers.Num = i
        Set itm = Cue.ListItems.Add(, , "[" & Str(i) & "]")
        itm.SubItems(1) = Str(Markers.Position)
        If (Markers.Length <> 0) Then
            itm.SubItems(1) = itm.SubItems(1) & " To " & Str(Markers.Length + Markers.Position)
        End If
        itm.SubItems(2) = Markers.Label
        itm.SubItems(3) = Markers.CodePage
    Next i
End Sub

See Also:

Count | Country | Dialect | Label | Language | Length | Note | Num | Position | Text

Apples To: AudioEditor2Markers


Count property (AudioEditor2Markers)

Count property (AudioEditor2Markers)

Read-only property that returns markers count.

Property type

A Long value.

Syntax

[value = ]object.Count

The Count property syntax has these parts:

Part | Type | Description
object | AudioEditor2Markers | An expression evaluating to an object.
value | Long | Can accept only non-negative values.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Markers As AudioEditor2Markers
Private Sub ResetList()
    Dim itm As ListItem
    Cue.ListItems.Clear
    For i = 1 To Markers.Count
        Markers.Num = i
        Set itm = Cue.ListItems.Add(, , "[" & Str(i) & "]")
        itm.SubItems(1) = Str(Markers.Position)
        If (Markers.Length <> 0) Then
            itm.SubItems(1) = itm.SubItems(1) & " To " & Str(Markers.Length + Markers.Position)
        End If
        itm.SubItems(2) = Markers.Label
    Next i
End Sub

See Also:

CodePage | Country | Dialect | Label | Language | Length | Note | Num | Position | Text

Apples To: AudioEditor2Markers


Country property (AudioEditor2Markers)

Country property (AudioEditor2Markers)

Gets or sets country.

Property type

A Integer value.

Syntax

object.Country [= value]

The Country property syntax has these parts:

Part | Type | Description
object | AudioEditor2Markers | An expression evaluating to an object.
value | Integer | A country number.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Markers As AudioEditor2Markers
Private Sub ResetList()
    Dim itm As ListItem
    Cue.ListItems.Clear
    For i = 1 To Markers.Count
        Markers.Num = i
        Set itm = Cue.ListItems.Add(, , "[" & Str(i) & "]")
        itm.SubItems(1) = Str(Markers.Position)
        If (Markers.Length <> 0) Then
            itm.SubItems(1) = itm.SubItems(1) & " To " & Str(Markers.Length + Markers.Position)
        End If
        itm.SubItems(2) = Markers.Label
        itm.SubItems(3) = Markers.Country
    Next i
End Sub

See Also:

CodePage | Count | Dialect | Label | Language | Length | Note | Num | Position | Text

Apples To: AudioEditor2Markers


Dialect property (AudioEditor2Markers)

Dialect property (AudioEditor2Markers)

Gets or sets dialect.

Property type

A Integer value.

Syntax

object.Dialect [= value]

The Dialect property syntax has these parts:

Part | Type | Description
object | AudioEditor2Markers | An expression evaluating to an object.
value | Integer | A dialect number.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Markers As AudioEditor2Markers
Private Sub ResetList()
    Dim itm As ListItem
    Cue.ListItems.Clear
    For i = 1 To Markers.Count
        Markers.Num = i
        Set itm = Cue.ListItems.Add(, , "[" & Str(i) & "]")
        itm.SubItems(1) = Str(Markers.Position)
        If (Markers.Length <> 0) Then
            itm.SubItems(1) = itm.SubItems(1) & " To " & Str(Markers.Length + Markers.Position)
        End If
        itm.SubItems(2) = Markers.Label
        itm.SubItems(3) = Markers.Country & Markers.Dialect
    Next i
End Sub

See Also:

CodePage | Count | Country | Label | Language | Length | Note | Num | Position | Text

Apples To: AudioEditor2Markers


Label property (AudioEditor2Markers)

Label property (AudioEditor2Markers)

Gets or sets marker label.

Property type

A String value.

Syntax

object.Label [= value]

The Label property syntax has these parts:

Part | Type | Description
object | AudioEditor2Markers | An expression evaluating to an object.
value | String | A short text label describing the cue or range.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Markers As AudioEditor2Markers
Private Sub ResetList()
    Dim itm As ListItem
    Cue.ListItems.Clear
    For i = 1 To Markers.Count
        Markers.Num = i
        Set itm = Cue.ListItems.Add(, , "[" & Str(i) & "]")
        itm.SubItems(1) = Str(Markers.Position)
        If (Markers.Length <> 0) Then
            itm.SubItems(1) = itm.SubItems(1) & " To " & Str(Markers.Length + Markers.Position)
        End If
        itm.SubItems(2) = Markers.Label
    Next i
End Sub

See Also:

CodePage | Count | Country | Dialect | Language | Length | Note | Num | Position | Text

Apples To: AudioEditor2Markers


Language property (AudioEditor2Markers)

Language property (AudioEditor2Markers)

Gets or sets language.

Property type

A Integer value.

Syntax

object.Language [= value]

The Language property syntax has these parts:

Part | Type | Description
object | AudioEditor2Markers | An expression evaluating to an object.
value | Integer | A number of language.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Markers As AudioEditor2Markers
Private Sub ResetList()
    Dim itm As ListItem
    Cue.ListItems.Clear
    For i = 1 To Markers.Count
        Markers.Num = i
        Set itm = Cue.ListItems.Add(, , "[" & Str(i) & "]")
        itm.SubItems(1) = Str(Markers.Position)
        If (Markers.Length <> 0) Then
            itm.SubItems(1) = itm.SubItems(1) & " To " & Str(Markers.Length + Markers.Position)
        End If
        itm.SubItems(2) = Markers.Label
        itm.SubItems(3) = Markers.Country & Markers.Language & Markers.Dialect
    Next i
End Sub

See Also:

CodePage | Count | Country | Dialect | Label | Length | Note | Num | Position | Text

Apples To: AudioEditor2Markers


Length property (AudioEditor2Markers)

Length property (AudioEditor2Markers)

Gets or sets marker length.

Property type

A Long value.

Syntax

object.Length [= value]

The Length property syntax has these parts:

Part | Type | Description
object | AudioEditor2Markers | An expression evaluating to an object.
value | Long | Marker length. Can be 0 (cue marker) or more then 0 (range marker length), in samples.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Markers As AudioEditor2Markers
Private Sub ResetList()
    Dim itm As ListItem
    Cue.ListItems.Clear
    For i = 1 To Markers.Count
        Markers.Num = i
        Set itm = Cue.ListItems.Add(, , "[" & Str(i) & "]")
        itm.SubItems(1) = Str(Markers.Position)
        If (Markers.Length <> 0) Then
            itm.SubItems(1) = itm.SubItems(1) & " To " & Str(Markers.Length + Markers.Position)
        End If
        itm.SubItems(2) = Markers.Label
    Next i
End Sub

See Also:

CodePage | Count | Country | Dialect | Label | Language | Note | Num | Position | Text

Apples To: AudioEditor2Markers


Note property (AudioEditor2Markers)

Note property (AudioEditor2Markers)

Gets or sets marker note.

Property type

A String value.

Syntax

object.Note [= value]

The Note property syntax has these parts:

Part | Type | Description
object | AudioEditor2Markers | An expression evaluating to an object.
value | String | A note string.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Markers As AudioEditor2Markers
Private Sub ResetList()
    Dim itm As ListItem
    Cue.ListItems.Clear
    For i = 1 To Markers.Count
        Markers.Num = i
        Set itm = Cue.ListItems.Add(, , "[" & Str(i) & "]")
        itm.SubItems(1) = Str(Markers.Position)
        If (Markers.Length <> 0) Then
            itm.SubItems(1) = itm.SubItems(1) & " To " & Str(Markers.Length + Markers.Position)
        End If
        itm.SubItems(2) = Markers.Label
        itm.SubItems(3) = Markers.Note
    Next i
End Sub

See Also:

CodePage | Count | Country | Dialect | Label | Language | Length | Num | Position | Text

Apples To: AudioEditor2Markers


Num property (AudioEditor2Markers)

Num property (AudioEditor2Markers)

Gets or sets a marker number.

Property type

A Long value.

Syntax

object.Num [= value]

The Num property syntax has these parts:

Part | Type | Description
object | AudioEditor2Markers | An expression evaluating to an object.
value | Long | A marker number.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Markers As AudioEditor2Markers
Private Sub ResetList()
    Dim itm As ListItem
    Cue.ListItems.Clear
    For i = 1 To Markers.Count
        Markers.Num = i
        Set itm = Cue.ListItems.Add(, , "[" & Str(i) & "]")
        itm.SubItems(1) = Str(Markers.Position)
        If (Markers.Length <> 0) Then
            itm.SubItems(1) = itm.SubItems(1) & " To " & Str(Markers.Length + Markers.Position)
        End If
        itm.SubItems(2) = Markers.Label
    Next i
End Sub

See Also:

CodePage | Count | Country | Dialect | Label | Language | Length | Note | Position | Text

Apples To: AudioEditor2Markers


Position property (AudioEditor2Markers)

Position property (AudioEditor2Markers)

Gets or sets marker position.

Property type

A Long value.

Syntax

object.Position [= value]

The Position property syntax has these parts:

Part | Type | Description
object | AudioEditor2Markers | An expression evaluating to an object.
value | Long | A marker position, in samples.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Markers As AudioEditor2Markers
Private Sub ResetList()
    Dim itm As ListItem
    Cue.ListItems.Clear
    For i = 1 To Markers.Count
        Markers.Num = i
        Set itm = Cue.ListItems.Add(, , "[" & Str(i) & "]")
        itm.SubItems(1) = Str(Markers.Position)
        If (Markers.Length <> 0) Then
            itm.SubItems(1) = itm.SubItems(1) & " To " & Str(Markers.Length + Markers.Position)
        End If
        itm.SubItems(2) = Markers.Label
    Next i
End Sub

See Also:

CodePage | Count | Country | Dialect | Label | Language | Length | Note | Num | Text

Apples To: AudioEditor2Markers


Text property (AudioEditor2Markers)

Text property (AudioEditor2Markers)

Gets or sets marker text.

Property type

A String value.

Syntax

object.Text [= value]

The Text property syntax has these parts:

Part | Type | Description
object | AudioEditor2Markers | An expression evaluating to an object.
value | String | A text description the cue or range.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Markers As AudioEditor2Markers
Private Sub ResetList()
    Dim itm As ListItem
    Cue.ListItems.Clear
    For i = 1 To Markers.Count
        Markers.Num = i
        Set itm = Cue.ListItems.Add(, , "[" & Str(i) & "]")
        itm.SubItems(1) = Str(Markers.Position)
        If (Markers.Length <> 0) Then
            itm.SubItems(1) = itm.SubItems(1) & " To " & Str(Markers.Length + Markers.Position)
        End If
        itm.SubItems(2) = Markers.Label & Markers.Note & Markers.Text
    Next i
End Sub

See Also:

CodePage | Count | Country | Dialect | Label | Language | Length | Note | Num | Position

Apples To: AudioEditor2Markers


AudioEditor2LameEnc Methods

Methods (AudioEditor2LameEnc object)

Method | Description
Delete | Deletes marker.
Insert | Inserts marker parameters.


Delete method

Delete method

Deletes marker.

Syntax

object.Delete()

The Delete method syntax has these parts:

Part | Type | Description
object | AudioEditor2Markers | An expression evaluating to an object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Markers As AudioEditor2Markers
Dim Position As AudioEditor2Position
Markers.Insert Position.StartSelect, Position.EndSelect - Position.StartSelect, "Marker " & Str(Cue.ListItems.Count + 1)
Position.StartSelect = Position.EndSelect
Position.EndSelect = Position.EndSelect +10
Markers.Insert Position.StartSelect, Position.EndSelect - Position.StartSelect, "Marker " & Str(Cue.ListItems.Count + 1)
Markers.Num = Markers.Count - 1
Markers.Delete

See Also:

Insert

Apples To: AudioEditor2Markers


Insert method

Insert method

Inserts marker parameters.

Syntax

object.Insert(Position As Long, Length As Long, Label As String, Note As String, Text As String, Language As Integer, Country As Integer, Dialect As Integer, CodePage As Integer)

The Insert method syntax has these parts:

Part | Type | Description
object | AudioEditor2Markers | An expression evaluating to an object.
Position | Long | A marker position.
Length | Long | A marker length.
Label | String | A label string.
Note | String | A note string.
Text | String | A text description the cue or range.
Language | Integer | A language number.
Country | Integer | A country number.
Dialect | Integer | A dialect number.
CodePage | Integer | A code page number.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Markers.Insert Editor1.Position.StartSelect, Editor1.Position.EndSelect - Editor1.Position.StartSelect, "Marker " & Str(Cue.ListItems.Count + 1)

See Also:

Delete

Apples To: AudioEditor2Markers


AudioEditor2Position

AudioEditor2Position object

Controls positions in an audio file.


CurrentPosition property (AudioEditor2Position)

CurrentPosition property (AudioEditor2Position)

Gets or sets current position during playing.

Property type

A Long value.

Syntax

object.CurrentPosition [= value]

The CurrentPosition property syntax has these parts:

Part | Type | Description
object | AudioEditor2Position | An expression evaluating to an object.
value | Long | The value is in samples.

Remarks:

During editing audio data this property is equal to the value of StartSelect property.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Position.StartView = Editor1.Position.CurrentPosition
Editor1.Position.EndView = Editor1.Position.EndSelect

See Also:

EndSelect | EndView | Selected | StartSelect | StartView | TotalSamples

Apples To: AudioEditor2Position


EndSelect property (AudioEditor2Position)

EndSelect property (AudioEditor2Position)

Gets or sets the position in the end of the selected part of an audio file.

Property type

A Long value.

Syntax

object.EndSelect [= value]

The EndSelect property syntax has these parts:

Part | Type | Description
object | AudioEditor2Position | An expression evaluating to an object.
value | Long | The value is in samples.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Markers.Insert Editor1.Position.StartSelect, Editor1.Position.EndSelect - Editor1.Position.StartSelect, "Marker " & Str(Cue.ListItems.Count + 1)

See Also:

CurrentPosition | EndView | Selected | StartSelect | StartView | TotalSamples

Apples To: AudioEditor2Position


EndView property (AudioEditor2Position)

EndView property (AudioEditor2Position)

Gets or sets the position in the end of the viewing part of an audio file.

Property type

A Long value.

Syntax

object.EndView [= value]

The EndView property syntax has these parts:

Part | Type | Description
object | AudioEditor2Position | An expression evaluating to an object.
value | Long | The value is in samples.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Position.StartView = Editor1.Position.StartSelect
Editor1.Position.EndView = Editor1.Position.EndSelect

See Also:

CurrentPosition | EndSelect | Selected | StartSelect | StartView | TotalSamples

Apples To: AudioEditor2Position


Selected property (AudioEditor2Position)

Selected property (AudioEditor2Position)

Gets or sets a flag indicating if the part of an audio file is selected or not.

Property type

A Boolean value.

Syntax

object.Selected [= value]

The Selected property syntax has these parts:

Part | Type | Description
object | AudioEditor2Position | An expression evaluating to an object.
value | Boolean | Is True if a part of an audio file is selected, otherwise - False.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Position.StartView = Editor1.Position.StartSelect
Editor1.Position.EndView = Editor1.Position.EndSelect

See Also:

CurrentPosition | EndSelect | EndView | StartSelect | StartView | TotalSamples

Apples To: AudioEditor2Position


StartSelect property (AudioEditor2Position)

StartSelect property (AudioEditor2Position)

Gets or sets the position in the beginning of the selected part of an audio file.

Property type

A Long value.

Syntax

object.StartSelect [= value]

The StartSelect property syntax has these parts:

Part | Type | Description
object | AudioEditor2Position | An expression evaluating to an object.
value | Long | The value is in samples.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Markers.Insert Editor1.Position.StartSelect, Editor1.Position.EndSelect - Editor1.Position.StartSelect, "Marker " & Str(Cue.ListItems.Count + 1)

See Also:

CurrentPosition | EndSelect | EndView | Selected | StartView | TotalSamples

Apples To: AudioEditor2Position


StartView property (AudioEditor2Position)

StartView property (AudioEditor2Position)

Gets or sets the position in the beginning of the viewing part of an audio file.

Property type

A Long value.

Syntax

object.StartView [= value]

The StartView property syntax has these parts:

Part | Type | Description
object | AudioEditor2Position | An expression evaluating to an object.
value | Long | The value is in samples.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Position.StartView = Editor1.Position.StartSelect
Editor1.Position.EndView = Editor1.Position.EndSelect

See Also:

CurrentPosition | EndSelect | EndView | Selected | StartSelect | S TotalSamples

Apples To: AudioEditor2Position


TotalSamples property (AudioEditor2Position)

TotalSamples property (AudioEditor2Position)

Read-only property that returns the number of samples in an audio file.

Property type

A Long value.

Syntax

[value = ]object.TotalSamples

The TotalSamples property syntax has these parts:

Part | Type | Description
object | AudioEditor2Position | An expression evaluating to an object.
value | Long | The number of samples in an audio file.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Position.StartView = Editor1.Position.StartSelect
Editor1.Position.EndView = Editor1.Position.EndSelect

See Also:

CurrentPosition | EndSelect | EndView | Selected | StartSelect | StartView

Apples To: AudioEditor2Position


AudioEditor2Position Methods

Methods (AudioEditor2Position object)

Method | Description
GoToMarker | Moves a current position to a marker.
SamplesToSec | Converts the number of samples to seconds.
SecToSamples | Converts the number of seconds in audio file samples.


GoToMarker method

GoToMarker method

Moves a current position to a marker.

Syntax

object.GoToMarker(Num As Long)

The GoToMarker method syntax has these parts:

Part | Type | Description
object | AudioEditor2Position | An expression evaluating to an object.
Num | Long | A marker number.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Markers As AudioEditor2Markers
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Position.StartView = Editor1.Position.StartSelect
Editor1.Position.EndView = Editor1.Position.EndSelect
Editor1.Position.GoToMarker Markers.Num

See Also:

SamplesToSec | SecToSamples

Apples To: AudioEditor2Position


SamplesToSec method

SamplesToSec method

Converts the number of samples to seconds.

Return Type

A Long value.

Syntax

Millisec= object.SamplesToSec(Samples As Long)

The SamplesToSec method syntax has these parts:

Part | Type | Description
object | AudioEditor2Position | An expression evaluating to an object.
Samples | Long | Number of samples.
Millisec | Long | Number of milliseconds.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Position As AudioEditor2Position
Position.Selected = True
Position.StartSelect = 0
Position.EndSelect = Position.TotalSamples
Position.StartView = Position.StartSelect
Position.EndView = Position.EndSelect
MsgBox "File duration is " & Position.SamplesToSec (Position.TotalSamples) & " ms"

See Also:

GoToMarker | SecToSamples

Apples To: AudioEditor2Position


SecToSamples method

SecToSamples method

Converts the number of seconds in audio file samples.

Return Type

A Long value.

Syntax

Samples = object.SecToSamples(Millisec As Long)

The SecToSamples method syntax has these parts:

Part | Type | Description
object | AudioEditor2Position | An expression evaluating to an object.
Millisec | Long | Number of milliseconds.
Samples | Long | Number of samples.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Position As AudioEditor2Position
Position.Selected = True
Position.StartSelect = Position.SecToSamples 140
Position.EndSelect = Position.TotalSamples
Position.StartView = Position.StartSelect
Position.EndView = Position.EndSelect
MsgBox "File duration is " & Position.SamplesToSec(Position.TotalSamples) & " ms"

See Also:

GoToMarker | SamplesToSec

Apples To: AudioEditor2Position


AudioEditor2Recorder

AudioEditor2Recorder object

Allows to get or set recording parameters.


AudioEditor2Recorder Properties

Properties (AudioEditor2Recorder object)

Property | Type | Default | Description
AccuAttackLevel | Long |  | Gets or sets level loudness for the starting of recording. This is a level for non-silence detection.
AccuAttackTime | Long |  | Gets or sets sounding time for the starting of recording. This is a time for non-silence detection.
AccuEnabled | Boolean | False | Gets or sets a flag indicating if recording without silence is enabled or not.
AccuReleaseLevel | Long |  | Gets or sets level loudness for the ending of recording. This is a level for silence detection.
AccuReleaseTime | Long |  | Gets or sets silence time for the ending of recording. This is a time for silence detection.
AGCEnabled | Boolean | True | Gets or sets a flag indicating if Automatic Gain Control is enabled or not.
AGCHighLevel | Long | -10 | Gets or sets AGC high level.
AGCLowLevel | Long | -40 | Gets or sets AGC low level.
AGCAttackTime | Float | 5 | Gets or sets the time during which the level changes by 20 db.
HighPassFilterEnabled | Boolean |  | Gets or sets a flag indicating if High Pass filter is enabled or not.
HighPassFilterFrequency | Float |  | Gets or sets frequency for High Pass filter.
LowPassFilterEnabled | Boolean |  | Gets or sets a flag indicating if Low Pass filter is enabled or not.
LowPassFilterFrequency | Float |  | Gets or sets frequency for Low Pass filter.
NotchFilterEnabled | Boolean |  | Gets or sets a flag indicating if Notch filter is enabled or not.
NotchFilterFrequency | Float |  | Gets or sets frequency for Notch filter.


AccuAttackLevel property (AudioEditor2Recorder)

AccuAttackLevel property (AudioEditor2Recorder)

Gets or sets level loudness for the starting of recording. This is a level for non-silence detection.

Property type

A Long value.

Syntax

object.AccuAttackLevel [= value]

The AccuAttackLevel property syntax has these parts:

Part | Type | Description
object | AudioEditor2Recorder | An expression evaluating to an object.
value | Long | The level is in db. Varies from -92 to 0.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.AccuEnabled = True
Editor1.Recorder.AccuAttackTime = 100
Editor1.Recorder.AccuReleaseTime = 300
Editor1.Recorder.AccuAttackLevel = -45
Editor1.Recorder.AccuReleaseLevel = -45
Editor1.Recorder.AGCEnabled = True
Editor1.Recorder.AGCLowLevel = -40
Editor1.Recorder.AGCHighLevel = -10
Editor1.Recorder.AGCAttackTime = 4
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AccuAttackTime | AccuEnabled | AccuReleaseLevel | AccuReleaseTime

Apples To: AudioEditor2Recorder


AccuAttackTime property (AudioEditor2Recorder)

AccuAttackTime property (AudioEditor2Recorder)

Gets or sets sounding time for the starting of recording. This is a time for non-silence detection.

Property type

A Long value.

Syntax

object.AccuAttackTime [= value]

The AccuAttackTime property syntax has these parts:

Part | Type | Description
object | AudioEditor2Recorder | An expression evaluating to an object.
value | Long | Time is in ms.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.AccuEnabled = True
Editor1.Recorder.AccuAttackTime = 100
Editor1.Recorder.AccuReleaseTime = 300
Editor1.Recorder.AccuAttackLevel = -45
Editor1.Recorder.AccuReleaseLevel = -45
Editor1.Recorder.AGCEnabled = True
Editor1.Recorder.AGCLowLevel = -40
Editor1.Recorder.AGCHighLevel = -10
Editor1.Recorder.AGCAttackTime = 4
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AccuAttackLevel | AccuEnabled | AccuReleaseLevel | AccuReleaseTime

Apples To: AudioEditor2Recorder


AccuEnabled property (AudioEditor2Recorder)

AccuEnabled property (AudioEditor2Recorder)

Gets or sets a flag indicating if recording without silence is enabled or not.

Property type

A Boolean value.

Syntax

object.AccuEnabled [= value]

The AccuEnabled property syntax has these parts:

Part | Type | Description
object | AudioEditor2Recorder | An expression evaluating to an object.
value | Boolean | Can be True (recording without silence is enabled) or False (recording without silence isn't enabled). By default is False.

Remarks:

The following properties allows to get or set parameters of silence and non-silence detection: AccuAttackLevel, AccuAttackTime, AccuReleaseLevel, AccuReleaseTime.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.AccuEnabled = True
Editor1.Recorder.AccuAttackTime = 100
Editor1.Recorder.AccuReleaseTime = 300
Editor1.Recorder.AccuAttackLevel = -45
Editor1.Recorder.AccuReleaseLevel = -45
Editor1.Recorder.AGCEnabled = True
Editor1.Recorder.AGCLowLevel = -40
Editor1.Recorder.AGCHighLevel = -10
Editor1.Recorder.AGCAttackTime = 4
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AccuAttackLevel | AccuAttackTime | AccuReleaseLevel | AccuReleaseTime

Apples To: AudioEditor2Recorder


AccuReleaseLevel property (AudioEditor2Recorder)

AccuReleaseLevel property (AudioEditor2Recorder)

Gets or sets level loudness for the ending of recording. This is a level for silence detection.

Property type

A Long value.

Syntax

object.AccuReleaseLevel [= value]

The AccuReleaseLevel property syntax has these parts:

Part | Type | Description
object | AudioEditor2Recorder | An expression evaluating to an object.
value | Long | The level is in db. Varies from -92 to 0.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.AccuEnabled = True
Editor1.Recorder.AccuAttackTime = 100
Editor1.Recorder.AccuReleaseTime = 300
Editor1.Recorder.AccuAttackLevel = -45
Editor1.Recorder.AccuReleaseLevel = -45
Editor1.Recorder.AGCEnabled = True
Editor1.Recorder.AGCLowLevel = -40
Editor1.Recorder.AGCHighLevel = -10
Editor1.Recorder.AGCAttackTime = 4
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AccuAttackLevel | AccuAttackTime | AccuEnabled | AccuReleaseTime

Apples To: AudioEditor2Recorder


AccuReleaseTime property (AudioEditor2Recorder)

AccuReleaseTime property (AudioEditor2Recorder)

Gets or sets silence time for the ending of recording. This is a time for silence detection.

Property type

A Long value.

Syntax

object.AccuReleaseTime [= value]

The AccuReleaseTime property syntax has these parts:

Part | Type | Description
object | AudioEditor2Recorder | An expression evaluating to an object.
value | Long | Time is in ms.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.AccuEnabled = True
Editor1.Recorder.AccuAttackTime = 100
Editor1.Recorder.AccuReleaseTime = 300
Editor1.Recorder.AccuAttackLevel = -45
Editor1.Recorder.AccuReleaseLevel = -45
Editor1.Recorder.AGCEnabled = True
Editor1.Recorder.AGCLowLevel = -40
Editor1.Recorder.AGCHighLevel = -10
Editor1.Recorder.AGCAttackTime = 4
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AccuAttackLevel | AccuAttackTime | AccuEnabled | AccuReleaseLevel

Apples To: AudioEditor2Recorder


AGCAttackTime property (AudioEditor2Recorder)

AGCAttackTime property (AudioEditor2Recorder object)

Gets or sets the time during which the level changes by 20 db.

Property type

A Long value.

Syntax

object.AGCAttackTime [= value]

The AGCAttackTime property syntax has these parts:

Part | Type | Description
object | AudioEditor2Recorder | An expression evaluating to an object.
value | Long | The time for level change by 20 db, in ms.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.AccuEnabled = True
Editor1.Recorder.AccuAttackTime = 100
Editor1.Recorder.AccuReleaseTime = 300
Editor1.Recorder.AccuAttackLevel = -45
Editor1.Recorder.AccuReleaseLevel = -45
Editor1.Recorder.AGCEnabled = True
Editor1.Recorder.AGCLowLevel = -40
Editor1.Recorder.AGCHighLevel = -10
Editor1.Recorder.AGCAttackTime = 4
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AGCEnabled | AGCHighLevel | AGCLowLevel

Applies to: AudioEditor2Recorder

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


AGCEnabled property (AudioEditor2Recorder)

AGCEnabled property (AudioEditor2Recorder)

Gets or sets a flag indicating if Automatic Gain Control is enabled or not.

Property type

A Boolean value.

Syntax

object.AGCEnabled [= value]

The AGCEnabled property syntax has these parts:

Part | Type | Description
object | AudioEditor2Recorder | An expression evaluating to an object.
value | Boolean | Can be True (AGC is enabled) or False (AGC isn't enabled). By default is True.

Remarks:

Sound cards use AGC to improve recordings.

The following properties allows to get or set parameters of AGC: AGCHighLevel, AGCLowLevel, AGCAttackTime.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.AccuEnabled = True
Editor1.Recorder.AccuAttackTime = 100
Editor1.Recorder.AccuReleaseTime = 300
Editor1.Recorder.AccuAttackLevel = -45
Editor1.Recorder.AccuReleaseLevel = -45
Editor1.Recorder.AGCEnabled = True
Editor1.Recorder.AGCLowLevel = -40
Editor1.Recorder.AGCHighLevel = -10
Editor1.Recorder.AGCAttackTime = 4
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AGCHighLevel | AGCLowLevel | AGCAttackTime

Apples To: AudioEditor2Recorder


AGCHighLevel property (AudioEditor2Recorder)

AGCHighLevel property (AudioEditor2Recorder)

Gets or sets AGC high level.

Property type

A Long value.

Syntax

object.AGCHighLevel [= value]

The AGCHighLevel property syntax has these parts:

Part | Type | Description
object | AudioEditor2Recorder | An expression evaluating to an object.
value | Long | The level is in db. Varies from -92 to 0. The default value is -10.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.AccuEnabled = True
Editor1.Recorder.AccuAttackTime = 100
Editor1.Recorder.AccuReleaseTime = 300
Editor1.Recorder.AccuAttackLevel = -45
Editor1.Recorder.AccuReleaseLevel = -45
Editor1.Recorder.AGCEnabled = True
Editor1.Recorder.AGCLowLevel = -40
Editor1.Recorder.AGCHighLevel = -10
Editor1.Recorder.AGCAttackTime = 4
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AGCEnabled | AGCLowLevel | AGCAttackTime

Apples To: AudioEditor2Recorder


AGCLowLevel property (AudioEditor2Recorder)

AGCLowLevel property (AudioEditor2Recorder)

Gets or sets AGC low level.

Property type

A Long value.

Syntax

object.AGCLowLevel [= value]

The AGCLowLevel property syntax has these parts:

Part | Type | Description
object | AudioEditor2Recorder | An expression evaluating to an object.
value | Long | The level is in db. Varies from -92 to 0. The default value is -40.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.AccuEnabled = True
Editor1.Recorder.AccuAttackTime = 100
Editor1.Recorder.AccuReleaseTime = 300
Editor1.Recorder.AccuAttackLevel = -45
Editor1.Recorder.AccuReleaseLevel = -45
Editor1.Recorder.AGCEnabled = True
Editor1.Recorder.AGCLowLevel = -40
Editor1.Recorder.AGCHighLevel = -10
Editor1.Recorder.AGCAttackTime = 4
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AGCEnabled | AGCHighLevel | AGCAttackTime

Apples To: AudioEditor2Recorder


HighPassFilterEnabled property (AudioEditor2Recorder)

HighPassFilterEnabled property (AudioEditor2Recorder)

Gets or sets a flag indicating if High Pass filter is enabled or not.

Property type

A Boolean value.

Syntax

object.HighPassFilterEnabled [= value]

The HighPassFilterEnabled property syntax has these parts:

Part | Type | Description
object | AudioEditor2Recorder | An expression evaluating to an object.
value | Boolean | Is True if the High Pass filter is enabled, otherwise -False.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.HighPassFilterEnabled = True
Editor1.Recorder.HighPassFilterFrequency = 4000
Editor1.Recorder.LowPassFilterEnabled = True
Editor1.Recorder.LowPassFilterFrequency = 2000
Editor1.Recorder.NotchFilterEnabled = True
Editor1.Recorder.NotchFilterFrequency = 3000
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

HighPassFilterFrequency | LowPassFilterEnabled | LowPassFilterFrequency | NotchFilterEnabled | NotchFilterFrequency

Apples To: AudioEditor2Recorder


HighPassFilterFrequency property (AudioEditor2Recorder)

HighPassFilterFrequency property (AudioEditor2Recorder)

Gets or sets frequency for High Pass filter.

Property type

A Float value.

Syntax

object.HighPassFilterFrequency [= value]

The HighPassFilterFrequency property syntax has these parts:

Part | Type | Description
object | AudioEditor2Recorder | An expression evaluating to an object.
value | Float | Frequency is in hertz.

Remarks:

This property is enabled only if HighPassFilterEnabled property is set to True.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.HighPassFilterEnabled = True
Editor1.Recorder.HighPassFilterFrequency = 4000
Editor1.Recorder.LowPassFilterEnabled = True
Editor1.Recorder.LowPassFilterFrequency = 2000
Editor1.Recorder.NotchFilterEnabled = True
Editor1.Recorder.NotchFilterFrequency = 3000
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

HighPassFilterEnabled | LowPassFilterEnabled | LowPassFilterFrequency | NotchFilterEnabled | NotchFilterFrequency

Apples To: AudioEditor2Recorder


LowPassFilterEnabled property (AudioEditor2Recorder)

LowPassFilterEnabled property (AudioEditor2Recorder)

Gets or sets a flag indicating if Low Pass filter is enabled or not.

Property type

A Boolean value.

Syntax

object.LowPassFilterEnabled [= value]

The LowPassFilterEnabled property syntax has these parts:

Part | Type | Description
object | AudioEditor2Recorder | An expression evaluating to an object.
value | Boolean | Is True if the Low Pass filter is enabled, otherwise -False.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.HighPassFilterEnabled = True
Editor1.Recorder.HighPassFilterFrequency = 4000
Editor1.Recorder.LowPassFilterEnabled = True
Editor1.Recorder.LowPassFilterFrequency = 2000
Editor1.Recorder.NotchFilterEnabled = True
Editor1.Recorder.NotchFilterFrequency = 3000
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

HighPassFilterEnabled | HighPassFilterFrequency | LowPassFilterFrequency | NotchFilterEnabled | NotchFilterFrequency

Apples To: AudioEditor2Recorder


LowPassFilterFrequency property (AudioEditor2Recorder)

LowPassFilterFrequency property (AudioEditor2Recorder)

Gets or sets frequency for Low Pass filter.

Property type

A Float value.

Syntax

object.LowPassFilterFrequency [= value]

The LowPassFilterFrequency property syntax has these parts:

Part | Type | Description
object | AudioEditor2Recorder | An expression evaluating to an object.
value | Float | Frequency is in hertz.

Remarks:

This property is enabled only if LowPassFilterEnabled property is set to True.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.HighPassFilterEnabled = True
Editor1.Recorder.HighPassFilterFrequency = 4000
Editor1.Recorder.LowPassFilterEnabled = True
Editor1.Recorder.LowPassFilterFrequency = 2000
Editor1.Recorder.NotchFilterEnabled = True
Editor1.Recorder.NotchFilterFrequency = 3000
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

HighPassFilterEnabled | HighPassFilterFrequency | LowPassFilterEnabled | NotchFilterEnabled | NotchFilterFrequency

Apples To: AudioEditor2Recorder


NotchFilterEnabled property (AudioEditor2Recorder)

NotchFilterEnabled property (AudioEditor2Recorder)

Gets or sets a flag indicating if Notch filter is enabled or not.

Property type

A Boolean value.

Syntax

object.NotchFilterEnabled [= value]

The NotchFilterEnabled property syntax has these parts:

Part | Type | Description
object | AudioEditor2Recorder | An expression evaluating to an object.
value | Boolean | Is True if the Notch filter is enabled, otherwise -False.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.HighPassFilterEnabled = True
Editor1.Recorder.HighPassFilterFrequency = 4000
Editor1.Recorder.LowPassFilterEnabled = True
Editor1.Recorder.LowPassFilterFrequency = 2000
Editor1.Recorder.NotchFilterEnabled = True
Editor1.Recorder.NotchFilterFrequency = 3000
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

HighPassFilterEnabled | HighPassFilterFrequency | LowPassFilterEnabled | LowPassFilterFrequency | NotchFilterFrequency

Apples To: AudioEditor2Recorder


NotchFilterFrequency property (AudioEditor2Recorder)

NotchFilterFrequency property (AudioEditor2Recorder)

Gets or sets frequency for Notch filter.

Property type

A Float value.

Syntax

object.NotchFilterFrequency [= value]

The NotchFilterFrequency property syntax has these parts:

Part | Type | Description
object | AudioEditor2Recorder | An expression evaluating to an object.
value | Float | Frequency is in hertz.

Remarks:

This property is enabled only if NotchFilterEnabled property is set to True.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Recorder.HighPassFilterEnabled = True
Editor1.Recorder.HighPassFilterFrequency = 4000
Editor1.Recorder.LowPassFilterEnabled = True
Editor1.Recorder.LowPassFilterFrequency = 2000
Editor1.Recorder.NotchFilterEnabled = True
Editor1.Recorder.NotchFilterFrequency = 3000
Editor1.New
Editor1.Record
...
Editor1.Stop
Editor1.Save OutputFile, False
Editor1.Close

See Also:

HighPassFilterEnabled | HighPassFilterFrequency | LowPassFilterEnabled | LowPassFilterFrequency | NotchFilterEnabled

Apples To: AudioEditor2Recorder


AudioEditor2Scale

AudioEditor2Scale object

Controls the type and the appearance of scales in the displaying window.


AudioEditor2Scale Properties

Properties (AudioEditor2Scale object)

Property | Type | Default | Description
Font | FontDisp |  | Gets or sets the font for scales.
Grid | Boolean |  | Gets or sets a flag indicating if the grid is present or not.
Orientation | Integer |  | Gets or sets the orientation of scale.
Type | Integer |  | Gets or sets the scale type.
Visible | Boolean |  | Gets or sets a flag indicating if the scale is visible or not.


Font property (AudioEditor2Scale)

Font property (AudioEditor2Scale)

Gets or sets the font for scales.

Property type

A FontDisp value.

Syntax

object.Font [= value]

The Font property syntax has these parts:

Part | Type | Description
object | AudioEditor2Scale | An expression evaluating to an object.
value | FontDisp | The font for scales.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim font1 As New StdFont    'declares the variable of the font type
CommonDialog1.DialogTitle = "Choice Font"   'sets the dialog window caption
CommonDialog1.Flags = cdlCFBoth 'and the type of the dialog window
Set font1 = frmDialog.Editor1.ScaleX.Font 'gets the font1
'setting up the font1 parameters for the dialog window
CommonDialog1.FontName = font1.Name
CommonDialog1.FontBold = font1.Bold
CommonDialog1.FontItalic = font1.Italic
CommonDialog1.FontSize = font1.Size
CommonDialog1.FontStrikethru = font1.Strikethrough
CommonDialog1.FontUnderline = font1.Underline
CommonDialog1.ShowFont  'and show the dialog window to set up the font
'sets the new font1 parameters
font1.Name = CommonDialog1.FontName
font1.Bold = CommonDialog1.FontBold
font1.Italic = CommonDialog1.FontItalic
font1.Size = CommonDialog1.FontSize
font1.Strikethrough = CommonDialog1.FontStrikethru
font1.Underline = CommonDialog1.FontUnderline
Set frmDialog.Editor1.ScaleX.Font = font1  'set the new font

See Also:

Grid | Type | Visible

Apples To: AudioEditor2Scale


Grid property (AudioEditor2Scale)

Grid property (AudioEditor2Scale)

Gets or sets a flag indicating if the grid is present or not.

Property type

A Boolean value.

Syntax

object.Grid [= value]

The Grid property syntax has these parts:

Part | Type | Description
object | AudioEditor2Scale | An expression evaluating to an object.
value | Boolean | Is True if the grid is present, otherwise - False.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.ScaleX.Visible = False
Editor1.ScaleY.Visible = False
Editor1.ScaleX.Grid = False
Editor1.ScaleY.Grid = False
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Reverse
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Font | Type | Visible

Apples To: AudioEditor2Scale


Orientation property (AudioEditor2Scale)

Orientation property (AudioEditor2Scale)

Gets or sets the orientation of scale (now only for ScaleY).

Property type

A Integer value.

Syntax

object.Orientation [= value]

The Type property syntax has these parts:

Part | Type | Description
object | AudioEditor2Scale | An expression evaluating to an object.
value | Integer | Can be 1 (scale is in the right side) or 2 (scale is in the left side).

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.ScaleX.Visible = True
Editor1.ScaleY.Visible = True
Editor1.ScaleX.Type = 2
Editor1.ScaleY.Type = 3
Editor1.ScaleY.Orientation = 1
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Reverse
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Font | Grid | Type | Visible

Apples To: AudioEditor2Scale


Type property (AudioEditor2Scale)

Type property (AudioEditor2Scale)

Gets or sets the scale type.

Property type

A Integer value.

Syntax

object.Type [= value]

The Type property syntax has these parts:

Part | Type | Description
object | AudioEditor2Scale | An expression evaluating to an object.
value | Integer | There are three possible values of Type for ScaleY and two for ScaleX: ScaleX: 1 - samples, 2 - time scale; ScaleY: 1 - samples, 2 - norm values (0-100), 3 - db.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.ScaleX.Visible = True
Editor1.ScaleY.Visible = True
Editor1.ScaleX.Type = 2
Editor1.ScaleY.Type = 3
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Tramsform.Reverse
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Font | Grid | Visible

Apples To: AudioEditor2Scale


Visible property (AudioEditor2Scale)

Visible property (AudioEditor2Scale)

Gets or sets a flag indicating if the scale is visible or not.

Property type

A Boolean value.

Syntax

object.Visible [= value]

The Visible property syntax has these parts:

Part | Type | Description
object | AudioEditor2Scale | An expression evaluating to an object.
value | Boolean | Is True if scale is visible, otherwise - False.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.ScaleX.Visible = False
Editor1.ScaleY.Visible = False
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Reverse
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Font | Grid | Type

Apples To: AudioEditor2Scale


AudioEditor2Transform

AudioEditor2Transform object

AudioEditor2Transform object is intended for processing and transforming of audio data.

This object contains the following methods and properties for audio data transforming using:

  • filters (BandPassFilter, FFTFilter, HighPassFilter, HighShelfFilter, LowPassFilter, LowShelfFilter, NotchFilter, PeakEQFilter);

  • delays (Delay, Phaser, Flanger, Reverb, Chorus);

  • amplitude changing (Invert, Reverse, Silence, Amplify, Normalize, Fade, Vibrato, Compressor, Expander);

  • equalizer (Equalizer);

  • other (Resample, AddNoise, Envelope, MixArrays, DeleteSilence, MixStereoChannels, TrimLeft, TrimRight, PitchShift, TimeStretch).

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


AudioEditor2Transform Properties

Properties (AudioEditor2Transform object)

Property | Type | Default | Description
SmoothEnabled | Boolean |  | Gets or sets a flag indicating if smoothing is enabled or not.
SmoothTime | Long | 50 ms | Gets or sets smooth time. Any applied effect has an abrupt transition on the edges of selected part. Smooth effect apply to this edges.


SmoothEnabled property (AudioEditor2Transform)

SmoothEnabled property (AudioEditor2Transform)

Gets or sets a flag indicating if smoothing is enabled or not.

Property type

A Boolean value.

Syntax

object.SmoothEnabled [= value]

The SmoothEnabled property syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object .
value | Boolean | Can be True (smooth sound) or False (current sound).

Remarks:

Any supported effect has sudden change on the bound. The SmoothEnabled property enables smoothing on this bound and bound neighborhood.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.SmoothEnabled = True
Editor1.Transform.SmoothTime = 100
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SmoothTime

Apples To: AudioEditor2Transform


SmoothTime property (AudioEditor2Transform)

SmoothTime property (AudioEditor2Transform)

Gets or sets smooth time. Any applied effect has an abrupt transition on the edges of selected part. Smooth effect apply to this edges.

Property type

A Long value.

Syntax

object.SmoothTime [= value]

The SmoothTime property syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
value | Long | A smooth time in ms. By default this value sets to 50 milliseconds.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.SmoothEnabled = True
Editor1.Transform.SmoothTime = 100
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

SmoothEnabled

Apples To: AudioEditor2Transform


AudioEditor2Transform Methods

Methods (AudioEditor2Transform object)

Method | Description
AddNoise | Inserts a noise in an audio file.
Amplify | Applies Amplify effect to the selected part of an audio file. Changes amplitude of input audio file.
BandPassFilter | Applies Band Pass filter to the selected part of an audio file.
Chorus | Applies chorus effect to the selected part of an audio file.
Compressor | Reduces the dynamic range of a signal.
Delay | Makes a Delay effect in a selected part of an audio file.
DeleteSilence | Deletes silence from the selected part of an audio file.
Envelope | Gives you control over which parts of the audio data array are amplified or inverted (negative values), and by how much according to data in dbEnvelopeArray. This method allows to set individual amplification factors for an every individual sample in the audio data array.
Equalizer | Makes Equalizing in the selected part of an audio file.
Expander | Adds expander effect to the audio data array. The expander is essentially an amplifier with a variable gain control.
Fade | Creates a fading in (soft to loud) or fading out (loud to soft) effect in the selected part of an audio file. The wave data will be linearly faded from the starting magnitude AmplifyStart to the ending magnitude AmplifyEnd.
FFTFilter | Applies the Fast Fourier transform filter to the selected part of an audio file.
FIRFilter | Applies Finite Impulse Response filter to the selected part of an audio file.
Flanger | Applies Flanging effect to the selected part of an audio file.
InsertSilence | Inserts silence in an audio file.
Invert | Inverts the selected part of an audio file.
LowPassFilter | Applies Low Pass Filter to the selected part of an audio file.
LowShelfFilter | Applies Low Shelf Filter to the selected part of an audio file.
MixStereoChannels | Mixes stereo channels in the the selected part of an audio file.
Normalize | Normalizes the selected part of an audio file.
NotchFilter | Applies Notch Filter to the selected part of an audio file.
PeakEQFilter | Applies Peak EQ filter to the selected part of an audio file.
Phaser | Applies phasing effect to the selected part of an audio file.
PitchShift | Changes the frequency of the selected part of an audio file.
Resample | Decreases or increases the rate of the selected part of an audio file.
Reverb | Reverberates selected part of an audio file.
Reverse | Reverses the selected part of an audio file.
Silence | Makes silence in the selected part of an audio file.
SmoothEnabled | Gets or sets a flag indicating if smoothing is enabled or not.
SmoothTime | Gets or sets smooth time. Any applied effect has an abrupt transition on the edges of selected part. Smooth effect apply to this edges.
Stretch | Makes a Stretch effect in the selected part of an audio file.
TimeStretch | Stretches an selected part of an audio file by time.
Trim | Adds trim effect to the selected part of an audio file.
Undo | Reverses the last action on the waveform, such as applying different effects, filters and performing any editing operations.
Vibrato | Makes a Vibrato effect in the selected part of an audio file.


AddNoise method

AddNoise method

Inserts a noise in an audio file.

Syntax

object.AddNoise(Amplitude As Float, NoiseType As Long)

The AddNoise method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object of type .
Amplitude | Float | An amplitude of noise in db, from -92 db to 0.
NoiseType | Long | The noise type. 1- white noise, 2 - Gaussian noise.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

If a part of a file is selected then the signal is inserted instead the selected part, otherwise it is inserted to the current cursor position.

The Amplitude = -92 is equal to least noise signal, Amplitude = 0 is equal to most noise signal.

N db = 20 lg (Pn/P0)

N - number of db.
Pn - Level of sound pressure in pascals.
P0 = 2*105 pascals.

Example:

' VB sample where Editor1 is an AudioEditor2Transform object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.AddNoise -50, 1
Editor1.Save OutputFile, False
Editor1.Close

See Also:

Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


Amplify method

Amplify method

Applies Amplify effect to the selected part of an audio file. Changes amplitude of input audio file.

Syntax

object.Amplify(Amplify As Float)

The Amplify method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
Amplify | Float | An amplification coefficient in percent. If Amplify = 100, then audio array isn't changed. If Amplify > 100 then Volume of audio is increased, otherwise it is decreased.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

The method doesn't change amplitude at the first and last position of the audio array, if property SmoothEnabled is set to True.

Example:

' VB sample where Editor1 is an AudioEditor2Transform object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
If flag = True Then
Editor1.Transform.Amplify 120 'Amplify+
Else
Editor1.Transform.Amplify 40 'Amplify-
EndIf
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


BandPassFilter method

BandPassFilter method

Applies Band Pass filter to the selected part of an audio file.

Syntax

object.BandPassFilter(Frequency As Float, Steepness As Float)

The BandPassFilter method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
Frequency | Float | The central frequency of the filter, in Hertz.
Steepness | Float | Steepness of the filter, varies from 0.01 to 100.

Remarks:

The Band Pass filter consists in a Low Pass and a High Pass combined together, so it allows the frequencies falling within a certain range. The Band Pass filter will act like a Low Pass and a High Pass together: it will pass only the frequencies falling within a certain range.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.BandPassFilter Editor1.FileInfo.Frequency / 100, 100
Editor1.Save OutputFile, False
Editor1.Close

See Also:

FFTFilter | FIRFilter | HighPassFilter | HighShelfFilter | LowPassFilter | LowShelfFilter | NotchFilter | PeakEQFilter

Apples To: AudioEditor2Transform


Chorus method

Chorus method (AudioEditor2Transform object)

Applies chorus effect to the selected part of an audio file.

Syntax

object.Chorus(DelayRate As float, MixDepth As float, FeedBackGain As float, SweepDepth As float, SweepRate As float, SweepPhase As float)

The Chorus method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
DelayRate | float | Rate of delay. Varies from 0 (no delay) to 100 (20 ms delay).
MixDepth | float | The dry is the volume of the input signal and the wet is the volume of the delayed signal, in percent. Varies from 0 to 100. If MixDepth = 0 the resulting signal does not contain delayed signal. If MixDepth = 100 the resulting signal does not contain input signal. Other values of MixDepth are a combination of the dry and the wet (wet = 100 - dry).
FeedBackGain | float | FeedBackGain sets how much delay is fed back to the input. Varies from 0 to 100.
SweepDepth | float | The sweep depth determines how wide the sweep is in terms of delay time, in percent. Varies from 0 (no effect) to 100 (maximal effect).
SweepRate | float | This parameter refers to the frequency of flanging. Varies from 0 to 100, in percent.
SweepPhase | float | Phase of delay, in degrees.

Remarks:

The Chorus differs from the Flanger in only a couple of ways. One difference is the amount of delay that is used. The delay times in a Chorus are larger than in a Flanger, usually somewhere between 20 ms. and 30 ms. (the Flanger's delay usually ranges from 1 ms. to 10 ms.) This longer delay doesn't produce the characteristic sweeping sound of the Flanger. The Chorus also differs from the Flanger in that there is generally no feedback used.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

For more information about chorus effect see: http://www.harmony-central.com/Effects/Articles/Chorus/

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Chorus 50, 40, 2, 40, 100
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Applies to: AudioEditor2Transform

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


Compressor method

Compressor method

Reduces the dynamic range of a signal.

Syntax

object.Compressor(dbThreshold As Float, CompressionRate As Float, RMSTime As Float)

The Compressor method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
dbThreshold | Float | Certain level for threshold, in db. Varies from -92 to 0.
CompressionRate | Float | Rate of mixing signals, in percent. Varies from 1 (minimal effect) to 100 (maximal effect).
RMSTime | Float | Time for root-mean-square calculation, in ms. Usually RMSTime is equal to 100 ms.

Remarks:

N db = 20 lg (Pn/P0)

N - number of db.
Pn - Level of sound pressure in pascals.
P0 = 2*105 pascals.

A compressor is basically a variable gain device, where the amount of gain used depends on the level of the input. In this case, the gain will be reduced when the signal level is high which makes louder passages softer, reducing the dynamic range. This effect equals dynamic volume regulator.

This behavior is opposite to that of the Expander.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

For more information about compression effect see: http://www.harmony-central.com/Effects/Articles/Compression/

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Compressor -40, 50, 100
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


Delay method

Delay method

Makes a Delay effect in a selected part of an audio file.

Syntax

object.Delay(DelayTime As Float, MixDepth As Float, FeedBackGain As Float)

The Delay method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
DelayTime | Float | Delay time, in milliseconds.
MixDepth | Float | The dry is the volume of input signal and the wet is the volume of delayed signal, in percent. Varies from 0 to 100. If MixDepth = 0 result signal isn't contain delayed signal. If MixDepth = 100 result signal isn't contain input signal. Other values of MixDepth are combination of the dry and the wet (wet = 100 - dry).
FeedBackGain | Float | FeedBackGain sets how much delay is feed back to the input. Varies from 0 to 100.

Remarks:

Delay is an echo effect that replays what you have played one or more times after a period of time. It's something like the echoes you might hear shouting against a wall.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

For more information about delay effect see: http://www.harmony-central.com/Effects/Articles/Delay

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Delay 120, 85, 10
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


DeleteSilence method

DeleteSilence method

Deletes silence from the selected part of an audio file.

Syntax

object.DeleteSilence(dbThreshold As Float, AttackTime As Long, ReleaseTime As Long)

The DeleteSilence method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
dbThreshold | Float | Certain level for threshold, in db. Varies from -92 to 0.
AttackTime | Long | Time for volume increase, in ms. Usually the value of AttackTime property is much less than ReleaseTime.
ReleaseTime | Long | Time for volume decrease, in ms. Usually the value of AttackTime property is much less than ReleaseTime.

Remarks:

N db = 20 lg (Pn/P0)

N - number of db.
Pn - Level of sound pressure in pascals.
P0 = 2*105 pascals.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Following picture shows change of volume for this method.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.DeleteSilence 40, 1, 10
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


Envelope method

Envelope method

Gives you control over which parts of the audio data array are amplified or inverted (negative values), and by how much according to data in dbEnvelopeArray. This method allows to set individual amplification factors for an every individual sample in the audio data array.

Syntax

object.Envelope(dbEnvelopeArray As Float())

The Envelope method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
dbEnvelopeArray | Float() | The array of amplification factors.

Remarks:

The number of elements in the envelope array has to be equal to the amount of samples in the audio data array. If the size of the envelope array is less than the amount of samples in the audio data array, the Envelope method takes effect only on the first samples in the audio data array. Otherwise superfluous elements of the envelope array are not used.

You can assign any values to elements in the envelope array (amplification factors) according to the Float data type. Here are several examples and its effects:

Sample values of the amplification factor | Effect
2 | Represents 100% (normal) amplification
1 | Takes no effect
0.5 | Decreases the current sample value
0 | Represents full attenuation (silence)
-1 | Inverts the current sample value
-2 | Inverts and amplifies the current sample value to 100%

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
ReDim EnvelopeArray(1000)
For i = 0 To 999
    EnvelopeArray(i) = Sin(PI * i / 1000)
Next i
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Envelope EnvelopeArray()
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


Equalizer method

Equalizer method

Makes Equalizing in the selected part of an audio file.

Syntax

object.Equalizer(dbGainArray As Float(), FreqArray As Float())

The Equalizer method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
dbGainArray | Float() | Gain array in db. All values varies from -92 to 0.
FreqArray | Float() | Frequency array, in hertz.

Remarks:

N db = 20 lg (Pn/P0)

N - number of db.
Pn - Level of sound pressure in pascals.
P0 = 2*105 pascals.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Equalization (EQ) is the process of boosting or cutting certain frequency components in a signal.

For more information about equalizer effect see: http://www.harmony-central.com/Effects/Articles/Equalization/

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim dbGain(11) As Single
Dim Freq(11) As Single
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
For i = 0 To 11: dbGain(i) = -sldEQ(i).Value: Next i
For i = 0 To 11: Freq(i) = sldEQ(i).Tag: Next i
Editor1.Transform.Equalizer dbGain(), Freq()
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


Expander method

Expander method

Adds expander effect to the audio data array. The expander is essentially an amplifier with a variable gain control.

Syntax

object.Expander(dbThreshold As Float, ExpansionRate As Float, RMSTime As Float)

The Expander method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
dbThreshold | Float | Certain value for threshold, in db. Varies from -92 to 0.
ExpansionRate | Float | Rate of expansion. Varies from 1 (minimal effect) to 100 (maximal effect), in percent.
RMSTime | Float | Time for root-mean-square calculation, in ms. Usually RMSTime is equal to 100 ms.

Remarks:

N db = 20 lg (Pn/P0)

N - number of db.
Pn - Level of sound pressure in pascals.
P0 = 2*105 pascals.

The expander is a type of dynamic processor. As the name implies, it increases the dynamic range of a signal such that low level signals are attenuated while the louder portions are neither attenuated or amplified.

This behavior is opposite to that of the Compressor.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

For more information about expansion effect see: http://www.harmony-central.com/Effects/Articles/Expansion/

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Expander -50, 4, 100
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


Fade method

Fade method

Creates a fading in (soft to loud) or fading out (loud to soft) effect in the selected part of an audio file. The wave data will be linearly faded from the starting magnitude AmplifyStart to the ending magnitude AmplifyEnd.

Syntax

object.Fade(AmplifyLeft As Float, AmplifyRight As Float)

The Fade method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
AmplifyLeft | Float | Starting value percent, varies from 0 to 100.
AmplifyRight | Float | Ending value percent, varies from 0 to 100.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Fade 20, 40
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


FFTFilter method

FFTFilter method

Applies the Fast Fourier transform filter to the selected part of an audio file.

Syntax

object.FFTFilter(FFTArray As Float())

The FFTFilter method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
FFTArray | Float() | Fourier coefficients array.

Remarks:

Dimension of FFTArray can be only 22n+1, for example 211 = 2048, 215 = 32768 and so on.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim FFTArray() As Single
Dim i As Integer
For i = 0 To 128 '27
    FFTArray(i) = 10 ^ ((i ^ 2) / 20)
Next i
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.FFTFilter FFTArray()
Editor1.Save OutputFile, False
Editor1.Close

See Also:

FIRFilter | BandPassFilter | HighPassFilter | HighShelfFilter | LowPassFilter | LowShelfFilter | NotchFilter | PeakEQFilter

Apples To: AudioEditor2Transform


FIRFilter method

FIRFilter method (AudioEditor2Transform object)

Applies Finite Impulse Response filter to the selected part of an audio file.

Syntax

object.FIRFilter(FreqArray As Float(), dbGainArray As Float(), WeightArray As Float(), Quality As Long)

The FIRFilter method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
FreqArray | Float() | The array of the frequency values of the filter, each value is in hertz.
dbGainArray | Float() | The array of the gain values of the filter, each value is in db.
WeightArray | Float() | The array of the weight values of the filter.
Quality | Long | The quality of the filter. Varies from 0 (10 points) to 100 (256 points). The more points is the better filter quality and most time for calculating.

Remarks:

The dimensions of FreqArray, dbGainArray, WeightArray arrays are equal. The FreqArray and dbGainArray arrays determine profile of filtering.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Dim Freq(4) As Single
Dim dbGain(4) As Single
Dim Weight(4) As Single
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples

Freq(0) = 0
dbGain(0) = 1
Weight(0) = 1000

Freq(1) = 1000
dbGain(1) = 1
Weight(1) = 1000

Freq(2) = -1
dbGain(2) = -1
Weight(2) = -1

Freq(3) = 1100
dbGain(3) = 0
Weight(3) = 1000

Freq(4) = 22050
dbGain(4) = 0
Weight(4) = 1000

Editor1.Transform.FIRFilter Freq(), dbGain(), Weight(), 100
Editor1.Save OutputFile, False
Editor1.Close

See Also:

BandPassFilter | FFTFilter | HighPassFilter | HighShelfFilter | LowPassFilter | LowShelfFilter | NotchFilter | PeakEQFilter

Applies to: AudioEditor2Transform

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


Flanger method

Flanger method

Applies Flanging effect to the selected part of an audio file.

Syntax

object.Flanger(DelayRate As Float, MixDepth As Float, FeedBackGain As Float, SweepDepth As Float, SweepRate As Float, SweepPhase As Float)

The Flanger method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object of type .
DelayRate | Float | Rate of delay. Varies from 0 (there isn't delay) to 100 (delay is 20 ms).
MixDepth | Float | The dry is the volume of input signal and the wet is the volume of delayed signal, in percent. Varies from 0 to 100. If MixDepth = 0 result signal isn't contain delayed signal. If MixDepth = 100 result signal isn't contain input signal. Other values of MixDepth are combination of the dry and the wet (wet = 100 - dry).
FeedBackGain | Float | FeedBackGain sets how much delay is feed back to the input. Varies from 0 to 100.
SweepDepth | Float | The sweep depth determines how wide the sweep is in terms of delay time, in percent. Varies from 0 (no effect) to 100 (maximal effect).
SweepRate | Float | This parameter refers to the frequency of flanging. Varies from 0 to 100, in percent.
SweepPhase | Float | Phase of delay, in radian.

Remarks:

Flanging is created by mixing a signal with a slightly delayed copy of itself, where the length of the delay is constantly changing. It is actually one specific type of phasing (Phaser).

You can select a part of a file using the Selected property in the AudioEditor2Position object.

For more information about flanging effect see: http://www.harmony-central.com/Effects/Articles/Flanging

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Flanger 50, 30, 10, 50, 5
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


HighPassFilter method

HighPassFilter method

Applies High Pass Filter to the selected part of an audio file.

Syntax

object.HighPassFilter(Frequency As Float, Steepness As Float)

The HighPassFilter method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
Frequency | Float | The central frequency of the filter, in hertz.
Steepness | Float | Steepness of the filter, varies from 0.01 to 100.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
AudioEditor2Transform.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.HighPassFilter Editor1.FileInfo.Frequency / 100, 100
Editor1.Save OutputFile, False
Editor1.Close

See Also:

BandPassFilter | FIRFilter | FFTFilter | HighShelfFilter | LowPassFilter | LowShelfFilter | NotchFilter | PeakEQFilter

Apples To: AudioEditor2Transform


HighShelfFilter method

HighShelfFilter method

Applies High Shelf Filter to the selected part of an audio file.

Syntax

object.HighShelfFilter(Frequency As Float, dbGain As Float, Steepness As Float)

The HighShelfFilter method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
Frequency | Float | The central frequency of the filter, in hertz.
dbGain | Float | Gain in db. Varies from -92 to 0.
Steepness | Float | Steepness of the filter, varies from 0.01 to 100.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
AudioEditor2Transform.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.HighShelfFilter Editor1.FileInfo.Frequency / 100, -10, 100
Editor1.Save OutputFile, False
Editor1.Close

See Also:

BandPassFilter | FIRFilter | FFTFilter | HighPassFilter | LowPassFilter | LowShelfFilter | NotchFilter | PeakEQFilter

Apples To: AudioEditor2Transform


InsertSilence method

InsertSilence method

Inserts silence in an audio file.

Syntax

object.InsertSilence(Millisec As Long)

The InsertSilence method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
Millisec | Long | Duration of silence in milliseconds.

Remarks:

If a part of a file is selected then the signal is inserted instead of the selected part, otherwise it is inserted to the current cursor position.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 10
Editor1.Position.EndSelect = Editor1.Position.TotalSamples-10
Editor1.Transform.InsertSilence 444
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


Invert method

Invert method

Inverts the selected part of an audio file.

Syntax

object.Invert()

The Invert method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Invert
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


LowPassFilter method

LowPassFilter method

Applies Low Pass Filter to the selected part of an audio file.

Syntax

object.LowPassFilter(Frequency As Float, Steepness As Float)

The LowPassFilter method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
Frequency | Float | The central frequency of the filter, in hertz.
Steepness | Float | Steepness of the filter, varies from 0.01 to 100.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
AudioEditor2Transform.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.LowPassFilter Editor1.FileInfo.Frequency / 100, 100
Editor1.Save OutputFile, False
Editor1.Close

See Also:

BandPassFilter | FIRFilter | FFTFilter | HighPassFilter | HighShelfFilter | LowShelfFilter | NotchFilter | PeakEQFilter

Apples To: AudioEditor2Transform


LowShelfFilter method

LowShelfFilter method

Applies Low Shelf Filter to the selected part of an audio file.

Syntax

object.LowShelfFilter(Frequency As Float, dbGain As Float, Steepness As Float)

The LowShelfFilter method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
Frequency | Float | The central frequency of the filter, in hertz.
dbGain | Float | Gain in db. Varies from -92 to 0.
Steepness | Float | Steepness of the filter, varies from 0.01 to 100.

Remarks:

Low Shelf filter decreases volume of the higher frequencies and pass the lowest.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
AudioEditor2Transform.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.LowShelfFilter Editor1.FileInfo.Frequency / 100, -10, 100
Editor1.Save OutputFile, False
Editor1.Close

See Also:

BandPassFilter | FIRFilter | FFTFilter | HighPassFilter | HighShelfFilter | LowPassFilter | NotchFilter | PeakEQFilter

Apples To: AudioEditor2Transform


MixStereoChannels method

MixStereoChannels method

Mixes stereo channels in the the selected part of an audio file.

Syntax

object.MixStereoChannels(AmpLL As Float, AmpLR As Float, AmpRL As Float, AmpRR As Float)

The MixStereoChannels method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
AmpLL | Float | A percentage left channels time. Varies from 0 to 100.
AmpLR | Float | A percentage left and right channels time. Varies from 0 to 100.
AmpRL | Float | A percentage right and left channels time. Varies from 0 to 100.
AmpRR | Float | A percentage right channels time. Varies from 0 to 100.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.MixStereoChannels 30, 40, 30, 40
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


Normalize method

Normalize method

Normalizes the selected part of an audio file.

Syntax

object.Normalize(Normalization As Float, DCBiasAdjust As Boolean)

The Normalize method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
Normalization | Float | Normalization coefficient. Varies from 0 to 100. The percentage of maximum to which you want to normalize. For example, choose 50% to compute values needed to amplify the selection no more than 50% of maximum.
DCBiasAdjust | Boolean | Can be True (leveling) or False (not leveling). By default is True.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Amplifies the selection part to within the specified percentage of the maximum level.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Normalize 80, True
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


NotchFilter method

NotchFilter method

Applies Notch Filter to the selected part of an audio file.

Syntax

object.NotchFilter(Frequency As Float, Steepness As Float)

The NotchFilter method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
Frequency | Float | The central frequency of the filter, in hertz.
Steepness | Float | Steepness of the filter, varies from 0.01 to 100.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
AudioEditor2Transform.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.NotchFilter Editor1.FileInfo.Frequency / 100, 100
Editor1.Save OutputFile, False
Editor1.Close

See Also:

BandPassFilter | FIRFilter | FFTFilter | HighPassFilter | HighShelfFilter | LowPassFilter | LowShelfFilter | PeakEQFilter

Apples To: AudioEditor2Transform


PeakEQFilter method

PeakEQFilter method

Applies Peak EQ filter to the selected part of an audio file.

Syntax

object.PeakEQFilter(dbGain As Float, Frequency As Float, Steepness As Float)

The PeakEQFilter method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
dbGain | Float | Gain in db, from 0.01 to 92.
Frequency | Float | Central frequency of the filter, in hertz.
Steepness | Float | Steepness of the filter, from 0.01 to 100.

Remarks:

The Peak EQ filter decreases volume of the peaks.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
AudioEditor2Transform.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.PeakEQFilter 50, Editor1.FileInfo.Frequency / 100, 100
Editor1.Save OutputFile, False
Editor1.Close

See Also:

BandPassFilter | FIRFilter | FFTFilter | HighPassFilter | HighShelfFilter | LowPassFilter | LowShelfFilter | NotchFilter

Apples To: AudioEditor2Transform


Phaser method

Phaser method

Applies phasing effect to the selected part of an audio file.

Syntax

object.Phaser(DelayTime As Float, MixDepth As Float, FeedBackGain As Float)

The Phaser method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
DelayTime | Float | Delay time, in milliseconds.
MixDepth | Float | The dry is the volume of input signal and the wet is the volume of delayed signal, in percent. Varies from 0 to 100. If MixDepth = 0 result signal isn't contain delayed signal. If MixDepth = 100 result signal isn't contain input signal. Other values of MixDepth are combination of the dry and the wet (wet = 100 - dry).
FeedBackGain | Float | FeedBackGain sets how much delay is feed back to the input. Varies from 0 to 100.

Remarks:

The phaser achieves its distinctive sound by creating one or more notches in the frequency domain that eliminate sounds at the notch frequencies.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

For more information about expansion effect see: http://www.harmony-central.com/Effects/Articles/Phase_Shifting/

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Phaser 120, 30, 50
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


PitchShift method

PitchShift method (AudioEditor2Transform object)

Changes the frequency of the selected part of an audio file.

Syntax

object.PitchShift(Rate As float)

The PitchShift method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
Rate | float | Degree of frequency change.

Remarks:

For example, for the files with voice this method increases or decreases timbre of voice.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.PitchShift 150
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Applies to: AudioEditor2Transform

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


Resample method

Resample method (AudioEditor2Transform object)

Decreases or increases the rate of the selected part of an audio file.

Syntax

object.Resample(Rate As float)

The Resample method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
Rate | float | The percent of increase/decrease. Varies from 50 to 150. If Rate = 100 rate is not changed. If Rate < 100 rate is decreased, otherwise rate is increased.

Remarks:

Fastens of reduces the existing rate of the melody.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Resample 125
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Applies to: AudioEditor2Transform

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


Reverb method

Reverb method

Reverberates selected part of an audio file.

Return Type

A Boolean value.

Syntax

object.Reverb(DelayTime As Float, MixDepth As Float, FeedBackGain As Float, ReverbrationRate As Float)

The Reverb method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
DelayTime | Float | The delay time, in ms.
MixDepth | Float | The dry is the volume of input signal and the wet is the volume of delayed signal, in percent. Varies from 0 to 100. If MixDepth = 0 result signal isn't contain delayed signal. If MixDepth = 100 result signal isn't contain input signal. Other values of MixDepth are combination of the dry and the wet (wet = 100 - dry).
FeedBackGain | Float | The feedback sets how much delay is feed back to the input. Varies from 0 to 100.
ReverbrationRate | Float | Rate of reverberation. Varies from 0 (no effect) to 100 (maximum effect), in percent.

Remarks:

It is the sound you hear in a room with hard surfaces where sound bounces around the room for a while after the initial sound stops.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

For more information about flanging effect see: http://www.harmony-central.com/Effects/Articles/Reverb/

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Reverb 400, 30, 10, 50
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


Reverse method

Reverse method

Reverses the selected part of an audio file.

Syntax

object.Reverse()

The Reverse method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Reverse
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


Silence method

Silence method

Makes silence in the selected part of an audio file.

Syntax

object.Silence()

The Silence method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 10
Editor1.Position.EndSelect = Editor1.Position.TotalSamples-10
Editor1.Transform.Silence
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform


TimeStretch method

TimeStretch method (AudioEditor2Transform object)

Stretches an selected part of an audio file by time.

Syntax

object.TimeStretch(Rate As float)

The TimeStretch method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
Rate | float | The rate of the stretching

Remarks:

For example for the voice audio file the speech is increased or decreased without frequency changing.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.TimeStretch 150
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | Trim | Vibrato

Applies to: AudioEditor2Transform

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


Trim method

Trim method

Adds trim effect to the selected part of an audio file.

Syntax

object.Trim(dbTrimLevel As Float, FadeTime As Long, TrimParam As TrimConstants)

The Trim method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
dbTrimLevel | Float | Maximal amplitude in db, which is considered as silence, from -92 db to 0.
FadeTime | Long | Time of trim fade, in ms.
TrimParam | TrimConstants | Type of trim. Can be one of following types: trim from left, right or from both sides of trim level. By default TrimParam is equal to TRIM_BOTH.

Remarks:

N db = 20 lg (Pn/P0)

N - number of db.
Pn - Level of sound pressure in pascals.
P0 = 2*105 pascals.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Trim -20, 100, TRIM_RIGHT
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Vibrato

Apples To: AudioEditor2Transform


Vibrato method

Vibrato method

Makes a Vibrato effect in the selected part of an audio file.

Syntax

object.Vibrato(SweepDepth As Float, SweepFrequency As Float, SweepPhase As Float)

The Vibrato method syntax has these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
SweepDepth | Float | The depth of the vibrato effect, in percent. Varies from 0 (no effect) to 100 (maximal effect).
SweepFrequency | Float | The certain frequency of the vibrato effect, in hertz.
SweepPhase | Float | Phase of delay, in radian.

Remarks:

Vibrato equals a cyclical changing of certain frequency of input signal.

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Vibrato 40, 3, 0
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim

Apples To: AudioEditor2Transform


NCTAudioEditor2 Constants

Constants

Constants | Description
BitrateConstants | These are the constants for the IsFormatMpegAvailable, IsFormatOggVorbisAvailable, SetFormatMP2, SetFormatMP3, SetFormatOggVorbis methods (AudioEditor2FileFormat object) and Bitrate, VbrBitrate properties (AudioEditor2LameEnc object).
BitsPerSampleConstants | These are the constants for the SetFormatG723, SetFormatG726, SetFormatPCM, SetFormatRaw methods (AudioEditor2FileFormat object).
ChannelsConstants | These are the constants for the following methods and properties: SetFormatADPCM, SetFormatALAW, SetFormatULAW, SetFormatMP3, IsFormatMpegAvailable, VbrBitrate, Bitrate, SetFormatOggVorbis, IsFormatOggVorbisAvailable, SetFormatPCM, SetFormatPAW (AudioEditor2FileFormat object), Channels (AudioEditor2FileInfo), Channels (AudioEditor2LameEnc), New, ConvertSampleType. (AudioEditor2LameEnc object).
ErrorConstants | These are the constants for the LastErrorNum property (AudioEditor2 object).
FormatTypeConstants | These are the constants for the Save, Open methods (AudioEditor2 object).
FrequencyConstants | These are the constants for the following methods and properties: SetFormatADPCM, SetFormatALAW, SetFormatULAW, SetFormatMP3, IsFormatMpegAvailable, VbrBitrate, Bitrate, SetFormatOggVorbis, IsFormatOggVorbisAvailable, SetFormatGSM, SetFormatG721, SetFormatG723, SetFormatG726, SetFormatPCM, SetFormatPAW, SetFormatVOX (AudioEditor2FileFormat object), Frequency (AudioEditor2FileInfo), Frequency (AudioEditor2LameEnc), New, ConvertSampleType.
MousePointerConstants | These are the constants for the MousePointer property (AudioEditor2 object).
Mp3LameMethodConstants | These are the constants for the VbrCodingMethod property (AudioEditor2LameEnc object).
Mp3LameTypeStereoConstants | These are the constants for the TypeStereo property (AudioEditor2LameEnc object).
PlayTypeConstants | These are the constants for the Play method (AudioEditor2 object).
RawTypeCompressConstants | These are the constants for the SetFormatRaw property (AudioEditor2FileFormat object).
RecordTypeConstants | These are the constants for the Record method (AudioEditor2 object).
TrimConstants | These are the constants for the Trim method (AudioEditor2 object).
TypeViewConstants | These are the constants for the TypeView property (AudioEditor2 object).


BitrateConstants enumeration

BitrateConstants enumeration

These are the constants for the IsFormatMpegAvailable, IsFormatOggVorbisAvailable, SetFormatMP2, SetFormatMP3, SetFormatOggVorbis methods (AudioEditor2FileFormat object) and Bitrate, VbrBitrate properties (AudioEditor2LameEnc object).

Members

Constants | Value
BR_350_KBPS | 350
BR_320_KBPS | 320
BR_256_KBPS | 256
BR_224_KBPS | 224
BR_192_KBPS | 192
BR_160_KBPS | 160
BR_128_KBPS | 128
BR_112_KBPS | 112
BR_96_KBPS | 96
BR_80_KBPS | 80
BR_64_KBPS | 64
BR_56_KBPS | 56
BR_48_KBPS | 48
BR_40_KBPS | 40
BR_32_KBPS | 32
BR_24_KBPS | 24
BR_16_KBPS | 16
BR_8_KBPS | 8
BR_NONE | 0


BitsPerSampleConstants enumeration

BitsPerSampleConstants enumeration

These are the constants for the following methods: SetFormatG726, SetFrmatG723, SetFormatPCM, SetFormatPAW.

Members

Constants | Value | Description
BPS_2_BIT | 2 | 2 bits per sample.
BPS_3_BIT | 3 | 3 bits per sample.
BPS_4_BIT | 4 | 4 bits per sample.
BPS_5_BIT | 5 | 5 bits per sample.
BPS_8_BIT | 8 | 8 bits per sample.
BPS_16_BIT | 16 | 16 bits per sample.
BPS_24_BIT | 24 | 24 bits per sample.
BPS_32_BIT | 32 | 32 bits per sample.


ChannelsConstants enumeration

ChannelsConstants enumeration

These are the constants for the following methods and properties: SetFormatADPCM, SetFormatALAW, SetFormatULAW, SetFormatMP3, IsFormatMpegAvailable, VbrBitrate, Bitrate, SetFormatOggVorbis, IsFormatOggVorbisAvailable, SetFormatPCM, SetFormatPAW (AudioEditor2FileFormat object), Channels (AudioEditor2FileInfo), Channels (AudioEditor2LameEnc), New, ConvertSampleType. (AudioEditor2LameEnc object).

Members

Constants | Value | Description
MONO | 1 | Mono data uses one channel.
STEREO | 2 | Stereo data uses two channels.


ErrorConstants enumeration

ErrorConstants enumeration

These are the constants for the LastErrorNum property (AudioEditor2 object).

Members

Part | Value | Description
NOERRORS | 0 | No errors.
BUSY | -10 | It is impossible to execute the current method because the application is busy by another one.
MEMORY | -11 | Memory error.
FORMATFILE | -12 | Wrong file format. It is an attempt to open a non-audio file as an audio file.
FORMATNOTSUPPORT | -13 | Unsupported audio file format. It is an attempt to open an unsupported audio file format.
OUTDRIVER | -14 | Output audio device error. For example: wrong device, audio device is already opened in your application or is in use by another one and many others… It hardly depends on hardware.
INPDRIVER | -15 | Input audio device error. . For example: wrong device, audio device is already opened in your application or is in use by another one and many others… It hardly depends on hardware.
MIXERDRIVER | -16 | Mixer device driver error.
ACMDRIVER | -17 | ACM driver error.
FILEACCESS | -18 | The specified file is already in use.
INVALIDOPERATION | -19 | Invalid operation. For example, you try to execute READ method before OPEN method.
INVALIDPARAM | -20 | Invalid parameters. You try to execute a method with invalid parameters.
ASPIDRIVER | -21 | Incorrect CD driver operation. ASPI driver returns an error.
CONTROLNOTINSTALLED | -22 | Control not installed.
INDEXOUTOFRANGE | -23 | Incorrect address to the array. Index out of the array range.
STREAM | -24 |
UNEXPECTED | -40 | Unexpected error.


FormatTypeConstants enumeration

FormatTypeConstants enumeration

These are the constants for the following methods: Save, Open.

Members

Constants | Value
DEFAULT | 0
WAV | 1
MP3 | 2
VOX | 3
RAW | 4
G726 | 5
OGG | 6
G721 | 7
G723 | 8
AVI | 9
MPC | 10
WMA | 11
MP2 | 12


FrequencyConstants enumeration

FrequencyConstants enumeration

These are the constants for the following methods and properties: SetFormatADPCM, SetFormatALAW, SetFormatULAW, SetFormatMP3, IsFormatMpegAvailable, VbrBitrate, Bitrate, SetFormatOggVorbis, IsFormatOggVorbisAvailable, SetFormatGSM, SetFormatG721, SetFormatG723, SetFormatG726, SetFormatPCM, SetFormatPAW, SetFormatVOX (AudioEditor2FileFormat object), Frequency (AudioEditor2FileInfo), Frequency (AudioEditor2LameEnc), New, ConvertSampleType.

Members

Constants | Value | Description
FQ_96_KHZ | 96000 | 96000 hertz.
FQ_88_KHZ | 88200 | 88200 hertz.
FQ_48_KHZ | 48000 | 48000 hertz.
FQ_44_KHZ | 44100 | 44100 hertz.
FQ_32_KHZ | 32000 | 32000 hertz.
FQ_24_KHZ | 24000 | 24000 hertz.
FQ_22_KHZ | 22050 | 22050 hertz.
FQ_16_KHZ | 16000 | 16000 hertz.
FQ_12_KHZ | 12000 | 12000 hertz.
FQ_11_KHZ | 11025 | 11025 hertz.
FQ_8_KHZ | 8000 | 8000 hertz.
FQ_6_KHZ | 6000 | 6000 hertz.


MousePointerConstants enumeration

MousePointerConstants enumeration

These are the constants for the MousePointer property.

Members

Constants | Value
vbDefault | 0
vbArrow | 1
vbCrosshair | 2
vbIbeam | 3
vbIconPointer | 4
vbSizePointer | 5
vbSizeNESW | 6
vbSizeNS | 7
vbSizeNWSE | 8
vbSizeWE | 9
vbUpArrow | 10
vbHourglass | 11
vbNoDrop | 12
vbArrowHourglass | 13
vbArrowQuestion | 14
vbSizeAll | 15
vbCustom | 99


Mp3LameMethodConstants enumeration

Mp3LameMethodConstants enumeration

If is constants for the VbrCodingMethod property.

Members

Constants | Value
VBR_NONE | -1
VBR_DEFAULT | 0
VBR_OLD | 1
VBR_NEW | 2
VBR_MTRH | 3
VBR_ABR | 4


Mp3LameTypeStereoConstants enumeration

Mp3LameTypeStereoConstants enumeration

If is constants for the TypeStereo property.

Members

Constants | Value | Description
SIMPLY | 1 | No uses of potentially existing correlations between the two input channels.
JOINTSTEREO | 2 | Uses of a correlation between both channels.
FORCEDJOINTSTEREO | 3 | Forces MS joint stereo on all frames.
DUALCHANNEL | 4 | The two channels will be totally independently encoded.


PlayTypeConstants enumeration

PlayTypeConstants enumeration

These are the constants for the Play method.

Members

Constants | Value | Description
NORMALPLAY | 1 | Play from the begin of selected part to the end of selected part.
PLAYTOEND | 2 | Play from the begin of selected part to the end of current audio file.
PLAYLOOPED | 3 | Cyclical play of the selected part.


RawTypeCompressConstants enumeration

RawTypeCompressConstants enumeration

These are the constants for the SetFormatRaw property (AudioEditor2FileFormat object).

Members

Constants | Value
PCM | 1
ALAW | 2
ULAW | 3
GSM | 4
IMA_ADPCM | 5
MS_ADPCM | 6


RecordTypeConstants enumeration

RecordTypeConstants enumeration

These are the constants for the Record method.

Members

Constants | Value | Description
RECORD_CLEAR | 1 | Clear old data before recording new data.
RECORD_MIX | 2 | Mix old and new data.


TrimConstants enumeration

TrimConstants enumeration

These are the constants for the Trim method.

Members

Constants | Value | Description
TRIM_LEFT | 0 | Trim from left side of trim level.
TRIM_RIGHT | 1 | Trim from right side of trim level.
TRIM_BOTH | 2 | Trim from both sides of the trim level.


TypeViewConstants enumeration

TypeViewConstants enumeration

These are the constants for the TypeView property.

Members

Part | Value | Description
WAVEFORM | 0 | Shape of analog signal.
SPECTRAL | 1 | Shape of spectrum.
EXPANDED | 2 | This value is created for future use.

Send Feedback on the NCTAudioEditor2 documentation.
NCTAudioEditor2 was developed by NCT company http://www.nctsoft.com


Filters information

Cookbook formulae for audio EQ biquad filter coefficients

All filter transfer functions were derived from analog prototypes (that
are shown below for each EQ filter type) and had been digitized using the
Bilinear Transform. BLT frequency warping has been taken into account
for both significant frequency relocation and for bandwidth readjustment.

First, given a biquad transfer function defined as:

b0 + b1*z^-1 + b2*z^-2
H(z) =
a0 + a1*z^-1 + a2*z^-2

This shows 6 coefficients instead of 5 so, depending on your architecture,
you will likely normalize a0 to be 1 and perhaps also b0 to 1 (and collect
that into an overall gain coefficient). Then your transfer function would
look like:

(b0/a0) + (b1/a0)*z^-1 + (b2/a0)*z^-2
H(z) =
1 + (a1/a0)*z^-1 + (a2/a0)*z^-2

or

1 + (b1/b0)*z^-1 + (b2/b0)*z^-2
H(z) = (b0/a0) *
1 + (a1/a0)*z^-1 + (a2/a0)*z^-2

The most straight forward implementation would be the Direct I form (second equation):

y[n] = (b0/a0)*x[n] + (b1/a0)*x[n-1] + (b2/a0)*x[n-2] - (a1/a0)*y[n-1] - (a2/a0)*y[n-2]

This is probably both the best and the easiest method to implement in the 56K.

Now, given:

sampleRate (the sampling frequency)

frequency ("wherever it's happenin', man." "center" frequency
or "corner" (-3 dB) frequency, or shelf midpoint frequency,
depending on which filter type)

dBgain (used only for peaking and shelving filters)

bandwidth in octaves (between -3 dB frequencies for BPF and notch
or between midpoint (dBgain/2) gain frequencies for peaking EQ)

_or_ Q (the Electrical Engineering kind of definition)

_or_ S, a "shelf slope" parameter (for shelving EQ only). when S = 1,
the shelf slope is as steep as it can be and remain monotonically
increasing or decreasing gain with frequency.

First compute a few intermediate variables:

A = sqrt[ 10^(dBgain/20) ]
= 10^(dBgain/40) (for peaking and shelving EQ filters only)

omega = 2*PI*frequency/sampleRate

sin = sin(omega)
cos = cos(omega)

alpha = sin/(2*Q) (if Q is specified)
= sin*sinh[ ln(2)/2 * bandwidth * omega/sin ] (if bandwidth is specified)

beta = sqrt[ (A^2 + 1)/S - (A-1)^2 ] (for shelving EQ filters only)

Then compute the coefs for whichever filter type you want:

The analog prototypes are shown for normalized frequency.
The bilinear transform substitutes:

1 1 - z^-1
s <- *
tan(omega/2) 1 + z^-1

LPF: H(s) = 1 / (s2 + s/Q + 1)

b0 = (1 - cos)/2
b1 = 1 - cos
b2 = (1 - cos)/2
a0 = 1 + alpha
a1 = -2*cos
a2 = 1 - alpha

HPF: H(s) = s2 / (s2 + s/Q + 1)

b0 = (1 + cos)/2
b1 = -(1 + cos)
b2 = (1 + cos)/2
a0 = 1 + alpha
a1 = -2*cos
a2 = 1 - alpha

BPF (constant skirt gain): H(s) = s / (s2 + s/Q + 1)

b0 = Q*alpha
b1 = 0
b2 = -Q*alpha
a0 = 1 + alpha
a1 = -2*cos
a2 = 1 - alpha

BPF (constant peak gain): H(s) = (s/Q) / (s2 + s/Q + 1)

b0 = alpha
b1 = 0
b2 = -alpha
a0 = 1 + alpha
a1 = -2*cos
a2 = 1 - alpha

Notch: H(s) = (s2 + 1) / (s2 + s/Q + 1)

b0 = 1
b1 = -2*cos
b2 = 1
a0 = 1 + alpha
a1 = -2*cos
a2 = 1 - alpha

PeakingEQ: H(s) = (s2 + s*(A/Q) + 1) / (s2 + s/(A*Q) + 1)

b0 = 1 + alpha*A
b1 = -2*cos
b2 = 1 - alpha*A
a0 = 1 + alpha/A
a1 = -2*cos
a2 = 1 - alpha/A

LowShelf: H(s) = A * (s2 + beta*s + A) / (A*s2 + beta*s + 1)

b0 = A*[ (A+1) - (A-1)*cos + beta*sin ]
b1 = 2*A*[ (A-1) - (A+1)*cos ]
b2 = A*[ (A+1) - (A-1)*cos - beta*sin ]
a0 = (A+1) + (A-1)*cos + beta*sin
a1 = -2*[ (A-1) + (A+1)*cos ]
a2 = (A+1) + (A-1)*cos - beta*sin

HighShelf: H(s) = A * (A*s2 + beta*s + 1) / (s2 + beta*s + A)

b0 = A*[ (A+1) + (A-1)*cos + beta*sin ]
b1 = -2*A*[ (A-1) + (A+1)*cos ]
b2 = A*[ (A+1) + (A-1)*cos - beta*sin ]
a0 = (A+1) - (A-1)*cos + beta*sin
a1 = 2*[ (A-1) - (A+1)*cos ]
a2 = (A+1) - (A-1)*cos - beta*sin


Mouse

Operations with mouse

Four following operations with mouse is possible.

The user releases the left mouse button:

  1. in the marker's area (cursor is the "tick"), near marker. Then StartSelect and CurrentPosition properties from AudioEditor2Position interface is set in accordance with marker. If the marker pick out any area then EndSelect and Selected properties from AudioEditor2Position interface is set in accordance with marker too.

  2. in the stereo channels area (cursor is the "L" or "R"). One of stereo channels is pick out and all operation not doing on the another channel. It is not work for the mono files.

  3. in the any waveform area. Current position is changed.

The user twice clicks the left mouse button in the marker's area:

  1. If cursor be situated near current marker position current marker position is added, otherwise - current cursor position is added like a marker position.

  2. Cursor points to the marker. Marker is deleted.

The user releases the right mouse button:

  1. in the any waveform area. Current area is pick out. The nearest bound is moved to the current cursor position.

  2. in the stereo channels area (cursor is the "L" or "R"). One of stereo channels is pick out and all operation not doing on the another channel. It is not work for the mono files.

The user moves the mouse with clamped left mouse button:

  1. in the any waveform area. Current position is pick out. Near the border of early detailed area the type of cursor is changed and user can decrease or increase dimension of current detailed area.

  2. in the stereo channels area (cursor is the "L" or "R"). One of stereo channels is pick out and all operation not doing on the another channel. It is not work for the mono files.

  3. in the Zoom area. It equals to rolling of waveform if ZoomIn operation is used or one of following properties is changed before: StartView, EndView from AudioEditor2Position interface.


Genre

Audio file genres

Value | Description
00 | Blues
01 | Classic Rock
02 | Country
03 | Dance
04 | Disco
05 | Funk
06 | Grunge
07 | Hip-Hop
08 | Jazz
09 | Metal
10 | New Age
11 | Oldies
12 | Other
13 | Pop
14 | R&B
15 | Rap
16 | Reggae
17 | Rock
18 | Techno
19 | Industrial
20 | Alternative
21 | Ska
22 | Death Metal
23 | Pranks
24 | Soundtrack
25 | Euro-Techno
26 | Ambient
27 | Trip-Hop
28 | Vocal
29 | Jazz+Funk
30 | Fusion
31 | Trance
32 | Classical
33 | Instrumental
34 | Acid
35 | House
36 | Game
37 | Sound Clip
38 | Gospel
39 | Noise
40 | Alternative Rock
41 | Bass
42 | Soul
43 | Punk
44 | Space
45 | Meditative
46 | Instrumental Pop
47 | Instrumental Rock
48 | Ethnic
49 | Gothic
50 | Darkwave
51 | Techno-Industrial
52 | Electronic
53 | Pop-Folk
54 | Eurodance
55 | Dream
56 | Southern Rock
57 | Comedy
58 | Cult
59 | Gangsta
60 | Top 40
61 | Christian Rap
62 | Pop/Funk
63 | Jungle
64 | Native US
65 | Cabaret
66 | New Wave
67 | Psychedelic
68 | Rave
69 | Showtunes
70 | Trailer
71 | Lo-Fi
72 | Tribal
73 | Acid Punk
74 | Acid Jazz
75 | Polka
76 | Retro
77 | Musical
78 | Rock & Roll
79 | Hard Rock
80 | Folk
81 | Folk-Rock
82 | National Folk
83 | Swing
84 | Fast Fusion
85 | Bebop
86 | Latin
87 | Revival
88 | Celtic
89 | Bluegrass
90 | Avant-garde
91 | Gothic Rock
92 | Progressive Rock
93 | Psychedelic Rock
94 | Symphonic Rock
95 | Slow Rock
96 | Big Band
97 | Chorus
98 | Easy Listening
99 | Acoustic
100 | Humor
101 | Speech
102 | Chanson
103 | Opera
104 | Chamber Music
105 | Sonata
106 | Symphony
107 | Booty Bass
108 | Primus
109 | Porn Groove
110 | Satire
111 | Slow Jam
112 | Club
113 | Tango
114 | Samba
115 | Folklore
116 | Ballad
117 | Power Ballad
118 | Rhythmic Soul
119 | Freestyle
120 | Duet
121 | Punk Rock
122 | Drum Solo
123 | A capella
124 | Euro-House
125 | Dance Hall
126 | Goa
127 | Drum & Bass
128 | Club-House
129 | Hardcore
130 | Terror
131 | Indie
132 | Britpop
133 | Negerpunk
134 | Polsk Punk
135 | Beat
136 | Christian Gangsta
137 | Heavy Metal
138 | Black Metal
139 | Crossover
140 | Contemporary C
141 | Christian Rock
142 | Merengue
143 | Salsa
144 | Thrash Metal
145 | Anime
146 | JPop
147 | SynthPop


System requirements

System requirements
System requirements:

  • Windows 98/Me/NT/2000/XP;

  • A sound card;

  • A microphone (optional);

  • MS Visual Basic 6.0 or MS VC++ 6.0 (SP5).

Installation

You must registry NCTAudioEditor2 ActiveX DLL in the Microsoft Windows system using Microsoft register server. For example:

regsvr32 NCTAudioEditor2.dll

The path to the NCTAudioEditor2.dll file must be included in registration command string. For example:

C:\Program Files\NCTAudioEditor2\regsvr32 NCTAudioEditor2.dll


Stretch method

Stretch method

Makes a Stretch effect in the selected part of an audio file.

Syntax

object.Stretch(Percent As Float)

The Stretch method syntax consists of these parts:

Part | Type | Description
object | AudioEditor2Transform | An expression evaluating to an object.
Percent | Float | The percent of stretching. We recommend to set this value from 50 to 150.

Remarks:

You can select a part of a file using the Selected property in the AudioEditor2Position object.

Example:

' VB sample where Editor1 is an AudioEditor2 object.
Editor1.Open InputFile
Editor1.Position.Selected = True
Editor1.Position.StartSelect = 0
Editor1.Position.EndSelect = Editor1.Position.TotalSamples
Editor1.Transform.Stretch 88
Editor1.Save OutputFile, False
Editor1.Close

See Also:

AddNoise | Amplify | Chorus | Compressor | Delay | DeleteSilence | Envelope | Equalizer | Expander | Fade | Flanger | InsertSilence | Invert | MixStereoChannels | Normalize | Phaser | PitchShift | Resample | Reverb | Reverse | Silence | TimeStretch | Trim | Vibrato

Apples To: AudioEditor2Transform